Page 1 of 3
#1 PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 08.04.2021 18:46

avatar

mrplamp
Hi All,

I hope you all are well. I wanted to give some feedback and ask for assistance with regards to having both my gpu and m.2 operational at the same.

Thanks @Fernando for all the help.

It seems that my rev 1.1 ga-z77m-dh3 mATX motherboard has a pcie link for the pxie 3.0 x16 and the pciex4 (2.0) which causes the issue when using both these slots at the same time due to the auto enabled crossfire pcie link which links both the slots when they are used by an amd VGA.
It's been literal hell wasting hours on this only to realize its something else. I have now gone through many intel 7 series, DMI and intel fdgma forums / docs.

I wanted to find out what would it take to have the entire pciex4 running through the chipset and having the gpu running at x16 pcie 3.0.

It seems like i need to do changes on my intel RCSsetup, however this may still link the two pcie slots due to the crossfire ability being actively applied whenever any amd VGA is on either slot. I only have two R9380s to test / make it work with.

Does anyone know how to delink the two pcie slots and completely remove crossfire from bios so that i have two independent slots which do not look for a master slave due to enable pcie linking?

Thanks in advance, Any suggestions / help is appreciated!

#2 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 08.04.2021 20:12

avatar

Nothing to do with AMD Crossfire, simple Z77 boards do what what the chipset is meant to do, divide PCie bandwidth,
its the same using multiple pcie cards, doesn't matter if GPU or any other, the bus bandwidth will be divided by the lanes.
U will see different bandwidth allocations for example in motherboard with embedded PLX add on controller

#3 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 09.04.2021 11:46

avatar

@MeatWar thank you,

Would you have any idea why would i not be able to get GPU display when the pcie adaptor is in ? I can use the m.2 drive in either pcie slot without the gpu without issues. I can also use the gpu without the m.2 drive without any issues but not both together.

#4 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 09.04.2021 14:23

avatar

So the only option not tried is GPU on bottom slot and PCIe M.2 on top slot...
There are many M.2 PCIe adaptors models around... u dont expect that all work as intended in all kind of models of motherboards... compatibility ring a bell???
Assuming that bios is updated...GPU card supports UEFI, my only option is to state that ur M.2 adaptor is the issue.
Sandy Bridge (PCIe 2.0) or Ivy Bridge (PCIe 3.0) cpu, i will not pointed here as an issue...but who knows.
99% of common M.2 adaptors around uses PCIe 2.0 x4.
Ur bottom PCIe is 2.0 not a full PCIe 3.0 as the top, this is standard design and its not intended to work as PCIe 3.0 in ur motherboard or others with same design.

#5 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 09.04.2021 17:08

avatar

Thank you profusely Mr @MeatWar . Your no nonsense attitude is telling me my issue is not what i thought it was.

The M.2 is pcie 2.0 compatible as it works on the pciex4 @ 2.0 x4 speeds.

I will check on the UIEFI VGA issue as i believe there is a disconnect only when selecting win8 WHQL( which is the only way the mobo picks up the pata) and having the m.2 adaptor inserted.

Do you think it could be something to do with IRQ sharing as they are on the same IRQ11 interrupt?

#6 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 09.04.2021 17:49

avatar

The M.2 is compatible... what im saying is that could not be compatible with ur actual hw devices and allocated resources by them.
Thats why u can see it working in different configurations but not in the one what u want
Presuming that u have a mod bios for NVMe boot, Win8 WHQL is not necessary and u dont need to see PATA, the only demand is PURE UEFI boot, secure boot off for installation, Other OS (NO Win8WHQL)
The system will engage EFI GOP boot and upon OS setup (Destination stage) it will see the NVMe ssd, even if its not present till this stage.
Final test for u test another M.2 adaptor, good luck.

#7 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 09.04.2021 17:53

avatar

@MeatWar thanks for taking the time to help remove my ignorance's. Much appreciated!

Hopefully this is my weekend at this, il do those tests tomorrow probably after some sleep. Will let you know!

#8 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 03.05.2021 14:46

avatar

Hi @MeatWar ,

I am here to report back and tell you that i have now given up as i have had too many instances where even getting my vanilla PC to display without anything else has become a common theme and i get scared it is broken ( happened 3 times now(yes even with clear cmos's and ram changes)) :'( honestly bro since my first post back in march i've wasted 90% of weekends and time off i had to get this bi#% working, alas life is sometimes cruel if youre swimming in a brand new ocean. I decided to get an m.2 to sata but it bugs me to have wasted this much time for naught but EFI fresh boot and clean driver packages.

Ok so this is what i know so far:
there is no post immediately after connecting the adapter in any mode besides win8WHQL ??
I tried it with all other settings but to no avail.
You can enable/disable csm and it will still work in win8WQL , secure is off, everything else is UEFI only
Both PCIE slots are on INTA# interrupt pin with the main buses being both on IRQ11.
I believe I need to change this interrupt line to something safe and enable DMI for my pcie bus2 (x4). I went through Ms documents on how to enable VT-d dmi devices but i was unable to do anything but set somethings for my pcie ethernet controller which is on bus 5 and on another IRQ.
I also tried to update the smbios/acpi after finding specific code for it open github but i cannot figure out how to use the smbios .asl tools.
My smbios is 2.7 with the bios at version 4.7 when viewed in hwinfo and the DMI at version 2.1 on hw/info yet the chipset version is 2.7

I believe the setting i found using APTIO IV 4.6 last night ( finally figured out how to open my bios in this mode)

I found that under miscellaneous bios setting which has the only pcie settings for Gen1,Gen2,Gen3 or auto there is a setting for isynchronous support for Vc0/VC1 was enabled in both default and optimal and was set to 'show in bios' but it is hidden in bios.

I am thinking if disable this it might assist me in delinking my pcie slots and then allow the system to auto config gen 3 16 at the top and gen 2 x4 at the bottom?

Here's an unintentional screenshot of the adaptor operational without gpu in the main slot (gpu disables as soon as i insert m.2 adaptor - no fan spin only lights)
https://imgur.com/3K6vfQE

Please let me know what info i can dump for anyone, i am fed up with myself , i really coulda broken my shit many times especially with my old psu having some sort of shortage for an entire night.

#9 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 03.05.2021 14:59

avatar

Really not seeing the issue in ur case...other factors for sure r implicated in ur problem.
This mod is so easy and successful in almost 99% of motherboards models (AMI Aptio IV UEFI)
>Here< a successful report of a user (Same motherboard as u) who tried the Z97 modules and after all, the simple module that Fernando offers gave him a surprise...worked like a charm.

#10 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 03.05.2021 15:08

avatar

Thank you for your alternate solution @MeatWar Sir! i really appreciate it.

I will go through it soon as i am onboard with you on not knowing what could be the issue for this simple PCH7 resource and DMI allocation!

I am hoping and praying that the Z97 modules are better then the nvmesmall.dxe and are able to allow both pcie devices to operate simultaneously at advertised speeds!

Will try it later when im home. muccch <3

#11 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 03.05.2021 16:17

avatar

@MeatWar have been going through his post and solution seems as you said- it just happened with the standard nvme.dxe .

Do you think if i manage to make a plan somehow to insert the large nvme.dxe instead of the small , that it could make any difference?

I think im going to redo the bios mod with the large file somehow if you think it could make a diff, if not i'll try the z97 hotfix. I'm dreading touching anything after its back together, but with your support i will keep going.

#12 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 03.05.2021 16:38

avatar

Just to clarified ... i did not said that using the modules of a Z97 motherboard resolves ur issue... it works but as u can see in that user report, the single module from Fernando was the solution.
The use of the standard nvme dxe module can be insert AS IS or COMPRESSED...of course that AS IS (Uncompressed is a better option) whenever the space volume permits.
Some users can increase the available space volume, removing any DXE Driver, which your specific system doesn't need/use, from the related Volume.
Ex: Unless you want to use the "Wake-On-LAN" feature, the module name Ip6Dxe would be a good candidate

Resuming, Fernando NVMe DXE driver module is always advisable, against extracted Z97 modules.

EDIT: There is no difference between modules regarding functionality (Regular or Small)

#13 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 03.05.2021 16:57

avatar

Thanks for clearing that up!

I am thinking the same thing,make some space and try the uncompressed nvme.dxe volume.

Would you know if there is a difference between the small.dxe or the normal .dxe besides maybe space ?

Thanks @MeatWar ! you give me hope and direction ! a Good day to you Sir!

#14 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by mrplamp 17.05.2021 19:49

avatar

Reporting back bros:

-deleted ip6dxe
-full dxe has been inserted <3
-haven't tried it as yet, will do when im more sobered(was up all night, will break the pc if i got to do a cmos right now)
-Went crazy in AMIBCP4.55 wanted to ask the masters @MeatWar opinion: https://imgur.com/a/rcKpLqY
-Also saved hwinfo.txt since only one thing is running on dmi-intel 82801CA I/O Controller Hub 3-S (ICH3-S) [B-0]

Links:
-bios's and hwinfo.log :https://mega.nz/fm/fQpjVCwQ
-Hwinfo Screenies : https://imgur.com/m6P5WXc
-IRQ table: https://imgur.com/hAdS3Rk
-Start of amateur gone wild on AMIBCP4.55 : https://imgur.com/ZxHnNVu.

I suspect the following Pcie x4 Bus 2# [J6B1] to be sharing the same IRQpin (INTA#) and Interrupt (IRQ11).
This conflict not allow for required additional lanes needed to run the m.2 to pcie adapter @ PCIE 2.0 x4 via the PCH DMI? Please advise bros..


Lastly someone please tell me i don't have to do the - MS Enabling DMA remapping for device drivers :https://docs.microsoft.com/en-us/windows...rts%20(e.g.%20M.

its so much learning............

Hwinfo for Intel Panther Point PCH - PCI Express Port 1:

pcie General Information
Device Name: Intel Panther Point PCH - PCI Express Port 1
Original Device Name: Intel Panther Point PCH - PCI Express Port 1
Device Class: PCI-to-PCI Bridge
Revision ID: C4
PCI Address (Bus:Device:Function) Number: 0:28:0
PCI Latency Timer: 0
Hardware ID: PCI\VEN_8086&DEV_1E10&SUBSYS_00000000&REV_C4

PCI Express
Version: 2.0
Maximum Link Width: 4x
Current Link Width: Not negotiated
Maximum Link Speed: 5.0 GT/s
Current Link Speed: 2.5 GT/s
Device/Port Type: Root Port of PCI Express Root Complex
Slot Implemented: Yes
Hot-Plug: Not Capable
Hot-Plug Surprise: Not Capable
Slot Power Limit: 25.000 W
Emergency Power Reduction: Not Supported
Active State Power Management (ASPM) Support: None
Active State Power Management (ASPM) Status: Disabled
L0s Exit Latency: 512 ns - 1 us
L1 Exit Latency: 8 - 16 us
Maximum Payload Size Supported: 128 bytes
Maximum Payload Size: 128 bytes
Resizable BAR Support: Not Supported

System Resources
Interrupt Line: IRQ11
Interrupt Pin: INTA#

Features
Bus Mastering: Enabled
Running At 66 MHz: Not Capable
Fast Back-to-Back Transactions: Not Capable

Driver Information
Driver Manufacturer: INTEL
Driver Description: Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 1 - 1E10
Driver Provider: INTEL
Driver Version: 10.1.3.1
DeviceInstanceId PCI\VEN_8086&DEV_1E10&SUBSYS_50011458&REV_C4\3&11583659&0&E0
Location Paths PCIROOT(0)#PCI(1C00)


-
much <3

#15 RE: PCIe bifurcation/ delinking - GA-Z77m-d3h by MeatWar 17.05.2021 20:56

avatar

Only thing to add to ur adventures, is related to ME (ur linked picture) that can be updated to the latest version described
here with the 8.1.70.1590
All the rest is ur risk to adventure urself, raising the stakes of bios break.
Good luck.

Xobor Forum Software von Xobor
Datenschutz