#1 Request for help modifying BIOS to use PCIE GEN 3 first by miku1958 28.03.2021 16:03

I am using AMIBCP 5.02.0031 to modify ASUS B550-i's BIOS, forcing PCIEX16 MODE to use GEN 3, here is what I did:


But it doesn't work after I flashback it to the motherboard, and the default value of this option is still ‘auto’.

Can anyone please help me?

Update: I can see two setupData in MMTool, is that the bios file contains 2 diffent image but AMIBCP can only modify the first one?

#2 RE: asus b550-i modified BIOS is not working by miku1958 26.06.2021 09:41

Any one help!!!?

I try to edit the order of these options in setup datas with UEFITool, replace and extract again to make sure it's ifr is Gen 3 first:
0x4A524 Setting: PCIEX16 Mode, Variable: 0x175 {05 91 6A 0E 6B 0E 65 01 01 00 75 01 10 10 00 04 00}
0x4A535 Option: GEN 3, Value: 0x3 {09 07 68 0E 00 00 03}
0x4A53C Option: GEN 1, Value: 0x1 {09 07 66 0E 00 00 01}
0x4A543 Option: GEN 2, Value: 0x2 {09 07 67 0E 00 00 02}
0x4A54A Option: Auto, Value: 0x0 {09 07 05 00 30 00 00}
but it didn't work either

I'm so desperate that I don't have the tools on hand to disassemble the computer and insert the graphics card straight into the motherboard

#3 RE: asus b550-i modified BIOS is not working by canpi 17.09.2021 12:05

I have the same problem as you, and there is no option to adjust pcie gen in my AMIBCP, but I tried to shield part of the pcie channel of the graphics card to x8 with tape, the driver problem is solved, I hope I can help you

Xobor Forum Software von Xobor
Datenschutz