Page 6 of 15
#76 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by lasergungamer 29.07.2020 11:25

@Lost_N_BIOS well, if you say so lol

https://www.dropbox.com/s/ktdx4qjw41zit3u/BACKUP10.ROM?dl=0

#77 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 30.07.2020 05:39

avatar

@lasergungamer - Here you go - http://s000.tinyupload.com/index.php?fil...568302323278310

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don't try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

*** WARNING *** - This BIOS is user specific! If you are not user lasergungamer at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not lasergungamer, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

#78 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by drmotile 31.07.2020 04:17

Hello @Lost_N_BIOS,

I also have a request for you if you can spare some time for me.

I have the same motile laptop M142.

Here is my bios backup.rom file
mega.nz/file/x9FVXARI#qNEnTTwTSKl5pAPRE_enCXNFdTKcGdS9lgykAaKuc7U



Can you please unlock the BIOS for me as well?

Thanks

#79 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 31.07.2020 06:10

avatar

@drmotile - Here you go
http://s000.tinyupload.com/index.php?fil...369079613680647

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don't try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

*** WARNING *** - This BIOS is user specific! If you are not user drmotile at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not drmotile, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

#80 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by drmotile 31.07.2020 12:52

Zitat von Lost_N_BIOS im Beitrag #79
@drmotile - Here you go
s000.tinyupload.com/index.php?file_id=00316369079613680647
*SNIP*



Thank you so much. worked!

I couldn't even imagine that this was even possible. And here we are. thanks again

#81 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by banhmigos 31.07.2020 21:26

Hi @Lost_N_BIOS, would you be so gracious as to unlock my bios as well? I am running an M141 on bios v 1.06

Thanks a lot and keep up the great work!

#82 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 01.08.2020 05:22

avatar

@drmotile - You're welcome! Yes, it's amazing what kind of stuff they hide from owners of products

@banhmigos - Here you go
http://s000.tinyupload.com/index.php?fil...313760405957430

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don't try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

*** WARNING *** - This BIOS is user specific! If you are not user banhmigos at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not banhmigos, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

#83 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by northranger 01.08.2020 20:08

Hi @Lost_N_BIOS

Is there anything different I should be aware of when flashing via UEFI shell? For some reason flashrom doesn't detect a writeable flash device on my linux install, but I was able to update from motile's 1.03 to 1.06 successfully with the AfuEfix64.efi tool. And I'm able to backup the rom with "> AfuEfix64.efi BACKUP.ROM /O"

#84 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 01.08.2020 22:24

avatar

@northranger - Sorry, I do not know about BIOS update method on this model, just update per the manufacturers suggested update method from 1.03 to 1.06 - Sounds like you did this already, so not sure what the issue is now?

Ohh, for Flashrom, follow the guided method Fernando linked at post #4, it works for everyone else with these systems. If you are trying some alternate method and it's failing, don't do that, follow the guided method only

#85 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by northranger 02.08.2020 01:52

Zitat von Lost_N_BIOS im Beitrag #84

Ohh, for Flashrom, follow the guided method Fernando linked at post #4, it works for everyone else with these systems. If you are trying some alternate method and it's failing, don't do that, follow the guided method only


Thanks @Lost_N_BIOS , I read Fernando's guide before, but I missed the link to DOS binaries of flashrom.exe. Unlike the Linux builds, it was successfully able to detect & read the Winbond chip on my system from a FreeDOS 1.3 boot USB with CSM enabled. Can you help me unlock the rom I was able to extract?

https://drive.google.com/file/d/1KU0mFz9...iew?usp=sharing

#86 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 02.08.2020 04:59

avatar

@northranger - You're welcome, and nice to see you got it! Also, thanks for the reason why it works now but wasn't working for you before
Here's your unlocked BIOS - http://s000.tinyupload.com/index.php?fil...531472541937783

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don't try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

*** WARNING *** - This BIOS is user specific! If you are not user northranger at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not northranger, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!

#87 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by northranger 02.08.2020 08:09

Thanks again @Lost_N_BIOS .

Flash was successful using

1
 
flashrom -p internal -o MOTIL~1.ROM -V -o BIOSLOG.TXT
 

on a FreeDOS1.3 boot USB.

As many BIOS options as I could imagine appear to be unlocked.

I was successfully able to overclock RAM from DDR4-2400 to 2733MT/s (using 1367Mhz option in Advanced - AMD CBS - UMC Options - DDR4 Timing Control - Memory Overclock). Sadly the overclock is less than the rated DDR4-3200 18-18-18-48 on my RAM stick (G.Skill RipJaws SO-DIMM), but that probably comes down to motherboard quality, SoC voltages, etc. I tried up to +50mv VDDP voltage and up to 120ohm ProcODT to try and stabilize even DDR-2800 but that wouldn't boot. On the plus side the timing controls in the unlocked BIOS enable tighter RAS-CAS etc. I was able to set CmdRate to 1T and crank down primary timings to 14-15-15-44 and see the measured RAM latency drop to 70ns in memtest.

For anyone RAM overclocking, I recommend leaving the bottom cover off and the CMOS battery unplugged (two pin next to wifi card). Wall power will retain settings until a failed boot requires an unplug.

Other notes:
The Advanced(1) - Keyboard Backlight - Light Effect setting to "disabled" does nothing and the backlight still resets on power off.
The Advanced(2) - AMD CBS - NBIO Common Options - System Configuration setting allows changing the configurable TDP of the SoC. Higher than 25 watts and the system does maintain higher boost clocks, but the M142 cooler design isn't really up to the task.

#88 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 02.08.2020 08:36

avatar

@northranger - Thanks for quick test and report back!
Try using 3000 multi instead of 3200, also try 100 x multi instead of 133 x multi, if those options are in there (I didn't look, am used to Intel too)
If not, at least you got to tighten it all up now, maybe that would perform better than looser timings at higher speeds anyway?

On the lighting effect, can you see both (two light effect options) now? They are for different things, but no one has confirmed what on these "Motile" systems yet, other similar systems user explained and tested all three I made visible for him (maybe you need other one made visible, instead of the one I added)?
OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files (18)
If you want to test, let me know and I will make all three visible to you.

#89 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by northranger 02.08.2020 10:13

Zitat von Lost_N_BIOS im Beitrag #88
@northranger - Thanks for quick test and report back!
Try using 3000 multi instead of 3200, also try 100 x multi instead of 133 x multi, if those options are in there (I didn't look, am used to Intel too)



@Lost_N_BIOS There's no multi or multiplier or base clock setting that I can find. I'm certainly no expert on Ryzen BIOSes, but from videos I've seen from e.g. GamersNexus, Hardware Unboxed, Level1Techs, etc. the "AMD CBS" and "AMD PBS" menus are as complete as I've seen on any modern AMD motherboard. Since I went from 2400 to 2733MT/s that's 12% more bandwidth. Also with the tweaking of primary and a couple secondary timings the reported latency in memtest went from 89ns stock down to 69ns. I saw others in the thread report better luck with 8GB sticks, but to me the 16GB capacity is more important.

Zitat von Lost_N_BIOS im Beitrag #88
On the lighting effect, can you see both (two light effect options) now? ...
If you want to test, let me know and I will make all three visible to you.


I do see two "Light Effect" options now. The 2nd one provides a list menu with 6 settings, and the first one 7 (same list but with "Mix" added). However this laptop's kb backlight is only one color, no zones, and two or three brightness levels. My guess is the EC controls the backlight, since it turns on and responds to the brightness Fn keys (Fn-F6 and Fn-F7) whenever there's power, even before the EFI boot menu appears. The machine has never remembered backlight brightness from power-off, so I'm not sure the EC consults NVRAM for a default or saved value. Since I have the silver colored machine, the white backlight is kind of pointless, which is why I was trying to default it to off, but honestly it's not the end of the world if the BIOS has no control. I tried the setting more as a "nice to have", but if there's another setting you can make visible, I'd be happy to test for other's sake (for science ;-) .

#90 RE: [BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS] by Lost_N_BIOS 05.08.2020 11:43

avatar

@northranger - There is a memory multiplier, that's what I was talking about, isn't there? If there is not, how are you seeing/trying 3200 from 2400 I see what you mean now, I guess there is not, and it's just "Pick memory speed"
Here is CBS/PBS IFR text output, if you want to, scroll through those are see if you see anything missing vs what you see in BIOS, such as "Combo CBS", if there is then we can make it visible too
http://s000.tinyupload.com/index.php?fil...702388198870106

If you want, I can hide that 2nd light effect back? Sorry, I assume they all had RGB keyboards and LED's, since Light Effect 1 is visible to you by default.
So you want backlight off? Nothing happens if you set both of those to disabled now? Yes, if you want to test, here is BIOS with all three visible, set all three to disabled and see if it disables all backlight or not
Yes, you are probably right, it's probably EC FW controlled, since there is no RGB keyboard and the default Light Effect seems to do nothing too. Lazy programmers, they should at least hide all that in stock BIOS since it does not apply to this model
http://s000.tinyupload.com/index.php?fil...884339462219829

Xobor Forum Software von Xobor
Datenschutz