Page 1 of 2
#1 [REQUEST]- delete the UEFI GOP module rx560 by fatkos 26.04.2020 23:49

sapphire rx560 4gb - can someone delete gop ? cant use card @old dell

thx

#2 RE: [REQUEST]- delete the UEFI GOP module rx560 by jhsvip 27.04.2020 08:52

avatar

I don't know why you want to delete gop? It noting helps.
I think you should find an other way to solve this problem.
Use Legacy boot or Update Gop drivers maybe works.

#3 RE: [REQUEST]- delete the UEFI GOP module rx560 by gloobox 27.04.2020 09:03

@jhsvip
I think his mobo is too old to support the VGA card,so delete the GOP would help!
I'm interested with it too.

#4 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 27.04.2020 09:03

avatar

@fatkos - dump BIOS with GPU-z, then attach
@jhsvip - some systems no matter what, wont boot with GOP in vBIOS, strange or old, some simply fail to boot
@gloobox - do you need vBIOS edited this way? If yes, attach

#5 RE: [REQUEST]- delete the UEFI GOP module rx560 by jhsvip 27.04.2020 09:20

avatar

You can refer to the tutorial on how to replace GOP to delete GOP:
https://www.overclock.net/forum/67-amd/1...x570-rx580.html

"magic" UEFI:
(done by lordkag, tested by gupsterg, ..copied by me)
For these GOP UEFI files the signature check was overridden. But they also lost their signature, so no secure boot is possible.
The files are universal, they can be used with all R9/RX up to the 580 (as long as the device ID is adjusted accordingly); with Vega a new UEFI was introduced.
Version 1.60 doesn't actually know a 580, but it works just as well, since the device ID for 470/570/480/580 is identical.
Search for the GOP UEFI part in the BIOS, then copy the complete content of the GOP.efirom and overwrite the original one. Do not change the the length of the rom file!

AMDGOP1.60.0.15.50
the new versions have a length of 0xE600; the remaining bytes of the original UEFI/GOP have to be overwritten with "FF" placeholders if necessary. (0x200 length max)
AMDGOP1.63.0.15.50
AMDGOP1.65.0.15.50
AMDGOP1.66.0.15.50
AMDGOP1.67.0.15.50
AMDGOP1.69.0.15.50

--EDIT--
You can find the gop in hex ,and fill them to FF and gop was erased .
@gloobox - do you need vBIOS edited this way? If yes, attach

#6 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 27.04.2020 09:48

avatar

I do it very differently! In regards to deleting GOP, there's a thread here on removing GOP too, and it references something at OCN, which I thought you linked, but didn't, but even then I don't do it same as the other thread here either.

The info above, is for mod BIOS, on some systems, nothing to do with issue here.

#7 RE: [REQUEST]- delete the UEFI GOP module rx560 by jhsvip 27.04.2020 09:52

avatar

Maybe my idea is too simple. I haven't tested it before. Can you explain your method?

#8 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 27.04.2020 10:08

avatar

I wasn't saying that what you mention is simple, mainly saying the above is not related to deleting the GOP. I simply FF entire GOP out, but then also change last image byte for legacy image too, then fix checksum if/when needed.
This isn't in the other thread info, about updating last image byte, I asked there and I don't think the user replied, but maybe that is your thread, I forget?

#9 RE: [REQUEST]- delete the UEFI GOP module rx560 by jhsvip 27.04.2020 18:23

avatar

I don't know how to change the last image byte for legacy image. I need some more examples to learn.

Zitat von Lost_N_BIOS im Beitrag #8
maybe that is your thread, I forget?

That's not my thread.
My post is asking you to unlock the menu of Toshiba U900
Thank u for the answer!

#10 RE: [REQUEST]- delete the UEFI GOP module rx560 by fatkos 27.04.2020 18:27

bios from my rx560

#11 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 28.04.2020 07:22

avatar

@fatkos - Here you go

http://s000.tinyupload.com/index.php?fil...372727162369582

#12 RE: [REQUEST]- delete the UEFI GOP module rx560 by jhsvip 28.04.2020 14:54

avatar

Thank u for your examples!
The last image byte is in 2609h on this vbios
I learned a lot!
Thank u!


---Edit----
Yes! 0x269h, My mistake

#13 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 28.04.2020 23:02

avatar

@jhsvip - You're welcome! If you mean the vBIOS above in #11, the last image byte is 0x269h, Unless you had typo there and meant 269

#14 RE: [REQUEST]- delete the UEFI GOP module rx560 by fatkos 28.04.2020 23:38

Zitat von Lost_N_BIOS im Beitrag #11
@fatkos - Here you go
[...|none]]
...



thx, working fine, old dell 460 alive again :)

#15 RE: [REQUEST]- delete the UEFI GOP module rx560 by Lost_N_BIOS 28.04.2020 23:46

avatar

@fatkos - Thanks for quick report back, and great to hear your Dell can now run with this card too

Xobor Forum Software von Xobor
Datenschutz