Page 2 of 2
#16 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by chinobino 09.01.2020 06:44

avatar

Try using command prompt instead of Powershell.

Also, can you post your 'meinfowin64 -verbose' output after changing the variable for 'Me FW Image Re-Flash'?

#17 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by Lost_N_BIOS 09.01.2020 08:03

avatar

@chinobino - Thanks, but I am asking if for B0 CPU, does he need to write to FD region (not to unlock, but to add in any possible SKU Change made during ME FW mod edits)?

@Jack07 - Yes!! ^^ always use CMD Prompt (AS ADMIN ONLY) for FPT, never powershell

If you are on Win10 - here is simply registry edit that adds "Open command window here as Administrator" to the right click menu
Double-click to install, reboot after install may be required
http://s000.tinyupload.com/index.php?fil...134606820377175

If you are on Win7, right click the folder which contains the EXE, hold shift and press right click, choose open CMD as here and it will be Admin CMD

As mentioned, you cannot write FD without either pinmod first or flash programmer. Correct command to write FD with FPT, after you've done Pinmod is as follows
FPTw.exe -desc -f fd.bin

Further FPT info, you cannot use ./ in command line strings and you cannot use PowerShell. Use Admin CMD directly from folder only, with file location just as I mentioned above (example below for ME)
FPTw.exe -me -f me.bin

Step #4 you mentioned is not used here, what do you even mean enter BIOS for ME Temp disable??
You are setting it hard disabled via grub, or it may only stick one reboot (I can't remember), but either way you do not enter BIOS, reboot to OS or DOS and do FPT right after step #3

You have now corrupted your ME FW, so you must do pinmod and unlock FD, flash FPT from DOS may not be an option with corrupted ME FW (I can't remember), or get flash programmer.
If you had followed my directions as outlined, this would not have happened Powershell was never mentioned, only Admin CMD (also, since users like to deviate from what I mention, I also didn't mention FPTwx64 so don't use it either - advanced mention )

Please boot back to grub and see if Me FW Image Re-Flash variable remains set to 0x0, if yes, then great! Check by doing >> setup_var 0x6C7 << and it will tell you current variable status
If it's not 0x0 but is 0x1 again, then do it again, as mentioned above

#18 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by Jack07 09.01.2020 10:50

step 4 # Because if ME Operation desn't setup temp disable When you use FPTW -me -f me.bin will got error in Windows mode.

Intel (R) Flash Programming Tool. Version: 11.6.10.1198
Copyright (c) 2007 - 2016, Intel Corporation. All rights reserved.

Reading HSFSTS register... Flash Descriptor: Valid

--- Flash Devices Found ---
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

PDR Region does not exist.
Unable to detect ME disabled.

P.S Currently My BIOS show up ME is 11.7.0.1229, but MEinfoWin64 has a error
I am not sure is ok or not, My CPU is i5-7400ES CPU

C:\TEMP\FPT\MEInfo64>MeinfoWin64.exe -Verbose
Intel (R) MEInfo Version: 12.0.22.1310
Copyright (C) 2005 - 2018, Intel Corporation. All rights reserved.

LPC Device Id: A2C4.
Platform: Intel(R) Kaby Lake Chipset

Error 63: Unknown or unsupported hardware platform. HW: Intel(R) Kaby Lake Chipset. Supported HW: Cannonlake Platform.

When use BIOS ez-flash 3 and try to flash H270PG.CAP file get the below error
Selected file is not a proper BIOS!

Could you tell me the detail of the step for flash the bios ? Thanks

#19 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by chinobino 09.01.2020 10:54

avatar

@Lost_N_BIOS From overclockers.ru;

Zitat
When installing Coffee Lake B0, sometimes you can do without a programmer and fuss with unlocking regions on any motherboard.
B0 processors require only a certain ME version and a modified BIOS region to start (for U0 / P0 / R0, changes in FD are also needed).
Thus, if the correct version of ME is already present on your board, all that remains is to flash the BIOS region always open for recording via FPT, AFU or ASUS USB Flashback.
For working with Coffee Lake, ME versions are suitable in the range: 11.0.x. Nxxx - 11.7.x. Nxxx, where "N" is not equal to "3".

And in Coffeetime v0.85 it says;

Zitat
B0 - Has "old" textolite, same as skylake/kabylake CPUs, and assigned with 906EB mCode.
It's easy for mod bios and not needed any shorting/isolating work. Almost all of
8th Gen i3/Pentium/Celeron use it.


According to this post from svarmod about the way the different versions of Coffeetime apply the SKU mod, Coffeetime v0.83 (and later) uses the hack method - which still requires writing to FD but again only for U0/P0.

So it seems you don't need to do the SKU change for B0 only ME FW.

#20 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by Lost_N_BIOS 09.01.2020 11:14

avatar

@Jack07 - Sorry, yes, I forgot, you need to FPT from DOS! Please redo, in DOS

EZ Flash is not used for anything here, ever

I told you best and easiest way to do this is with flash programmer, or you do pinmod and dump FD, edit it (which I've send you unlocked and Coffee edited already), then program it back.

Everything else will be difficult or impossible for you without doing one of those ways. Once you get ME FW downgraded your problems will be over, focus on that only for now.

Once you get ME FW downgraded, then you only need to USB Flashback the .CAP BIOS I sent you (Don't do this first!)

@chinobino - yes, thanks, I've read that, and it was not very clear (Since I'm generally not concerned about FD for region unlocking purposes) but I think you clarified it for me now, thanks

#21 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by Jack07 11.01.2020 04:04

@chinobino Thanks for your advice
I try to find the Intel ME Tool v11 again which not from github.
run MeinfoWin64 -verbose again. The attached file is it.

@Lost_N_BIOS Thanks for your help. BIOS file is MCode is 906E9, 906EA, 906EB (Option1)
which is not Option2, but it is work for me with i3-8100(B0) of ASUS H270F MB.

P.S 1. by the way, If ME can unlock with efi shell(setup_var 0x6C7).
Is it possible, can use efi shell(setup_var something) for unlock FD?
Because pinmod is difficult to short the pin.
2. I used AMISetup_IFR.bat to check found 0x8E5 offset is BIOS Lock.
I am not sure is right or wrong.

#22 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by Lost_N_BIOS 15.01.2020 06:50

avatar

@Jack07 - Sorry about that, I sent you wrong option package because I had the files labelled opposite than post #10
Here is proper Option #2 package w/ 506E8, 906EA, 906EB - http://s000.tinyupload.com/index.php?fil...410967107019646

You can get latest ME 11 tools from here in section C.2 - Intel Management Engine: Drivers, Firmware & System Tools

No, FD can only be unlocked by pinmod or flash programmer, but for B0 CPU, you do not need to write to FD region so you are OK on this unless you can't get ME re-written, then you would need to unlock FD so you can do that.
BIOS lock not related to FD/ME stuff

From your MEINFO report >> Local FWUpdate = Enabled
So you should be able to flash in ME now, however, I think now after seeing this (Host Write Access to ME = Disabled), that option we changed only allows ME FW reflash via ME FW update tool, which wont downgrade ME FW in this instance
So you will need to do pinmod or get flash programmer, if flashing in the above CAP file via USB Flashback does not downgrade the ME FW

#23 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by 21.02.2020 03:16

Hello,

sorry for hijacking this topic, but I have the same motherboard as the topic author and kindly asking for a help with a way, how to run i3-9100F there (SRF7W - B0 stepping).

My ME version is 11.6.0.1126, so I'm curious if there's a way, how to get the modified BIOS to the board without using flash programmer (I have one, but SOIC8 clip won't fit in there as there's too little space around BIOS chip) and while FD is still locked (sound chip is shielded, so pinmod won't be an easy one).

Can FPT help me to dump the original BIOS to backup board specific data (SN, UUID, etc.) or is even CoffeeTime tool able to grab that info from running system? (option 3 - Setup MAC-address and personal data) I'm quite worried, that as long as FD is locked, I'm won't be able to dump original BIOS.

Lastly, I'm curious about the CoffeeTime vs ModTool difference (both tools can be used for modifying the BIOS, but I'm not getting the exact difference between them) and why are you using some extra tools mentioned in this topic (MMTool, UEFITool, HEX editor) - does this mean, that CoffeeTime or ModTool are missing something, which is needed to be fixed manually?

Thank you very much for your time in advance.

#24 RE: [REQUEST] BIOSMOD ASUS ROG STRIX H270F Gaming Support i3-8100 i3-9100F by motorolarulez 02.03.2020 03:50

Hi,

in the end, I was able to successfully run i3-9100F on mentioned motherboard and would like to share steps taken by me for future reference / other users.

As I wrote in my previous post, my ME (Intel Management Engine) version was 11.6.0.1126, so no ME downgrade was necessary (this will help a lot).

* If the ME is newer than 11.7.0.1xxx, downgrade is necessary. To do so, there are (AFAIK) only 2 possible options - flash via hardware programmer (eg. CH341A ... the problem is, that SOIC8 clip probably won't fit the BIOS chip as JSPI1 header is right next the BIOS and header pins are getting in the way of the clip ... I've tried at least 50 times but was able only to bend JSPI1 pins) or through FTP, but FD (Flash Descriptor) needs to be unlocked first (good luck with that as sound chip is shielded) - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
* Not sure if the GRUB option will be working for ME downgrade as well ... didn't tried it, but it's probably worth to check if you really need to downgrade ME.

As ME was fortunately no issue for me, I've focused on preserving board specific data (SN, UUID, MAC). To answer my previous question - CoffeTime tool is able to grab MAC address from running system, but I didn't found option to grab SN and UUID. There's an option to restore such data from BIOS backup, so I went in that way.

As the FD was still locked, I wasn't able to perform complete dump of BIOS incl. ME and other regions (I've used FPTW64.exe from W10 64bit) with following command (command line runned as local administrator) : ftpw64.exe -d BIOS_Backup.bin
On the other hand I was interested in BIOS region only (due to board specific data), so this command did the trick : ftpw64.exe -bios -d BIOS_Backup.bin; my backup was 13 824kb big.

Don't bother to try modify this backup via CofeeTime or Coffee_Lake_Mod_Tool, those tools are expecting to get the "full package" (BIOS incl. ME region, etc.). Anyway, I've used FD44Editor to open up my BIOS backup and was able to extract board specific data.

At this moment I needed to insert my board specific data to modified BIOS file and flash it back to board. I've used BIOS prepared by @Lost_N_BIOS in this thread, but as both BIOS files in this topic are "full package", I needed to extract BIOS region only. To do so, I've used UEFITool, opened up the H270PG.CAP file (option2.bin file will work as well), found "BIOS region", right click it, selected "Exctract as is" and saved to the disk.

Now it's time to open up this exctracted BIOS by FD44Editor and fill up all board specific data obtained from original BIOS backup (you should see, that ME version and GbE version are stated as "not present". Once done, save it.

Alright, so now we have prepared BIOS (without ME) with board specific date, so all we need to do is to flash it back to the board.
To do so, you need remove BIOS lock first - follow this guide : [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Long story short - in the end, I've done this : Downloaded EFI-Setup-FPT-Universal-IFR-Extractor.zip (attached in first post in the guide), unpacked, went to \efi Setup\boot folder, copied bootx64.efi to flash drive and renamed to Shell.efi (it has to be in root of USB drive). Rebooted the computer, went to BIOS and launched EFI shell from USB drive. I've typed in "setup_var 0x8A6 0x00" (without quotes) and then "reboot" (again without quotes)....the command (VarOffset to be exact) can be different on newer BIOS builds (as mentioned in the guide), but this was working just fine for me (BIOS version 0308). So if you won't be able to flash BIOS region back (in next step) due to active lock, you need figure out the correct VarOffset (0x8A6) by yourself.

As the BIOS lock was now removed (based on my experience it last only for one reboot), I went back to Windows 10 and finally flashed the BIOS to the board with following command : ftpw64.exe -bios -f BIOS_Backup.bin (it took approx. 1 minute). Once this was done, I've powered off the computer and changed the CPU.

I have i3-9100F B0 stepping (SRF7W), so absolutely no CPU modification was needed - just put the CPU to the socket and power up the computer. First boot will take a while, so don't panic if your screen will be blank for longer time than usual ... approx. after 15-20 seconds, the system started with message, that BIOS update is in progress and by 2 automatic reboots later it was done.



Proof of concept (BIOS screens) attached.



Basically all necessary information can be found in this forum, but it can be quite time consuming to get all the pieces together, that's why I've described all my steps in one post.

Btw - it's possible to import modified BIOS region back to "full package" BIOS (bin or cap file) file provided by @Lost_N_BIOS via UEFITool and such file can be adjusted by CofeeTime or Coffee_Lake_Mod_Tool again - I did it just to triplecheck, that I didn't corrupted BIOS region during my editing.

Once again, thanks a lot @Lost_N_BIOS for the modified BIOS files, it helped me a lot (I've tried to modify CPU microcodes via MMTool as I was using Celeron G3900 - microcode 506E3, but I was getting ERROR 4001: FV size is too small the required FV image size exceeds the set FV image size; no matter how many microcodes I've updated / deleted....so I've used your files instead and just believed, it will work on the first try )

Xobor Forum Software von Xobor
Datenschutz