#1 help to flash MCode on asrock e3c224d4i (XEON) by n1ete 04.12.2019 09:19

hey there,

just stumbled yesterday on this forum and the awesome resources to save my mainboard but after 10 hours of hex editing i am lost... so here am i not beeing able to help myself even though the excelent guides here.
the problem i got is, that the microcodes doesnt fit because of size changes.... so i tried to alter the fit table without success. is someone able to patch the microcode for me? that would be awesome! i attached bios and microcode in case someone is able and willing to help. :-)
also i would like to know if i can flash the ipmi/bmc on the mainboard aswell, but thats probably a question for a different thread....

thanks a hundred in advanced for all the work in this forum to the contributors and big hello to everyone in here ;)

#2 RE: help to flash MCode on asrock e3c224d4i (XEON) by Lost_N_BIOS 04.12.2019 10:06

avatar

@n1ete - One must be removed, or maybe only update one of 306C3 or 40671 (other two can update without issue, same size). What is your CPU model, whatever it is, for now, that is the only CPUID you need to actually update, rest would never be used.
So, your only option is to update that specific one for your CPU, and see if there is room for only that update after inserting and trying to save, if not one will need removed.

I can do all that for you, tell me which you don't care to loose if needed, and what is your CPU, then I can better see what your options might be.
Also, if you move forward yourself, this should not be done with hex editor or UEFITool, due to the only microcode volume in this BIOS that contains the microcodes is in a PEI Volume. Use MMTool 5.00.0007 or 5.024

Thank you for the awesome words of support, we all try best we can!

IMPI/BMC question I can't comment on, other than you should ask Asrock about that. Someone else might know though, we'll have to see who else replies.
I assume if they provide an update on site for this, then you can update as instructed on the download page or info contained within the download.

#3 RE: help to flash MCode on asrock e3c224d4i (XEON) by n1ete 04.12.2019 13:18

thats why it didnt work....thanks for the clarification!
i have an Xeon e3-1231 v3 working on the mobo so the 40671 one shouldnt be needed at all
... i will try myself, but it would also be really nice if you could provide me a modded file....i would appreciate if you could send me a modded version aswell, as reference to check and if all else falls...... ;)
i will open another topic for the bmc related stuff so it gets the right attention.

it gets more and more awesome in here.....
thanks

#4 RE: help to flash MCode on asrock e3c224d4i (XEON) by Lost_N_BIOS 04.12.2019 19:26

avatar

You're welcome! Thanks for CPU info, I will make you a BIOS and or let you know what's possible here shortly (If you read this and no info edited in, then I had to run, but will be back to edit in info later tonight)
Note to self for reference - User CPU is 306C3

*Edit - @n1ete - Here, all updated except 40671 + FIT Fixed - http://s000.tinyupload.com/index.php?fil...629823469687921


Edit was done using MMTool 5.00.0007 as outlined below (method does not have to be specific, but I always leave one ucode in place while doing ucode edits, so this my method)
Removed first three ucodes (40671, 306C3, 306C2), leaving 306C1 in place. Then inserted new 306C3, remove old 306C1, insert new 306C2, insert new 306C1, insert old original 40671, save as mod BIOS name
The then fix FIT with UEFITool v25, rename to stock BIOS name.extension once you are done, and then you're ready to flash

#5 RE: help to flash MCode on asrock e3c224d4i (XEON) by n1ete 07.12.2019 04:07

after i removed the 40167 one it worked aswell with ubu tool, flashing went good so i guess everything is right...unfortunatly i still face some apic id mismatch kernel errors at os level.

i am missing some further virtualisation options in the bios. is it possible to add some or will i likley brick my mainboard?

#6 RE: help to flash MCode on asrock e3c224d4i (XEON) by Lost_N_BIOS 07.12.2019 06:10

avatar

@n1ete - Try the BIOS I made you instead, especially due to your comment about missing virtualization, sounds like a bad mod you made and ucode is not loading properly.
UBU or UEFITool/UEFIReplace, and sometimes MMTool too, can mess up BIOS when doing mircrocodes, by adding or removing certain padding/non-uefi files.
My normal method to update microcode is UEFITool 25, as you can see above I used MMTool, so obviously this happens on microcode edit in this BIOS or I would have used UEFITool,
Additionally, the microcodes in this BIOS are in PEI volume, so that may also be why I used MMTool. With UBU, only in certain situations you can choose which method it uses to replace microcode (MMtool or UEFIReplace), so you can't be sure.

I suggest you test with the BIOS I made, and also send me the BIOS you made so I can check and let you know if I see anything funky.

Are you asking also, you need some settings revealed in BIOS in regards to virtualization? If yes, were they there before you modified the BIOS? If yes, then above is for sure true (issues with your mod BIOS)
In general, to answer that, no, unlocking BIOS menus would not brick the board, and I can usually unlock all the hidden BIOS settings you see in AMIBCP (4.55 in this case).
But, to do that, I need you to give me images of every page in your BIOS, all sections so I can see at root level, all submenus, all contents inside each (all settings = total BIOS, since I can't see it myself to know what is visible.)

#7 RE: help to flash MCode on asrock e3c224d4i (XEON) by n1ete 07.12.2019 06:39

thanks again for helping me out, the options in the bios are the same as before but i miss some more acpi options (ACPI SRAT) and numa/node interleaving options for instance.
ive attached my modded and already flashed bios for you to check and here are the pics ;)
https://photos.app.goo.gl/4E5mghnZTWviRojL7

thank you a lot for your time ;)

#8 RE: help to flash MCode on asrock e3c224d4i (XEON) by Lost_N_BIOS 07.12.2019 07:12

avatar

@n1ete - Are you saying settings like this >> acpi options (ACPI SRAT) and numa/node interleaving, were there before and not now, or is those something you mean you want revealed if in BIOS as hidden options?

Did you flash the BIOS I made too, and same issues you mentioned APIC ID Kernel errors? Thanks for pics, I will work on this and get back to you soon

* I checked your mod BIOS, FIT is "OK" but not edited correctly, not an issue only mentioning. But, there is major issue, luckily it didn't brick the board, but it may be causing the issues you mentioned.
As I mentioned above, this mod BIOS has a missing padding file at the last microcode volume in PEI region, due to method used for microcode edit. This can cause bricked BIOS, luckily not here, and can also cause non-load of microcode (may be occurring here)

* Edit 2 - I checked your BIOS, and I do not see any settings like you mention above. Please download AMIBCP 4.55 and open your BIOS and then on left, browse through each section and see all possible options, maybe I miss them or they are named slightly different etc.
The no named folder under main cannot be enabled, this is a debug folder. Settings there can be changed directly, but not made visible to you (everything else can be made visible, generally)

Xobor Forum Software von Xobor
Datenschutz