#1 Tips for Win7 on MSI Z370 PC Pro with i5-8600K by bgmCoder 15.08.2019 01:20

In March of 2018, B&H sold me an MSI Z370 PC Pro and an i5-8600K for my Win7.
I went through a lot of trouble getting Windows 7 to work on it (I do NOT want to discuss Windows 10 here, please), and everything is working and runs pretty well except for a few glitches.
Since there are no win7 drivers for that board, I cannot use the onboard graphics, so I disable it in the bios and use two graphics cards for my three monitors.

MSI told me that Win7 only worked on this board in 25% of their tests, and even though there are *some* win7 drivers for this board, win7 is not supported at all.

Sometimes the entire computer will freeze - the monitors freeze and the input freezes and I have to cold power it and reboot.
Sometimes there is an input lag where keys are received seconds after I type, and the mouse is draggy-feeling and inaccurate. To resolve this, I either have to reboot, or I start shutting down applications until one of them finally triggers some release of the lag - it doesn't seem to matter so much which programs I shut down nor in what order I do this. Sometimes it works, sometimes it doesn't.
I have LOTS of RAM and neither the cpu nor the ram are even halfway past their max consumption in these cases.

I am running IRST on the machine, using an SSD drive to accelerate my HDD C drive.

I have tried updating the BIOS, but if I update past the initial driver version 7B49v10 (I've tried v17 and v12), then BIOS tells me the RAID configuration is invalid and cannot boot windows. So I have to put v10 back on the machine. Every time I update the BIOS, I have to switch from AHCI back to RAID.

I am posting here, hoping to see if anyone else has worked out this combination and if there are any tips on improving the state of things.

I have another thread over on DonationCoder about this topic, as well as on on BadCaps. Since I'm willing to use mods to fix my issues, I decided to try here.

#2 RE: Tips for Win7 on MSI Z370 PC Pro with i5-8600K by Fernando 15.08.2019 01:32

avatar

@bgmCoder:
Welcome to the Win-RAID Forum!
Since I don't use Win7, I cannot really help you, but is is rather normal, that you have to restore your specific BIOS settings after having updated the BIOS.
Regards
Dieter (alias Fernando)

#3 RE: Tips for Win7 on MSI Z370 PC Pro with i5-8600K by PatrickK 15.08.2019 18:07

avatar

I would not recommend talking with manufactures, I don't think they are interessted in your side with your idea, but I think I am.
I used the drivers on this thread: [Solution] Win7 drivers for USB 3.0/3.1 Controllers of new Intel chipset systems
to install Windows 7 on a ASRock H310M-HDV, works just fine, but I am pretty shure that you need just the official Intel-drivers slipstreamed in Windows 7 to be able to install it. What motherboard are you using? I recommend you to reset the bios-settings with taking out the battery while unplugged, after the update, i do this almost everytime on my X470 AORUS GAMING 7 WIFI that i use in my workshop-pc where i do all my experiments and my developments for my Windows 7 Service Pack 2-series, currently SP2.8.
Why do you not install Windows 7 on your SSD and use your HDD just as a HDD ? I don't have any experience with IRST, but maybe there is the issue. Memtest could be useful.

Xobor Forum Software von Xobor
Datenschutz