Page 2 of 2
#16 RE: Need help on a stubborn Intel DX58SO2 desktop board by Paraffine 13.11.2019 17:55

I may be a bit late to the party (about 7 months indeed) but anyway specifying what bios version did the trick for you could be helpful for those who are still struggling with this motherboard (as I am doing right now :P ) and give this thread a little more value for the future

Thank you in advance

#17 RE: Need help on a stubborn Intel DX58SO2 desktop board by DeeKay789 18.10.2021 02:21

Hi everyone, I am late this thread but I think the solution I have below will help anyone who is experiencing the same problem with their DX58SO2 Mobo.

Warning, the text is long so the TL:DR version is flash old BIOS, flash latest BIOS and you're off and running. The long version....

For those who might find this useful - and do copy this to as many forums as you think will find it useful.

Intel motherboard DX58SO2 BIOS 80h '2b' hanging problem - BIOS starts it's MTRR write sequence ('2A') but never exits from it's write and hangs at '2b'. This wouldn't normally be a problem but none of the normal BIOS reset strategies work. These are:

A) using the Boot to BIOS button
B) moving the BIOS boot jumper to Pins 2 & 3 (by default it's on pins 1 & 2 for normal operation)
C) removing the CMOS battery
D) removing the CMOS battery and shorting the pins for 24 hours
... or any other strategy that I had yet to come across.

Stalwarts will have reduced their system to a 'Minimum viable build' - that being one stick of ram, all cards removed except for a basic graphics card. No front panel connectors (use the Mobo buttons) and removal of all USB devices (except keyboard), removal of alld PCIe cards and all storage devices, including the boot drive - and disconnected all fans (except the CPU fan).

They will have swapped out the graphics card, moved the graphics card slot, swapped the stick of RAM, booted via USB thumb drive to FreeDOS (it still doesn't). They will have swapped out the processor (Xeon X5660 in my case) and reseated the cooler and swapped out the PSU. This is all great fun and good experience.

At this point you could bin your board and live a better life. You may however like to try this first. Rolling back your BIOS, booting to your OS (Win10 pro in my case), and then reflashing the latest BIOS.

Flashing the BIOS of course requires the iflash version from intel as obviously you don't have a working OS. The reinstatement of the latest BIOS you could do through the OS but why bother, see next.

You'll need two USB thumb drives of 1GB or greater - empty. They can be USB3xx but you will be connecting them to the USB2 port on the DX58SO2 Mobo.

Thumb 1 has an old BIOS. In my case version 0776.
The backdated BIOS update that worked for me come from here:
(htp........w. stuff) opendrivers.com/download/driver-155831.html
(use the mirror server - as of writing the main one is broken - 17/10/21)

Thumb 2 has the latest BIOS. In my case that's 0920.
The latest (I can find) BIOS update comes from here:
(htp........ stuff) followed by drivers.softpedia.com/get/BIOS/Intel/Intel-DX58SO2-Desktop-Board-Express-BIOS-0920.shtml
(select the BIOS version that does NOT include the word 'Express')

As long as you've read this whole diatribe first, you'll now know that you need to download the Thumb 2 files first. Copy the unzipped files to the Thumb 1 and the Thumb 2 USB drives. There will be three; the iflash2 exe file, the .bio image (SO0920.bio) and the licence(?) .itk file (with matching name).

The old BIOS image in my case came as a renamed file with the filename in quotes. Copy this file to Thumb 1. Rename that file removing the quotes and make sure the file extension is set to dot BIO (.bio). Delete the original .bio image file (...0920). Rename the .itk file with the same name as the new (old) BIOS name. I don't know if this is necessary, but I did it so I've documented it here. Did I test it, no.

You should now have three files on both Thumb 1 & 2 drives: the iflash2 exe file, the .bio file, and it's .itk counterpart.

Now, approach the machine in distress and remove it's power. Double check you've removed the SATA boot drive and you have the 'Minimum viable system' configuration. Remove the yellow BIOS jumper completely. Insert Thumb 1 into one of the rear USB2 ports (the backdated BIOS). Connect the power and fire it up. Wait, wait, wait. wait.... the 80h display will show 'BF' for quite a while but then your screen will eventually flash up with the encouraging lines that the BIOS update is in progress. It will conclude successfully (in my case) after about 4 minutes.

Power off when instructed on the screen and replace the BIOS jumper back to pins 1 & 2 - as instructed on the screen. Remove the USB Thumb 1 drive and connect your SSD boot drive to one of the blue onboard SATA ports. Power up. Your machine should now boot normally albeit on an aged BIOS. Be happy, and then shut it down normally.

Remove the yellow BIOS jumper again. Remove the SATA drive again. Insert Thumb 2 into the same USB 2 port as the original Thumb 1 drive. Power up. Wait, wait &c. The BIOS flash will be successful (in my case). Shut down and restore the yellow jumper as the screen instructs. Connect the boot SATA drive and remove the USB Thumb 2 drive.

Power back up. Your BIOS POST should now resolve as normal and your system will boot to your OS, as normal. Be incredulous that Intel forgot to reset some important BIOS settings on a failed POST runtime.

Walk away. Be happy.

Hope this helps someone.

Xobor Forum Software von Xobor
Datenschutz