Page 4 of 11
#46 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 01.03.2019 22:06

avatar

Thanks @MMFC378 - No there would be no change reflected on your end from what I changed. OK, lets test some NVRAM clearing, swapping next.
These will likely remove your serial, UUID etc (I did not check all this details location), but you can always put back because we have your OG backup, so don't worry. If one, or both of these methods fix the issue, then we know were the lock/password is, so then I can work to remove without doing a clear/swap like this.
One has empty stock NVRAM defaults x2 from IMPI 1208 BIOS (May still contain lock, but in case not checking to be sure), and then non-IMPI 4005 BIOS NVRAM defaults x2. Please test both, let me know outcome (message will not be shown, just check if you can see actual Ai Tweaker or not.)
If both fail, go ahead and flash back your OG FPT backup for now, in case using like that causes any instability. If these both fail, I'll dig in further and see if I can find where this is being applied.
http://s000.tinyupload.com/index.php?fil...567498978288067

#47 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 01.03.2019 22:47

So I flashed the first one (cleared nvram I think). Password still there and now I’m getting chassis intrusion - system halted. Can’t boot to windows

I solved that problem before with the “Chassis Open” jumper on the board but now it won’t go away. Maybe @Nuckyy could help me out with this one

#48 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Nuckyy 01.03.2019 23:07

What can I do to help?

#49 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 01.03.2019 23:09

Did you ever get a Chassis Intrude error?

And did you use any jumper on that Aux Panel below the data ports?

#50 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 01.03.2019 23:36

@Lost_N_BIOS - Heres what happened

CLRSTKNV - Password still there, cant get rid of Chassis Intrusion. Disabled it in the BIOS after clearing CMOS but it still comes back (not saving?). Couldnt boot to windows
4005NONIMPINV - Wont post. VGA DIAG light stays on, systems hangs with a "01" post code, then it restarts, again VGA light stays on then HDD DIAG light stays on and hangs at post code "9C", then it shuts off. Did this everytime i turned it back on, 2 restarts and same post codes, never posts.

Hope that helps. If you need more details i can flash them again

#51 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 02.03.2019 06:17

avatar

Thanks @MMFC378 - odd one with chassis intrusion, but don't worry about it, since password still there this confirms NVRAM does not control this. I thought later about the 4005 non-IMPI one, and I bet it needs swapped out setup/amitse regions from the non-impi board, otherwise the settings wont match up.
So, maybe best way to sort this out would be to go ahead and flash you over to the non-IMPI BIOS and then get a dump from you again and put back in your board specific details. Is this board more like the P9X79-WS or the P9X79-E WS?
Or, I can try finding it in setup or amitse, but that may take me some more time, if you don't mind waiting while I dig around in assembly

#52 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 02.03.2019 06:25

Its the P9X79-WS

#53 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 02.03.2019 07:16

avatar

@MMFC378 - what is your MAC Address, can you dump GbE region with FPT? >> FPTw.exe -gbe -d gbe.bin
If you do not have FPT already, you need ME System Tools Package V8 from here in section "C" - Intel Management Engine: Drivers, Firmware & System Tools

If no Intel Gigabit LAN then no GbE region, so it may be expected to error/fail. I was unsure if it's there or not, and maybe missing from your dump due to how you dumped the BIOS (Unsure method used)
I don't see it in stock BIOS, but that doesn't always mean it's not there on the board BIOS.

#54 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 02.03.2019 07:26

Very weird. This board had dual Intel I210 Gigabit LANs but im getting a GBE Region does not exit

I can pull up my mac address if thats all you need

#55 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 02.03.2019 07:29

avatar

I thought so, since it's not in the dump, but as I mentioned wasn't sure how you dumped the BIOS and didn't check back to see (I remember now, AFU, so wasn't sure if that would dump it or not). Maybe back then, this kind of LAN did not use GbE? Or, it's inside a BIOS volume etc.
Give me one of your MAC ID's, so I can find in BIOS and copy out the correct details, already have serial and UUID

#56 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 02.03.2019 07:30

AC-22-0B-8A-16-9C

#57 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 02.03.2019 08:22

avatar

@MMFC378 - OK, here is test, this is BIOS 4901 extracted from a live board, so full dual NVRAM areas populated properly, and I swapped in your serial, UUID and MAC.
Since you cannot use FPT, I swapped BIOS FID's (x2), so after this goes through you will be on regular WS BIOS, but you wont be able to flash regular WS BIOS until you get a programmer, since it will still have IMPI FID.
I believe this is the only thing that needs swapped for AFU to allow the flash, but I've not done this one often so there may be another thing or two I need to swap from IMPI if it fails due to BIOS ID mismatch etc.
Went ahead and also swapped in the 1208 Flashback module too, so flashback may even take this BIOS too if put back into a capsule.
http://s000.tinyupload.com/index.php?fil...515798243734987

If this works for him ^^ @Nuckyy, I'll have you send me a programmer dump and I'll swap regions for you and put back in your board details, then you can program back in.

!!!! I just realized you guys board has USB Flashback, so half this dance around how to flash mod we could have used that for the mod BIOS flash !!!

#58 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 02.03.2019 16:02

Just to make sure, Im using APU for this flash? All the other apu files have been .rom, this is .bin (FPT)

#59 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by MMFC378 02.03.2019 16:56

Here what i did -

Used AFU to flash P9X79-WS-IPMI-ASUS-1208.cap
Then flashed 4901NVSMPadFIDFB.bin
Restarted
Doesnt post, hangs on 01, then restarts and hangs on 6F

Edit: re-flashed and now it’s in a loop. 4F 67 69 5A, 4F 67 69 5A, etc.

#60 RE: [HELP REQUEST] P9X79 WS/IPMI BIOS Overclocking unlocked... by Lost_N_BIOS 02.03.2019 18:50

avatar

@MMFC378 - rom/bin = same, sorry for any confusion. And damn, did not expect a loop, I guess we should have had Nuckyy test program in directly P9X79-WS BIOS before doing this, sounds like that BIOS is not as compatible with this board as we thought, at least he could easily recover.

@Nuckyy - can you please test to confirm this is the issue, and not my edit, if it's my edit maybe we can still fix. Please backup your current BIOS with programmer and verify it's valid by opening in hex and other BIOS apps to be sure it's OK (Or upload and I will check)
Then program in P9X79-WS BIOS, removed from capsule (open in UEFITool, right click on capsule, choose extract body), that body extracted file is what you program in with programmer.

MMFC378 - Try this, same file in capsule, put on root of small USB (FAT32) - http://s000.tinyupload.com/index.php?fil...297809899216250

If that fails, download stock P9X79-WS 4901 and put that on root of USB, named same as above file (P9X79WS.CAP) and use USB Flashback button.
Hopefully you have a compatible with flashback USB, smaller is better, LED on flashback button will blink a few times then get faster and faster for a minute then stop and it's done.
If it only blinks a time or two and stops or stays lit, then it's not compatible USB or file is incorrect (not named properly, not found etc).
Once you see it's working, and you get same errors with both of the above, try doing same with your IMPI cap BIOS to recover, it's recovery/flashback name needs to be P9X79WSI.CAP, but I'm betting you're locked to non-IMPI now since the other flashed in, unsure if flashback will flash in the original model now.

Please order one of each of these now, you can find on Amazon or Newegg or other similar shops closer to you for more $$.
These are just examples of what you need to manually recover unless you have another board you can hotflash with that has socketed BIOS and you know how to safely remove BIOS chip without an extractor.
https://www.ebay.com/itm/201316582787
https://www.ebay.com/itm/123167465408

To give some info on the error, stopping at 5A is internal CPU related error, and also = Early Chipset, VGA, SuperIO and Interface Init, so hard to say, could be related to the IMPI chip trying to run?
Can also be memory related, try swapping sticks around, or going down to 1 stick in proper slot for single. Also try other sticks of memory than current, if you have (Non-ECC for now)
We'll know more once Nuckyy tests stock 4901 on his board. It may be my edit, or simply this BIOS is not compatible with your board for some reason

Xobor Forum Software von Xobor
Datenschutz