Page 3 of 3
#31 RE: Intel NUC DCCP847DYE Results by Lost_N_BIOS 13.05.2019 10:27

avatar

Hey @ricktendo - yes, no problem. I am not sure why UBU is still doing funky stuff with ucode sometimes...?
I see 2-3 BIOS this week with bad edits, we discussed a few times too, but I'm not sure if he doesn't quite understand what I mean, even with images showing, or if he thinks it's OK/safe sometimes (And it may be), I'm not sure why it's not correct every time like it used to be?
Did you test the BIOS with the UBU padding issue, if yes was it bricked, or did it boot but not properly load the ucodes or what?

You'll have to learn to do this yourself manually, this BIOS is an easy one
http://s000.tinyupload.com/index.php?fil...772927349298646

#32 RE: Intel NUC DCCP847DYE Results by ricktendo 13.05.2019 16:19

avatar

@Lost_N_BIOS can you point me again to your tutorial?

Editing uCode with ubu does not brick the device, it only breaks the version display in bios

@Lost_N_BIOS I just tried your modded bios and it will not boot.

#33 RE: Intel NUC DCCP847DYE Results by ricktendo 13.05.2019 18:44

avatar

@Lost_N_BIOS I just tried your modded bios and it will not boot.

#34 RE: Intel NUC DCCP847DYE Results by Lost_N_BIOS 14.05.2019 09:00

avatar

@ricktendo - Good to hear the UBU edit is not bricking the device at least! Not showing the ucode means it's not loading it either

!!Ahh!! Very sorry about the non-boot BIOS! Of course, now that we have this again I remember I think we had that before too, and I had to edit another way, sorry I forgot to check back on this before making you a new BIOS!
Sorry about that, I'll make a note in your folder on this to keep this in mind next time around!

Please test all of these, and let me know which boot and do not break microcode shown (all should boot I hope), then let me know, then I will update my notes with which method to use next time
I suspect M2M ones will work/boot, M2U may not boot, CC and D0 is test on which method needs to be done for the actual uCode edit and for those to be shown to you and not broken/not-loaded.
I noticed UEFITool is making changes inside next module (MemoryInit), that we're not editing, and I didn't notice last time we tried to figure out why MiesMosel's edits were working and mine were not

So, if you want to be sure you can boot, and not have to go through non-boot hassles again, maybe only testing M2MD0 and M2MCC would be good enough to let us know with method onthe ucodes to use.
And then, if you wanted, you could confirm the M2U ones both fail to boot, but this not as important as the M2M tests, if both of those boot anyway
http://s000.tinyupload.com/index.php?fil...942404117023315

#35 RE: Intel NUC DCCP847DYE Results by ricktendo 14.05.2019 09:39

avatar

@Lost_N_BIOS as you suspected NONE of the M2U* images booted

M2MCC boot but the CPU/uCode in bios was not loaded
M2MD0 also boot and CPU/uCode in bios loaded correctly, so this appears to be the WINNER!



Thank you for your help!

#36 RE: Intel NUC DCCP847DYE Results by Lost_N_BIOS 14.05.2019 09:54

avatar

@ricktendo - Great! And you're welcome

So, here's the breakdown of the issue, in case you wondered. M2U edits were done with UEFITool, this to preserve the padding initially (v25), I think we checked out V25/26 previously and both were the same edit via hex, so version didn't matter.
Anyway, I found after saving, it's making some changes in the module following the microcodes, which it shouldn't be doing, there may be other edits below that done too but I didn't look further after seeing that as that alone was plenty of non-desired edit, any single byte changed not desired since we didn't edit that module.

M2M files were straight hex edits on the entire file, microcode body block removed and hex edited outside of BIOS but same/same, then pasted back in once work done. CC was part of starting alignment location of the last microcode in one file, D0 in the other.
CC aligned that ucode at a 400h alignment offset, and D0 used 800h alignment offset. So your BIOS requires 800h offset to be used for the starting location each ucode (800, 1000, 1800, 2000 etc).
The main issues here were UEFITool editing other modules, and then the alignment of ucodes. Microcodes were kept in there original order this time, but now that we know all this I don't think that matters (we can test and confirm this if you want?)

#37 RE: Intel NUC DCCP847DYE Results by ricktendo 14.05.2019 10:04

avatar

@Lost_N_BIOS if you want me to test further images feel free to post them I will gladly test, its past my bedtime so I will do this tomorrow some time.

If you ever need help SPI flashing I am your guy, I will gladly help you out if needed

#38 RE: Intel NUC DCCP847DYE Results by Lost_N_BIOS 14.05.2019 10:49

avatar

Thanks @ricktendo - here is mod BIOS with ucodes not in matching order of original BIOS, properly edited other than that, lets see if it works
This is how I normally put them in when editing, order being highest name value to least.

http://s000.tinyupload.com/index.php?fil...589404201520048

And thank you, if I run into any issues with SPI flashing I can't resolve I'll remember to tag you to hop in and advise

Ahh, I just realized your CPU is 206A7, so in all test BIOS this is last ucode anyway Once you confirm above test is OK, I'll make you new one with your ucode first

#39 RE: Intel NUC DCCP847DYE Results by ricktendo 09.08.2019 01:19

avatar

@Lost_N_BIOS sorry for the late reply, I got sick and I could not test your our of order uCode Bios updates, also Intel released a new version of the bios and of course they did not bother to update the uCodes, any chance if you have the time you could update them for me?

https://mega.nz/#!fxR11KiC!lGqKseBRy7xB-...TdFIbu6obV5F5vs

Thanks for everything!

Xobor Forum Software von Xobor
Datenschutz