Page 69 of 345
#1021 RE: Windows XP SP3 32bit and modern PC parts by cedar 09.07.2019 21:37

@diderius6

Thanks. I will try them soon.

Cedar

#1022 RE: Windows XP SP3 32bit and modern PC parts by XPLives 09.07.2019 23:12

avatar

Yeah you will have to do the eyeball to motherboard check.

Look for where the Ethernet connector comes in from the rear side of the motherboard. Then follow that into the motherboard and look for any Realtek 8168 chip. You can find which model it is that way.
Probably starts with RTL.

I have a few PCIe NIC from Realtek and you can read it off the chip if you look closely.

I can confirm the one in Ivy Bridge I had is 8168E that works in XP.

Okay the one I recommended to buy off eBay the chip will say on it:
RTL8111E.

Cost about $5 on average shipped to the US total cost.

This one works great if not depending on the motherboard to hook it up which sometimes you have to be picky about which motherboard to get if you don't want to use any internal slots up.

#1023 RE: Windows XP SP3 32bit and modern PC parts by diderius6 10.07.2019 03:30

I just flashed the new Bios PRIME-X570-PRO-ASUS-7010
with result, that the board with Ryzen 1700 does not promt any longer, brrr.
But before I make a complete extract of the Bios with Universal BIOS Backup ToolKit 2.0.exe.
Now I am going to flash the Bios back, because ASUS CrashFree BIOS 3 does not work at all!
The Bios chip is Winbond 25Q256JWEQ, which is package size WSON 8x6-mm (8 pins)

25Q256JW
1.8V 256M-BIT
SERIAL FLASH MEMORY WITH
DUAL/QUAD SPI

I use for this Epromer tl866ii plus which supports this Bios chip as W25Q256JW(1.8V) @SOIC8
Dietmar

EDIT: I cant flash this Bios chip until now, because the package size 8x6-mm is too big for my test clip.
Because my original 407 Bios version is not listed at Asus site, I think, they just deleted the CPU id for Ryzen 1700,
for to make true, that this first generation of Ryzen chips can not work on this board..

#1024 RE: Windows XP SP3 32bit and modern PC parts by diderius6 10.07.2019 14:50

I just see, that the Universal BIOS Backup ToolKit 2.0.exe reads out only 16Mbyte (I compared 2 times)
but the Bioschip 25Q256JWEQ is 32Mbyte!!! So, on 256 Megabit Bios chip forget about this tool!
(EDIT: May be, that the Bios was before 16 Mbyte. And this information is written in header and the rest may be only FFFFFFFF..
In this case, I have a working Bios file.EDIT2: No, the Bios is always 32 Mbyte. The Tool Universal BIOS Backup ToolKit 2.0 does not work for this BIOS. )
I make a try with Epromer tl866ii plus to read the chip out, but fail.
I solder 8 cables, check check check each one for good contact, ok, works.
But even without cpu, ram, cmos battery,
the Epromer told "unknown chip" (but Pin check is ok) and reads out only FFFFFFFFFFFFFFFFF...also as serial number FFFFFFFF.
This behavior I know from results with other Bios chips, it just means, that not enough power is left for the insoldered chip.
To solder this Bios chip out will be a hard job, because other solder points are very near.

So I make NO try to write anything to this Bios chip, I also have no valid copy(?see above) from original Bios before.
Now, I desolder all cables, connect cpu, batterie, ram but behavior is the same as before:
The yellow LED is on all the time (ram). I changed to other DDR4 ram, test every slot,
no success, always yellow LED on.
So I wait for my 3700x cpu and then we will see.
No error message has been there when updating the Bios with Asus EZflash tool from version 407 to 7010.
Dietmar

#1025 RE: Windows XP SP3 32bit and modern PC parts by cedar 10.07.2019 17:35

@XPLives

Wow, it is small like a pea on the motherboard.
I need a flash light. It shows 8111H on the chip.
Good info to know, thanks.

After adding my HW ID to Dietmar's driver. Networking is ok now.
The remaining 2 devices still have yellow exclamation mark are
the AMD GPIO device and USB 3.0 driver. If I try to install
USB 3.0 driver on the Standard Enhanced USB controller(installable),
but with no function USB HUB driver.

I got BSOD with USBport.sys error. So mouse on USB 3.0 port not
working, but mouse on 3.1 port works, as USB 3.1 driver works.

Cedar

#1026 RE: Windows XP SP3 32bit and modern PC parts by diderius6 10.07.2019 22:45

I changed the cpu Ryzen 1700 against Ryzen X4 950 on the Asus Prime x570-Pro.
This time nothing at all happens, when I try to start the board.
So I hope for the best, that the Ryzen 3700x (comes tomorrow)
will boot this board. Interesting, if it is possible to flash back to the first, original 407 Bios
Dietmar

#1027 RE: Windows XP SP3 32bit and modern PC parts by diderius6 11.07.2019 11:28

The yellow LED (ram) stays enlighted, even with new processor Ryzen 3700x on the Asus Prime x570-Pro.
So, Asus has done a very bad job on their new Bios 7010 for this board. No flashback Bios no crashfree Bios, all lie
Dietmar

PS: Hope, that desoldering the Bios chips and flash new (with old Bios 407) will help.
Or I put this board away and just stay with Intel.

It is not me, to give up so quick. I just ordered the Epromer REVELPROG IS
who supports the 25Q256JW Bios chip. I hope, that with this Epromer I can flash
the still insoldered Bios chip. Until now, I do not find this Bios chip for to buy.

EDIT: I found this Bios chip at mouser.com and ordered it:
Mouser-Nr.:
454-W25Q256JWEIQ
Herst.- Nr.:W25Q256JWEIQ
Beschr.: NOR-Flash spiFlash, 1.8V, 256M-bit, 4Kb Uniform Sector

EDIT2: After long search I found also a socket for this Bios Chip
Description
The socket is designed for chips with WSON8 6*8 mm package. The socket can be soldered directly on the WSON8 6*8 mm PCB foot print. Will be not easy to solder.


#1028 RE: Windows XP SP3 32bit and modern PC parts by diderius6 13.07.2019 14:45

I succeed to flash the original Bios 407 back to the Asus Prime x570-Pro board.
The serial number of the Bios chip 25Q256JWEQ is EF6019.
Uefi tool shows this as a valid Bios, 16 Mbyte.
I test this 2 times. All seems ok. I also read out before the "new" Bios 7010, Uefi tool show this as valid Bios, 32 Mbyte.
I reset Cmos, put the Ryzen 1700 in, which works there before.
But the yellow LED (ram) continues to shine. I test different DDR4 rams, in different slots. Always the same,

Dietmar

EDIT: I just order a new board Asus Prime x570-Pro.

#1029 RE: Windows XP SP3 32bit and modern PC parts by diderius6 13.07.2019 18:55

This message I send to Asus:

"Dear Sirs and Madames,
5 days ago I bought an Asus Prime x570-Pro.
The CPU is Ryzen 1700. Everything worked with it.
A bios version 407 was indicated to me.
I have made a backup of this bios,
however, it does not work, possibly because of the wrong size 16 Mbytes, since the new updates all have a size of 32 Mbytes. The biochip is Winbond 25Q256JWEQ (Wson 8 * 6, 8 pins).
With this Ryzen 1700 CPU I have updated to the Bios 7010. The update via USB stick was normal, means works full until the end, without any error message.
After that I could not start the board anymore, the yellow LED (RAM) lights up constantly. Other DDR4 Ramsticks in different slots do not change that.
I have also tested the Ryzen processor 3700x, the yellow LED is constantly on.
I would be very happy if you could send me an original Bios 407 with the number for the network card, etc.
I have experience in biosupdate and can flash a bios by eprommer.
Please send me such a bios without the CAP backup,
many greetings
Dietmar
"

#1030 RE: Windows XP SP3 32bit and modern PC parts by diderius6 13.07.2019 19:09

Now I will test the Ryzen 3700x for XP on the
Asrock Fatal1ty AB350 Gaming k4 board,
there I can change the Bios chip
Dietmar

#1031 RE: Windows XP SP3 32bit and modern PC parts by diderius6 13.07.2019 21:09

Yessssssa, nice board Asrock Fatal1ty AB350 Gaming k4 !!!
I think, this is very first time, XP SP3 on Ryzen 3700x.
I update Bios from 5.40 to 5.80.
Size of Bios is always 16 Mbyte.
Even USB 3.1 works, ACPI, lan, sound, STORAHCI, mouse, y-cable on PS/2 and everything else.
The Ryzen 3700x is in Cinebench without any overclock
exact as fast as the 9900k
Dietmar

EDIT: Chipset is not running hot, and also the Mosfets not. Temperature is about 50 degree Celsius
with Prime95, 3DMark2001, Cinebench, Youtube video running all at the same time.
The CPU Ryzen 3700x reaches 78 degree Celsius during this torture , which is about the same as with Ryzen 1700.
Both use 65 Watt.

EDIT2: I just get 143 brandnew updates for XP SP3 from Posready2009:)).

EDIT3: Any overclocking makes the cpu a little bit slower!

EDIT4: Nvme boot of XP does not work. Last time was with Bios 3.30.

EDIT5: With nearly zero load, cpu core is 1.50 Volt (standard settings all). This is not good for cpu long life.

#1032 RE: Windows XP SP3 32bit and modern PC parts by XPLives 14.07.2019 02:33

avatar

@diderius6

Try installing XP with F7 NO ACPI method on the same motherboard.

Will it install XP all the way to first desktop boot or freeze?

Freezes on my Asrock X370. Safe Mode works but very sluggish as if something stalling it and mouse is laggy sometimes.

Any Windows 2000 OS install on Ryzen success?


Maybe try to add 3700X CPU MicroCode to BIOS 3.30 so it works and can use nVME XP boot?

My hope is Intel Ice Lake / Tiger Lake continues same backward compatibility as Z370 so XP will continue to work using 10nm including Windows 2000.

Seems too many compatibility issues with AMD AM4 so far. Intel's backward compatibility is superior.

Intel Sapphire Rapids for 7nm and DDR5 / PCIe 5.0 256GB-512GB RAM support with 8 memory modules I will upgrade then and use XP.

Tired of limited 64GB memory max with 4 slots instead of 64GB DDR5 memory sticks and 8 slots to match the 16 Cores / 32 Threads.

#1033 RE: Windows XP SP3 32bit and modern PC parts by diderius6 14.07.2019 03:02

@XPLives
I have not tried to install "Standard PC" on Ryzen 3700x,
because then you dont get Acpi after.
Only vice versa this works.
The installation works without any crash or freeze.
I noticed another thing: On Ryzen 1700 the STORAHCI driver was faster than the ASM106x.
But on Ryzen 3700x, the ASM106x is faster
Dietmar

PS: Asrock changed whole Bios from version 3.30 to version 3.40.
With 3.40 the problem with lancard is gone, but also nvme boot is gone.
So, in the end I stay with Intel, because those kind of problems I have never seen there.
It is a problem of how the board is constructed. Crazy, how Asrock can to give lancard the same lines as for USB3.1.
On all my newer Intel boards I can do nvme boot of XP SP3 and those crazy problems with Bios updates I match the first time with AMD, brrr.., but ok, now I am again better in soldering..and do crazy things to flash an Bios chip:)).

#1034 RE: Windows XP SP3 32bit and modern PC parts by infuscomus 14.07.2019 06:04

@XPLives

Can you take a screenshot of the A5 BSOD you are getting on X370 in XP?

#1035 RE: Windows XP SP3 32bit and modern PC parts by diderius6 14.07.2019 17:31

@Lost_N_BIOS

Can you please help me to save my Mac adress etc.
from the broken Bios of AMD board asus prime x570-pro?

I make a backup with working Bios 407 with Universal BIOS Backup ToolKit 2.0.exe, which may have wrong file 16Mbyte size which I call 407.
The other is with Epromer full read out after the update, not working Bios 7010 32MByte,
I call 7010.

Dietmar

PS: Both Bioses should have Mac adress etc. from my board and they should be identic.

https://ufile.io/0nlebva8

https://ufile.io/pttbiy9k

Xobor Forum Software von Xobor
Datenschutz