Page 66 of 355
#976 RE: Windows XP SP3 32bit and modern PC parts by infuscomus 03.07.2019 06:58

@cedar

on your XP drive go to c:\windows\system32\drivers folder

check that you have these files

acpi.sys - our patched version - should be about 234kb in size
storahci.sys
storport.sys

if you don't have these 3 files you will get A5 or 7B BSOD

#977 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 08:23

@infuscomus.

They are all there. I put extra copies in driver cache , i386 folder too, just in case.
Windows may or may not look there. I also have a Sp3.cab and a Sp2.cab. I replaced
the acpi.sys in those two cab as well just case.

If I swap the XP installed on Ryzen hard disk to my other Ivy 3470 CPU system. Replace the
newest (Ryzen) acpi.sys , your checksumed version with the one original from XP SP3.

I can run this "new" installed XP (from Ryzen) on the older Gigabyte P75 Ivy system.
So, the newly installed XP seem fully functional on Ivy but BSOD on Ryzen.

On my Ivy system the same storport.sys also run the ahci mode.

I can run XP on Ryzen in standard PC with the same storport.sys and Storachi, but not
APCI Uni or Multi mode.

Cedar

#978 RE: Windows XP SP3 32bit and modern PC parts by diderius6 03.07.2019 08:29

@cedar

I test with Bios version 3806 and 5007 on the Asus PRIME B350-PLUS board,
both work
Dietmar

#979 RE: Windows XP SP3 32bit and modern PC parts by infuscomus 03.07.2019 08:30

@cedar

do you get the same BSODs in XP textmode setup?

#980 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 08:50

@Dietmar

Good to know that, mine is 4023 is somewhere in between, it should work then.

@infuscomus

I got BSODs in XP textmode. and then swap the hard disk to the ivy system. Manually add
acpi.sys, storport, and USBXPSp1. Storachi is already there.

Swap back the HD drive to the Ryzen system. To install Std. mode or lately ACPI multi proc
mode. Ryzen system then let me complete install graphic mode asking bunch of usual
questions.

Name, region time zone etc. till the end. Then XP said install complete, Click finish. quite
smooth, no hiccup. On the Std PC mode. I can reboot back to XP.

On ACPI mode, next reboot is BSOD 7B, so I try reboot again, this time in Safe Mode.
Same thing, also 7B. reboot third time, 7B.

The thing is, it let me completely installed. a bit unusual here .

Cedar

#981 RE: Windows XP SP3 32bit and modern PC parts by diderius6 03.07.2019 08:57

@cedar

storport.sys is gone on reboot
Dietmar

#982 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 09:16

@Dietmar
storport of course is always gone, after txtmode BSOD. After manually added after txtmode BSOD,

it stays there. Is it not? Do you mean every reboot?

#983 RE: Windows XP SP3 32bit and modern PC parts by infuscomus 03.07.2019 11:54

@cedar

during xp textmode setup do you ever see something like this?



as in, does storahci ever load?

#984 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 16:15

@infuscomus

I did see a textmode screen. and can choose which partition to install to. Whether the
word " Storahci" appeared at the end of the sentence. I am not sure. I will install again
to see if it is there.

I installed 3 times successfully at graphic mode. After textmode complete installed,
BSOD is expected. I knew that. If I don't use the checksum version, it will complain.
otherwise it proceed to complete textmode install. Windows folder size is about
550 MB in size after this

After textmode installed. I add Storport and USBXPSp1. Next reboot, Windows let
me install graphically with mouse working till the end. XP will say setup completed.
Ask to click "Finish" button.

On next (final) reboot, BSOD 7B. This I don't expect is normal!.
BSOD 7B with this message

(0xF78A2524, 0xC000 0034, 0x00000000, 0x00000000)

Try a 4th boot in safe mode, message "slightly changed" to

(0xF789E524, 0xC000 0034, 0x00000000, 0x00000000).

Windows folder size now is about 800 to 900MB. and Storport is here in system32\drivers
folder after "Graphic Mode" completed. I swap HD verified that Storport, acpi, Storahci
are all in system32\drivers folder.

This Ryzen XP installation will boot ACPI in my older P75 (z77 clone), with 1 file acpi.sys
replaced. So I am sure the XP is fully functional.

I will install a 4th time, may be in MPS or other mode and see what happen.

Cedar

#985 RE: Windows XP SP3 32bit and modern PC parts by diderius6 03.07.2019 17:01

@cedar

I think, the acpi.sys is restored to the original one.
You only have to change this original acpi.sys (5512) against the modded acpi.sys (5048) one time more,
Dietmar

#986 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 17:50

@diderius6

It is not ver. 5512. This version got me to Std. mode only.

I used the newest jun 29 version on the burnt disc for the 3rd successful installation.

Another older disc with jun 26 version from a week ago, I got the first 2 successful installed
at textmode. and then I replaced the older jun 26 version, in \system32\drivers
with the newest "jun 29". This let me boot again to install graphic mode successfully.

I did it twice to 2 different partitions. Both success completely installed. But both XPs
BSOD on next reboot. Safe mode BSOD too.

On 3rd installed, I burn a new disc last night contain latest jun 29 version. Textmode and Graphic
mode installed fine. Hoping it differs this time.

But still BSOD after successful XP installion. Safe mode too. I am a bit confused now.

Cedar

#987 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 17:55

@diderius6

Does it work in MPS mode? Or it is not meant to work in MPS mode.

Cedar

#988 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 18:00

@Dietmar

I checked every time after installation. I have no version 5512 in any folders. All acpi
are jun 29 lastest version.

Cedar

#989 RE: Windows XP SP3 32bit and modern PC parts by infuscomus 03.07.2019 18:10

@cedar

MPS has never worked for me

have you got a storahci.inf in c:\windows\inf ?

#990 RE: Windows XP SP3 32bit and modern PC parts by cedar 03.07.2019 18:19

@infuscomus

Hmm... there is no storahci.inf in my inf folder!

Cedar

Xobor Forum Software von Xobor
Datenschutz