Page 1 of 2
#1 [Request] Modded BIOS for Medion PCGA-Z170X-Gaming 7-OC by Kris1967 15.10.2018 16:34

Hello,
I have been trying to get KabyLake to work on this motherboard. I made backup bios with AfuDos, I used MMtool to patch cpu microcode nothing else, flashed back with AfuDos /GAN but its not working. Motherboard must booting from backup bios in dual mode. Medion will not provide an upgrade. I attach a file with the bios. Could you help me please ?
Greetings

Original last bios from Gigabyte is F22m, can i write it to my board? how to do it?

Edit by Fernando: Thread moved into the "BIOS Modding Requests" Sub-Forum and thread title customized

#2 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 16.10.2018 06:52

avatar

What is Medion Gigabyte board? Is this some OEM, custom gaming type builder? Is the motherboard actual z170x Gaming 7, not stripped down OEM type?

AFU Backup or flash is not good, toss that and don't think about AFU again for this. Intel Flash Programming Tool (FPT) is better to use for this.
What is your current Intel ME version (Look in device manager, or check with HWINFO64)

Do you have flash programmer (Hardware, like CH341A)? I can help you flash Gigabyte BIOS to your board without tools, by editing the Gigabyte BIOS to match your current boards ID, but you would have to do that each time you want to BIOS update.
Or you could purchase CH341A flash programmer + SOIC8 Test clip cable ($2.50 + $3.50) - or kit like EZP2010 or EZP2013. Then you can program any BIOS you want, any time.

#3 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 16.10.2018 10:11

Big thanks for Your reply :-)
I will make a copy of the bios using fpt and I will join to my post. This board in fact is Gigabyte z170x Gaming 7 OEM for Medion. I do not have a programmer I'll probably buy one, but the chip is soldered to the board. If this is not a problem for you, please modify this bios gigabyte for me and describe how to do it later.
Can I read curent boards id in AMIBCP?
Greetings

#4 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 16.10.2018 12:35

avatar

You're welcome! For programmer, they are cheap but take long time for delivery if you buy cheap (3-5 weeks or so), and the clip and cable will take care of you for soldered on BIOS that is why I mentioned it too.
There is other ways, solderless I mean without having to use a clip and cable, but it costs substantially more ($20-25 I think, but faster shipping than from China) If you want to know about that let me know I will link you, otherwise put in an order on ebay or elsewhere for CH341A and SOIC8 test clip and cable.

You may not need them, but they're so cheap, best to order now so in case if you do need it will be on the way, otherwise if not you'll be ready next time you might need to save a board from bad flash or flash in a stubborn modified BIOS.

Yes, you can read the ID in AMIBCP 5.02.0023, in the last tab on top "BIOS Features", it's the "BIOS Tag" That is what I will change, maybe 3-5 places in the BIOS, I forget exactly right now but will make you a list as I do the mod.

Did you use this command for the FPT dump? >> FPTw -d MEDION.BIN
Just curious, seems like a full dump and fully unlocked FD, surprising to see

Will edit in BIOS soon

FYI, the reason Kaby was not working was likely due to Intel ME was very old 11.0 in your BIOS, needs to be 11.6 or higher for Kaby. Your BIOS did already have the correct microcodes.
If you want, I can update your BIOS ME instead, that will maybe be better for you in the long run, so you wont have to edit BIOS next time around (ME wont get back-flashed by their next BIOS update)

#5 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 16.10.2018 16:43

Yes :-) it is full dump, fpt -d option, is it danger for me?
Now i know why kaby don't working. Please update my bios with Intel Me :-)



Okay, I'm still learning - is this for me Intel CSME 11.8 Consumer PCH-H Firmware v11.8.55.3510 ?
Next: Can I upload CSME 11.8 to board by FWUpdate?
Next: OK update done.
Next: KabyLake still not working error 62 on board - maybe too old graphics driver (IGX) 9.0.1042 ?
Next: AMIBCP crashing after click save (problems with Gigabyte bioses?)

I must write to flash Gigabyte bios this is my chance, I will be waitng for your mod.
Greetings

#6 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 17.10.2018 07:53

avatar

@Kris1967 - apologies for the delay! No, FPTw -d is not bad, usually FD is locked so dumping full BIOS like that often does not work for people is all. Did you verify ME went to 11.8 after your update?

Sorry, I forgot to mention, vBIOS/GOP also probably need updated too (Not driver, this is part of BIOS). However, I checked just now and they are both already updated to a minimal sky-kaby version, but I will update them further just in case.
I will do that for you too tonight, update BIOS with ME 11.6 (not sure if 11.8 allow this or not without being put in by company, you can test update to 11.8 later).
Since you already flashed to ME 11.8, you probably will need to use FPT to backflash ME version, FW Update tool will not allow that. I will send put clean settings transferred ME 11.6 into BIOS, and update vBIOS/GOP to Sky-Kaby.

I noticed _FIT_ table is broken/missing from the Medion BIOS, it's there, but not referenced properly in last VTF is missing (Incorrect address). This can be viewed with UEFITool NE Alpha.
I have corrected this as well, this may be the sole reason Kaby isn't working in the mod you've done already, due to this Kaby microcode probably would not load because FIT table is broken/missing due to the VTF not being correctly configured (pointing to incorrect FIT table location)
I think your BIOS as-is, aside from the issue above and needing ME 11.6 (Maybe 11.8 OK, but test 11.,6 first) is all that's needed for Kaby to work. I put BIOS below with only this correction, if you use after flash update ME again to 11.6 or 11.8 then retest with onboard graphics.

AMIBCP 5.002.0023 works fine here, I test edited a few settings and saved, no issues. Maybe you used wrong version? Or you didn't wait long enough?
Sometimes on larger BIOS like this you have to wait while it seems frozen/not responding, it's only like that maybe 30-45 seconds depending on your setup.

Please do not use below commands randomly with BIOS or ME, you can brick your board very easily if you use FPT incorrectly, so be careful

Here is Gigabyte Z170X-Gaming-7-F22m Modified with Medion BIOS tag. This can be flashed with Qflash from within the BIOS, if asked do "full update", if not asked, reflash twice or check to ensure ME is updated to 11.8 by the BIOS itself
Once both flash complete, load optimized defaults and boot to windows, then shut down and put in other CPU. With this test, use onboard graphics temporarily, in case PCIE needs patched. Once confirmed working, you can then test with PCIE GFX Card
https://www.sendspace.com/file/cro2k8

And here is heavily modified Medion BIOS
ME to >> 11.6.20.1221
CPU uCode to >> 906E9 Platform 22 Rev 48 << This is old version, but we can update later to latest once all is OK.
GOP to >> EFI GOP Driver SKL-KBL - 9.0.1056
vBIOS to >> 1037
GbE >> 0.2 << If you loose LAN connectivity but Kaby works, we can put this back to original, I only changed in case it's possibly part of the issue.
Last VTF (Volume File Table, very last module in BIOS, last RAW entry viewed with UEFITool) corrected + FIT Table re-corrected once microcode update changed

Please flash via following commands for this above BIOS. >>> FPTw -rewrite -ME -f modMedion.bin << this will backflash the ME with older 11.6 version I include in BIOS. Once that is done run this command from same command prompt >> FPTw -greset
System will then reboot. Once it's done, go to windows and run this command to reflash the BIOS > FPTw -f modMedion.bin
https://www.sendspace.com/file/zyoxy7

And finally, here is barely modified Medion BIOS, with only VTF/FIT table fixed, so mircocodes load properly. With this BIOS, I think, you may be able to just update ME using MW FW Update tool with old CPU in, then reboot and install new CPU.
I made this because some of the mods (vBIOS/GOP changes are in a protected region of the BIOS, and I do not know if these will cause boot failure for you or not, so this BIOS without those would be quick test otherwise)
You may want to test this one/method first, if you do not have hardware flash programmer or have not ordered one already (least risk of bad flash, easy recovery here if necessary)
https://www.sendspace.com/file/s5cx91

All BIOS above should be able to be flashed with Qflash from within the BIOS, for informational purposes I say this, flash via FPT as mentioned above for the most part initially.

#7 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 17.10.2018 11:20

Houston we have a problem, The Medion Bios dont have q-flash option (it is protecting the bios from unauthorized access). Can I write gigabyte mod by FPT?
FPT -f -noverify ?

Next: I flashed medion barely bios - not working error 62 on kaby.
I think it is problem with medion backup and I think only Gigabyte bios can fix this but I can use only an external flasher program.
PS. Bios booting time is veeeery long.
I have a first backup from mobo without any modification made by @bios (gigabyte windows flasher) maybe it is good for modeing?

#8 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 17.10.2018 12:57

avatar

@Kris1967 - Sorry, I didn't think to check and see if they removed Qflash or not. Yes, all can be done with FPT too.
So, even F8 from within BIOS, or End key at boot instead of Del can't get you to Qflash?

Which BIOS do you want to try first, then I will give you FPT command to use. No need for -noverfiy

Medion backup? You can reflash main and backup BIOS to match, unless they removed that too? At startup, where you normally hit Del to get into BIOS, keep pushing ALT+F10, if you get boot menu reboot and try some more.
Sometimes you have to use PS/2 keyboard, if you do not have that, make sure USB is at least in USB 2.0 port if there is one, if not 3.0 not 3.1.

It could just be that Medion Barely BIOS is not as fully ready as I suspected though, but it does look ready once you update ME.
You did update ME again to 11.6 or 11.8 after flashing it correct, before putting in Kaby CPU? Kaby wont work on that BIOS, if it's going to, until you do that

No, @BIOS is only good for uninstalling, I mean that's all you should do with that app Unless you have flash programmer in your hand and can recover from bad flashes.

I forgot about Dual BIOS, if you use the Gigabyte BIOS, you should probably flash that in DOS with EFIFlash and the /X or /Z switch so it reflashes both BIOS at once

FPTw -f biosname.bin <<< This flashes entire BIOS
FPTw -me -f biosname.bin <<< This flashes ME region only. If you are updating ME, from one of the BIOS I sent with updated ME inside it (Gigabyte BIOS, or Medion Heavy), do this first followed by >> FPTw -greset and system will reboot. Then follow this with above command to flash entire BIOS after that
FPTw -rewrite -me -f biosname.bin << This fully erases ME region and rewrites the entire ME region with ME contained within BIOS file. When going backwards, for example from 11.8 to older version, I would use this, flashing forward not as important.

DO NOT use FPT to flash ME with a 1.5-2MB ME file by itself, those files cannot be used with FPT only ME FW Update tool

#9 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 17.10.2018 13:18

No qflash - f8 and del or end not working (medion intellectuals)
Of course I did update to 11.8 after update Medion Barely - error 62 Kaby. I think maybe its dual bios problem.
Alt +f10 not working
Should I write Medion Barely by Efiflash /x /z or FTP -f?

#10 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 17.10.2018 13:27

avatar

Del doesn't work either? How do you enter BIOS? I checked internals just now, and they ripped out Qflash, so yeah not gonna be an option no matter what.

ALT+F10 doesn't work for a lot of people on Gigabyte either, you have to get it just right, keep trying and I bet you get it (Maybe they ripped that out too, but I kind of doubted that since it's well hidden)
I checked I/O and see PS/2, so use that if you have one, it will work much quicker with that. If you don't have one, use the red USB Port under LAN

You can try EFIFlash with Medion barely, use the /X switch, if you don't see it update both BIOS (it will say on screen once done with main, backup will follow), reboot and try again with /Z switch
EFI Flash may not work either? Do they send a "DOS" flasher with their BIOS update package?

If you try more on Medion barely, after updating to it again use FPTw -rewrite -me bios.bin with one of the other BIOS I sent you (Gigabyte or Heavy), so you can backflash from ME 11.8 to 11.6 instead
This will only flash the ME Region from within those files, similar to if you use ME FW Update tool, but this ME will already have settings in it which are not there when using FW Updater

11.8 might not be working without special settings already programmed into ME 11.8 from manufacturer kaby ready (Not included with default stock ME 11.8) - just a thought, something to try

#11 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 17.10.2018 13:43

Efiflash invalid command /x /z
Sorry OK - command must be after bios file

#12 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 17.10.2018 13:50

avatar

Yes, sorry for not specifying that, EFIFlash.exe BIOS name /x or /z (Sometimes /y too - seriously)

#13 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 17.10.2018 13:55

It is my mistake - OK
Efiflash info - / x main bios is writen and what to try now FW update or Gigabyte bios mod?
Only main bios was flashed /z not working
Next: OK - success Gigabyte mod working! Big Thx!
Next: What with PCIe, how to fix it?
Next: PCIe working - my dvb PCI tuner on PCIe adapter is OK
Update for HTPC is done.

And big thanks for Your precious time!

#14 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Lost_N_BIOS 18.10.2018 05:15

avatar

@Kris1967 - So what was the final fix there, did you ever try the heavy Medion or no? And, still no way to update backup BIOS to match main? Even when flashing in Gigabyte BIOS?
If you're on the Gigabyte BIOS now, then ALT+F10 should be working for sure, keep trying via USB under LAN or it's easy if done with PS/2 keyboard (Not USB to PS/2 adapter)

What about PCIE? I assumed it was same board, there may be issues if board layout is not exact same as the original Gigabyte board. You got that sorted out now?

SO Kaby working, and Gigabyte official BIOS, great outcome without a programmer! Now, remember next time you update BIOS, you will have to edit the Gigabyte BIOS again to have the Medion ID.
Uunless you end up purchasing a programmer and clip/cable, then you can program it on there with your LAN ID edited into BOIS.

You're welcome, sorry I presented so many options for you Maybe should have stuck with thing one at a time until finding solution, but since you didn't have programmer in hand I wanted to let you decide which way to go first.
I would have done the straight to Gigabyte first, but only with programmer in hand in case recovery needed, and I didn' want to leave you stuck in that position unless you choose it yourself after seeing all possible options.

#15 RE: [Help] Medion (gigabyte) Board z170x Gaming 7 bios update problems by Kris1967 18.10.2018 09:50

I did not try the heavy Medion - it was too dangerous in my mind ;-)
I did not try flashing backup chip - it was too dangerous in my mind ;-)
But I'm not saying I will not do it ;-)
Q-flash must working now, I will try
So many options is not bad for me, because it forces me to thinking and learning. Now I,m a little wiser ;-) and I will buy a programmer.

Thx again
Greetings

Xobor Forum Software von Xobor
Datenschutz