Page 5 of 10
#61 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 21.12.2018 12:45

avatar

@pedro77 - Slide a piece of paper or thin plastic between the battery and that metal clip on top, then press and hold power on button/switch for 10-20 seconds, that should clear the CMOS. If that is a battery? If it's not, then CMOS battery might be on other side.
I checked BIOS, and only see CMP Support (like HT I think, setting above HT), and all the C state settings (and enhanced C State), C6/C7, Turbo, no speedstep or EIST

Do you have "Full menu Access" set/enabled in that BIOS, I can't tell what the default option is?

@FPSUsername - In the package Pedro linked above, you can edit the ME inside that BIOS (or have me do), and then edit the platform.ini file that controls the flash process, near the end is UpdateME flag, set to Flag=1, directly below that is the SPI (FD) control, set ME to 1
To fully unlock the FD, set FD to 1 while you are there, and then before you flash BIOS edit the BIOS FD to be fully unlocked at line 60 via hex

#62 RE: Microcode Update of Insyde UEFI BIOSes by FPSUsername 21.12.2018 18:25

avatar

@Lost_N_BIOS interesting find. I am not sure what you have to edit for the ME inside the bios, but a simple unlock would be enough to ensure that I can update from 6.2.31 to 6.2.50 using the MEI FW updater.
The bios in @pedro77's post is the bios from post 14 which is a stable build, so it would be great if you can unlock it.

For now I edited this in the platform.ini file:

1
2
3
4
5
6
7
8
9
10
11
 
[UpdateME]
Flag=1
 
;0 -> Not flash Me.
;1 -> Flash Me.
 
[Region]
BIOS=1
GbE=0
ME=1
DESC=0
 



I don't know where a "FD" flag should be, I did a search through the file, but I'm not sure what part you are referring to.


To make post #59 clear to you:
Post #17, Update Error
Post #29, Can't update from 6.2.40 to 6.2.50 and more broken things

Edit: @pedro77
Stable as in stable on my laptop. I don't know why you would disable hyperthreading in the first place as you will lose a ton of performance
You should be able to boot into the bios and reset it, right?

Oh and, the dev that modded the bios over at bios-mods didn't test it either. The bios from post 14 is an "iteration" on that bios with updated microcode for the cpu.

#63 RE: Microcode Update of Insyde UEFI BIOSes by pedro77 21.12.2018 18:29

@FPSUsername I didnt know it was untested, I was simply tinkering with it, in fact I got it mixed up with virtualization, and didn't see what harm it would do. If that is the problem, then it will need to be hidden, again it's going to take some time I need to get a soldering iron. To remove it. No I can't see anything, it turns off after 30 seconds even in emergency flash mode.
http://www.tomshardware.co.uk/answers/id...rthreading.html

@Lost_N_BIOS If I find out what setting it was, some things may have to be hidden i.e. quick boot, HT. I don't think it was a bad flash as after flashing I was able to boot into bios settings and adjust, on saving and exiting and rebooting the problem started. A bad flash wouldn't result in this type of behaviour as it auto shuts down even in emergency flash mode.
I would say we have full access to the menus possibly more than is necessary. It's the same as 5741g

If I can get this working again, I will test it all and tell you what to hide.

I'm having no luck resetting the bios. I have tried shorting the points as in this video. The battery in this is the same as the last one in this video. You can't put paper in between it's been stamped on, it would have to be underneath anyway as this is the + side. I don't have a soldering iron and it's going to take time for it to arrive.
https://youtu.be/scpy4jH6HY4

#64 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 22.12.2018 08:29

avatar

@FPSUsername - FD - sorry for not being clear, I meant this
[UpdateME]
Flag=1

[Region]
BIOS=1
GbE=0
ME=1
DESC=1 << = FD, but you need to edit the FD of the BIOS file first, it's in line 60, as you see in this FD Unlock guide second spoiler first image in Section B

Please wait on the ME, I am looking into getting this sorted out for you with Plutomaniac's advice, or by making an older/current ME (.40) BIOS for you with AMT enabled, that will then allow you to reflash ME via AMT/MEBx
Seems UPD files and ME FW Update tool are the only way to update ME on these, aside from a BIOS dump/transfer.
I asked him about the settings I found in your BIOS *Ignition ME Protect + Ignition ME Check Inform), I think that first one might be/allow the local reflash, if not it's a setting within the ME that can only be active when AMT is enabled that;s why I mentioned AMT enabled ME if necessary.

@pedro77 - wouldn't matter if it's + or - side, breaking that connection would break the circuit, but I guess no deal since that blade is soldered on there.
Did you try, with main battery and power removed, short power on pins, or press power on button for 10-20 seconds, then see if that drained it enough to clear CMOS, sometimes that will work.

#65 RE: Microcode Update of Insyde UEFI BIOSes by FPSUsername 22.12.2018 11:30

avatar

@Lost_N_BIOS Thank you for your effort, I'll wait for the two unlocked bioses with .31 and .40

#66 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 22.12.2018 11:55

avatar

I thought you wanted .50? Well, some BIOS unlocked so you can use ME FW Update tool to update to .50

#67 RE: Microcode Update of Insyde UEFI BIOSes by FPSUsername 22.12.2018 11:57

avatar

Yes, .50 can only be installed with the mei update tool, so I'll wait for the unlocked variant and then update using the mei update tool

#68 RE: Microcode Update of Insyde UEFI BIOSes by pedro77 22.12.2018 14:10

@Lost_N_BIOS
Removed battery and AC then tried pin shorting; didn't work. Then tried holding the power button for 30+ seconds and that didn't work either. Looks like the battery has been stamped on there are two tiny idents on the metal contact itself which I couldn't remove. Pity there is not a file to flash via emergency flash to reset the settings, would only take a second to apply well before it would auto turn off.

#69 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 23.12.2018 07:17

avatar

@FPSUsername - I heard back from Plutomaniac and he thinks that one setting I mentioned is probably the one blocking ME FW update tool from working, he said probably that or MEBx. And I do see a setting to enable/disable local FW update via MEBx, but it's only enabled as a function when AMT is enabled in BIOS.
So, if this other setting change does not help (ME Ignition protect), then we can try an AMT enabled BIOS and then you will have access to the setting within MEBx to enable/disable Local ME FW update via FW Update tool.

For now, since we do not need/want to update ME from the included BIOS package, leave the ME here on 0, but set Desc/FD to 1 or use package file I sent.
If we end up having to do the AMT enabled ME, then we'll put that back to 1 on both below
[UpdateME]
Flag=0

;0 -> Not flash Me.
;1 -> Flash Me.

[Region]
BIOS=1
GbE=0
ME=0
DESC=1

Here is edited BIOS based on package pedro77 posted at #58, this has unlocked FD region and ME Ignition protect disabled.
First, flash using the Insydeflash.exe and then reboot to BIOS, load optimal and then come back into windows and see if you can dump FD and entire BIOS via FPT
FPTw.exe -desc -d FD.bin << Check this file, at line 60 Do you see 00 00 FF FF 00 00 FF FF 18 01 FF FF Or or do you see >> 00 00 0b 0a 00 00 0d 0c 18 01 08 08 (if you see the FF's, then flashing the FD worked, you now have unlocked FD)
FPTw.exe -d bios.bin << If entire BIOS dumps 4MB, without error, then FD unlocked

http://s000.tinyupload.com/index.php?fil...521286095884356

If still same error, let me know and I will redo, I may need to switch the value locations as well as set the enabled bit, I couldn't tell since some of the default enabled settings are switched around and some are not

Can you guys both see all these menus listed below, inside the "Advanced" section? "User Access" level looks to be set to "View Only" so I can't be sure what is visible to you or hidden etc. (BIOS included in above with "Full Access" Set as default)
And more specifically on this ME issue, can you see the chipset one? If not, I can enable I think! This is where the ME settings are contained.
Currently, looks like it's under suppress and gray out, but controlled by variables so not sure if you guys can see or not. but I can take these outside those suppress/gray out constraints

Boot Configuration, Form ID: 0x21
Peripheral Configuration, Form ID: 0x22
IDE Configuration, Form ID: 0x23
Thermal Configuration, Form ID: 0x24
Video Configuration, Form ID: 0x25
USB Configuration, Form ID: 0x26
Chipset Configuration, Form ID: 0x27
ACPI Table/Features Control, Form ID: 0x28

@pedro77 - If you can find the board schematics then I bet there is two points on the board to short to clear CMOS. Can you give me any/all numbers printed on the PCB, so I can try to find the schematic for you
I was thinking maybe that one that you can follow the white lined trace going off to the right and up a little bit to those two exposed points (C147), but it's just something I was guessing on while looking at your image. You could short the battery itself for a few seconds, but it's better if we can find another way
Actually, here is schematics for both LA-5891P and LA-5892P boards, but I can't tell how to clear CMOS or RTC / reset etc. Maybe you or FSPUsername will be able to better decipher these schematics. I see LA-589 on the image you posted, but unsure if it's 91P or 92P, but assume one of these should help.
http://s000.tinyupload.com/index.php?fil...125708503330251

I see ME pull down (GPIO33 Pull Down) marked out in here, this can be used to disable ME which would allow FPT flash ME if we had a usable .50 RGN file. But, I think we will solve this eventually via the routes mentioned above.

If you can enter the BIOS, load optimal should reset any changes you made, that would fix it too I think. In the platform.ini there is a setting you can change to clear CMOS during flash >> [Others] ClearCMOS=0 (<< Set to 1)

#70 RE: Microcode Update of Insyde UEFI BIOSes by FPSUsername 23.12.2018 16:41

avatar

@Lost_N_BIOS I'm getting "Error: Region Map not found." when using insydeflash on both FullAccess-Set and the other one you included.

#71 RE: Microcode Update of Insyde UEFI BIOSes by pedro77 23.12.2018 19:39

Soldering iron came today I just removed the battery completely, still hasn't cleared after a few hours, will leave over night. If you read this, doesn't look good
http://www.tomshardware.co.uk/forum/7902...-corrupted-bios

I don't understand schematics + I don't have a pc working to look at them.

Looking like my motherboard is fried.

#72 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 24.12.2018 07:16

avatar

@FPSUsername - are you using the packages as I sent them? If yes, try adding /PR to the command, so run from command insydeflash filename.fd /PR

If that does not work, it must be due to some protection, unless in @pedro77 mod this package he removed something? I'm not sure what he modified?
Can you flash that BIOS package from post #58 as it is, without modifying the BIOS or platform.ini? If yes, then it's something to do with a protected region and you'll either have to do pinmod or get a programmer to get around this FD lock.

#73 RE: Microcode Update of Insyde UEFI BIOSes by FPSUsername 24.12.2018 12:54

avatar

@Lost_N_BIOS It only gives me that error when I set "Desc=1" in the platform.ini file. I just flashed your full access bios with a stock platform.ini

#74 RE: Microcode Update of Insyde UEFI BIOSes by pedro77 24.12.2018 14:59

@Lost_N_BIOS I didn't remove anything, just swapped out the .FD file. I did notice however when running the .exe there is a dos window that pops up first before the inside window pops up. I doubt it's doing anything important but worth noting anyhow.

@Lost_N_BIOS
@FPSUsername Update: I did desolder the battery from board and disconnected it completely and left it overnight but it still doesn't work.. I also noticed when in emergency flash mode, the light on the usb doesn't even flash anymore so it's fair to say the board is toast. I can only assume it was disabling hyperthreading although it could also have been enabling fast/quick boot too, the latter being less likely. I can only assume it was modifications to the bios that have cause it, maybe microledes or something. I don't believe a simple unlock of the bios could result in this occuring. In any event I'll have to look for another board to replace it as I can't think of anything else to do with this one??

#75 RE: Microcode Update of Insyde UEFI BIOSes by Lost_N_BIOS 25.12.2018 07:02

avatar

@FPSUsername - I thought that probably had something to do with it, without that edit the FD is not written to, seems some other change is probably needed to enable FD write with the stock flasher (Map edit, or adding that map file, or some unlock in the BIOS itself too)
You can enable "Options" or flash method flag=2 on one of those settings in there (can't remember the exact name) and it adds an option box to the window that comes up, with many of the same settings within that platform file, but some are missing and nothing new/good in those options.

Any change in presented settings with the "Full Access" BIOS? Neither of you guys answered my question about that list within advanced section I posted above @ #69
And, now that you flashed in this ME settings changed BIOS, even though the FD is still locked, this should also mainly affect the ME FW Update tool, can you use it now, does it give same error if not?

Thanks @pedro77 I assumed you didn't change much, but wasn't 100% certain since you said modified package.

Sorry to hear about your board! Did you put the battery back correctly now? I agree, all this from changing BIOS settings, seems that can't be the final outcome! Neither of those settings enabled or disabled should cause a non-boot, even if CPU didn't support it
Get a programmer and re-write the entire BIOS, I bet that will fix it. Since you have the board out now, you can do the pinmod and fully unlock the FD, then you wont need programmer, if you can still boot to DOS(?).
Did you look into that yet? Pinmod is in E.1 here - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
If you can't boot at all, then you'll need a programmer and cable, only costs $5 total for both but it's a long wait for delivery at that cheap price.

Xobor Forum Software von Xobor
Datenschutz