Page 2 of 40
#16 RE: Allow B0 stepping on Asus W621E Sage by mitdal369 18.08.2018 06:40

Alright it flashed but the issue persists unfortunately. It gets to post code 04 and sits there. PCH initialization according to Asus' AMI codes. If I hit reset at that point, it'll cycle through some codes and end with 66 and one long beep followed by two short beeps which indicates a memory error. This was the same issue as before. Any other potential ideas? If not luckily I can still return the board.

#17 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 18.08.2018 10:14

avatar

The only other difference I can see that may matter is ME version. Supermicro has 04.00.04.340 and the Asus has 04.00.04.288 (I assumed it would have been the other way around, older ME supporting/allowing the XEON)

You can update to that version, by first cleaning and transferring settings from your current BIOS/ME to that version ME using this guide
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

I am unable to find that version to download, so you would need to extract it via UEFITool and then clean and settings transfer via the guide. I can do that if you need, but I would only feel comfortable doing that if you already had a flash programmer in hand to recover in case of a bad flash, due to I've never worked with this Intel ME type and the guide specifies it may not cover all settings/necessary info. I could transfer manually from your boards ME to the other ME though, one setting at a time, no guide needed for that it just takes much longer, but still I'd really prefer you have a programmer in hand in case something goes wrong.

If you want to do that, order a CH341A flash programmer, since this is limited time before you can return you may need to purchase one locally for $8-12 or something vs $3 if you order from China and wait.

#18 RE: Allow B0 stepping on Asus W621E Sage by mitdal369 18.08.2018 20:14

Hey Lost,

Would it matter if I have the flash programmer in this case since there isn't a removable BIOS chip on this motherboard (at least as far as I can see)? In the past when I've worked with similar devices its needed me to take the chip off of the board and put it on the programmer. Is my assumption that this would work the same way correct?

#19 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 19.08.2018 20:45

avatar

Can you show me a few good images of the board so I can see if I can locate the BIOS, Asus is usually removable, but I normally only see Desktop boards. If it's soldered on you'd just need a test clip jumper type cable to use with the programmer.
Never mind, I see BIOS here and it's QFP package, so test clips can't even be used on that. https://images.anandtech.com/doci/11960/ics.png

Can you tell me if you see a unlabeled/undocumented in PDF header with 8 pins? If yes, you may be able to use an adapter I can show you on ebay, it's used to boot from BIOS on a chip (MSI have similar JSP1)
Possible suspect to me is header directly next to the debug LED (under jumpers), or the one right next to that one.
https://images.anandtech.com/doci/11960/boardfront.jpg

#20 RE: Allow B0 stepping on Asus W621E Sage by mitdal369 20.08.2018 02:01

Took a look and the one directly to the right of the debug LED is a VPP_I2C1 header used for Intel VMD and associated sensor readings and the header to the right of that is a USB header. I compared the board to the documentation and I believe every header was accounted for unfortunately.

#21 RE: Allow B0 stepping on Asus W621E Sage by oldirdey 20.08.2018 02:46

Board has a SPI Header left to the Chipset Cooler. On the other hand there is a GPIO Header at the bottom right side.

Pinout for SPI Header

Pin#1 - NC
Pin#2 - WP#
Pin#3 - VCC
Pin#4 - GND
Pin#5 - CS#
Pin#6 - CLK
Pin#7 - MISO
Pin#8 - MOSI
Pin#9 - HOLD#

Be carefull if you hook up a SPI Programmer to the Header, some new Asus Mainboards (AMD AM4 for example) have 1.8v Bios Chips. So always take a look at Bios Chip Datasheet before you hook external VCC to the Board.

#22 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 20.08.2018 08:42

avatar

I don't know the pinout of the adapter I have, only that it's made to work with Asus boards and MSI boards, and I have used on both without issue. SPI header would be the one you'd use this for! Or you could also hookup CH341A or other raspberry based programmer via cables.
Here is it's info page, mainly showing MSI based details, Asus is on other side of adapter, but same functions so he only wrote one info guide
http://cafe.daum.net/tualatin/J11z/244

If you want one of his ebay listings let me know, you'll have to message him directly and ask to purchase this item only, he doesn't have any listings up for this only as extra items in his other listings, but he will send/sell separately I've ordered one that way.
He ships from Korea, usually 10-15 days to arrive, and I've ordered 10+ times from him always fast shipment compared to many others overseas shipping

#23 RE: Allow B0 stepping on Asus W621E Sage by mitdal369 22.08.2018 05:09

Dam while that would be handy as hell to have, it would be outside of the return date. I have exactly 10 more days before I have to return it. I don't mind taking the risk flashing it. It seems like there are some others that are in the same boat as me. I've linked em to this post so there may be some other activity soon.

#24 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 22.08.2018 07:39

avatar

So you want a BIOS with the other ME version?

#25 RE: Allow B0 stepping on Asus W621E Sage by mitdal369 22.08.2018 21:11

If you think that may make a difference then I'm down. I was gonna try and go through the guide this weekend and see if I could make the changes myself. How challenging do you think it'll be for a person who's never messed with BIOS modding before?

#26 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 22.08.2018 21:15

avatar

It is generally easy, but I'm only saying that as a BIOS mod person, I don't think it's that hard to follow along though the guide is pretty straight-forward and covers all steps.
However, the guide specifically states it does not cover this type of ME or ME FIT tool, so you would have to do side-by-side and change each setting to match as you go through to be sure all is copied over. I will do it tonight, and see if it looks OK.

*Edit - I just tried, and due to the guide not being specifically for these tools and ME types, and no clean ME files for this specific type and version, I am unable to get a clean error free copy transferred over.
Maybe someone more familiar with ME and CSE SPS Tools could get this copied over for you? @plutomaniac if you have time, would you mind trying a simple transfer from the supermicro board to the Asus board here, thanks!
I keep getting @FPT entry point error on outimage builds (Shown at MCE), and the ME version does not change either (Few settings at top of XML get removed on build when compared to original Asus)

#27 RE: Allow B0 stepping on Asus W621E Sage by levelud 22.08.2018 22:44

I am reading this thread very interessted, hopefully there will be a way to unlock ES Cpu‘s on this Mainboard.

#28 RE: Allow B0 stepping on Asus W621E Sage by maxdata 24.08.2018 07:14

avatar

This is the only useful discussion I've been able to find on the web addressing BIOS for C621E Sage. Mine absolutely refuses to boot with B0 stepping Xeon gold 6149 QLQ9s single or dual, with any combo of QVL RAM, GPUs, etc. So a good chance the ASUS BIOS vs my cpu is the culprit. I have changed out and checked every other component except CPU and mobo. Post slows at q code 14, then cycles and stalls at 66 (PXE initialization).

LOST_N_BIOS I found your file here and it backflashed fine (whereas the ASUS updates do not). But system still stalls at Q-code 66. Based on this info do you have any advice on a further mod that would be needed to recognize a QLQ9?

Also, the system has never booted, there is no OS interface- does the CPU have an Intel ME component I need to clean/modify or is the chipset ME the one needing cleanup?

I wanted performance features of the C621E, but Supermicro X11 looks better now. I have a couple dual X10 boards that run ES cpus perfectly. I am still going to take a shot at getting this to work. Would be willing to try microcode mods on the WS C621E BIOS myself after I get educated here a little more. Please advise concerning QLQ9s- Thanks!!

#29 RE: Allow B0 stepping on Asus W621E Sage by Lost_N_BIOS 24.08.2018 07:42

avatar

Well the OP said he was able to boot his same Xeon on similar system but another brand Supermicro X11DPH-T, and the only differences I noticed right away was the microcode differences which I edited and posted update BIOS of here, and then the Intel ME is newer in the other board.
But, due to this ME type, I'm not able to correctly transfer in a clean settings transferred ME to the Asus. This may not be the solution though, there could be many other things different within the BIOS itself, which I have no way to compare without knowing exactly what makes the Xeon work on the Supermicro X11DPH-T

In cases like this on a normal desktop board, and CPU works on one board but not another, it's usually only those two things (CPU microcodes and then ME not as often)

The BIOS I posted here on post #4 has the matching updated microcodes from the Supermicro X11DPH-T, so if you already flashed that in then you are using the updated microcodes that are known to work on the other board

#30 RE: Allow B0 stepping on Asus W621E Sage by maxdata 24.08.2018 07:44

avatar

Hi MIT, I successfully backflashed my C621E with LOST's mod, but still code 66. B0 xeon 6149s, QLQ9s, this forum looks like the only help around.

Xobor Forum Software von Xobor
Datenschutz