Page 10 of 11
#136 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 30.11.2020 20:47

avatar

Yes, maybe they edited the BIOS and replaced them with original BIOS and kept same build dates etc. Yes, it will be safer to play with all this once you have programmer.
Be sure to get U Type Flat IC extractor too, that way you don't damage BIOS legs removing the chip, they bend super easy and just when you think you've got it out fine without it all goes sideways in one quick flip/smash and the legs are bent all crazy

OK, thanks for current CPU model, I will make you 3805 BIOS to test and we'll see if it's just microcode holding 3xxx series back from using ES
It could be ME FW too, which we can't address without programmer/FPT methods, so if this fails, then you'll have to wait on programmer.

I will edit in mod BIOS shortly, and will then tag you

* Edit @pies666 - Here is 3805 mod BIOS to test - http://s000.tinyupload.com/index.php?fil...104618341661345
Make sure you use the following flags with AFU >> /p /b /n /k
If /K causes errors, OK to remove. /b is most critical, this will flash in the microcodes / boot block
Shut down, then clear CMOS after flash, then boot to BIOS, load optimal faults, save/apply/reboot back to BIOS and shut down then try the ES CPU.

#137 RE: ASUS Z170-A HPET Toggle Option by pies666 30.11.2020 21:05

Thanks! I will give it a try in a moment :-)

Edit: @Lost_N_BIOS Error 22: Problem allocating Memory

Edit2: It's Aptio V and as far as I can see there is only guide for IV available.

#138 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 30.11.2020 21:39

avatar

Sorry, I have no idea what guide you're talking about? But, any AFU Guide about flashing BIOS applies same for Aptio IV and V, both flash with AFU same way
You already did this once with AFU, correct? If yes, use same method.

As for the error, if that is in DOS, then you need to create your DOS another way, such as Win98 SE, instead of using "FreeDOS"
See post #3 here, I just made same comment the other day for user on this

#139 RE: ASUS Z170-A HPET Toggle Option by pies666 30.11.2020 21:48

I did it with this guide:
https://rog.asus.com/forum/showthread.ph...1670#post701670

It's some kind of auto-flash so I couldn't put /p /b /n /k options. It worked fine with freedos. I've just downloaded AFUDOS from other webpage (version for Aptio V) and did have that error. I will make Win98 SE instead of freedos asap.


Edit:

@Lost_N_BIOS

I did it with this guide:
https://rog.asus.com/forum/showthread.ph...1670#post701670

It's some kind of auto-flash so I couldn't put /p /b /n /k options. It worked fine with freedos. I've just downloaded AFUDOS from other webpage (version for Aptio V) and did have that error. I will make Win98 SE instead of freedos asap.

Edit: OK, I got it - there is autoexec.bat in that guide.

@echo off
cls

afudos.exe bios.rom /GAN

I will change it to:

@echo off
cls

afudos.exe bios.rom /p /b /n /k

Am I correct?

I might have downloaded some weird version of AFU - this is why it coused the problem. This one from guide was working just fine.

#140 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 30.11.2020 21:56

avatar

You don't need anything else, you used this method previously, so it will work now (meaning you don't need anything about Aptio V)
I will check download package now, I assume you will need to edit Autoexec.bat on the USB stick before you flash, that is where you will add/edit in the flags I mentioned, if not there already.

Yes, there is the issue, this is OLD AFU /GAN method, not ideal, but already too late since you used before, at least you know it does not brick. Anyway, do itsame as you did before, but edit the autoexec file first
Edit autoexec.bat >>> afudos.exe bios.rom /GAN >> Change to >> afudos.exe bios.rom /p /b /n /GAN

* Edit - Yes, like you have above, but use what I mentioned, so you still use /GAN to force the downgrade

There is certain AFU versions that are ES, and allow such things like /GAN and force downgrades, other normal retail ones wont, so you will get errors but the error you mentioned is a DOS one not AFU one.

#141 RE: ASUS Z170-A HPET Toggle Option by pies666 30.11.2020 21:57

So this is almost the same as I wrote in edit above :-)

Gonna check it in a minute.

#142 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 30.11.2020 21:58

avatar

Yes, see my edit above too

#143 RE: ASUS Z170-A HPET Toggle Option by pies666 30.11.2020 22:15

@Lost_N_BIOS
Bios updated just fine. POST to Bios without any problem with G4400. Clear CMOS, restart, power off, swap to ES and ... still black screen.
Mobo does not show CPU error on LEDs but does not POST.
Do You think it's related with ME?

#144 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 01.12.2020 09:02

avatar

@pies666 - Now with G4400 please dump BIOS region with FPT so we can confirm the microcodes flashed in first (if not, alternate command flags will be needed, one at a time maybe, no use of /GAN, alternate method I'll link you to etc)
Please do step #1 of spoiler below, ignore everything else for now this is my copy/paste for how to dump/reflash BIOS region which we're not doing here, just grab ME System Tools V11 and do step #1

And yes, it may be due to ME FW, or it may be due to you need to use old BIOS version as you mentioned (w/ proper microcode inserted back too like we did here).
During the BIOS update, did you see ME FW region mentioned in any output erase/program comment etc?
Are you 100% sure the CPU is functional?

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS' main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section "C.2" find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose "open command window here" (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If "open command window here" does not appear, look for the "Simple Registry Edit" below...))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don't forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds "Open command window here as Administrator" to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you...
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

#145 RE: ASUS Z170-A HPET Toggle Option by pies666 01.12.2020 11:46

@Lost_N_BIOS

I attach HWINFO ME ver screenshot

Unfortunatelly got an error when atempting to dump bios file.

I can't do that in via dos either. There is only FPT.EFI file in Intel CSME System Tools v15.0 r2\Flash Programming Tool\EFI64 (I suppose this is the folder for DOS dump?)

There is only this EFI64 folder (+ Windows and Linux) - no "Flash Programming Tool \ DOS" folder at all.

EDIT: When I want to install "Intel MEI Drivers & Software v2044.15.0.1951 DCH (Windows 10 >= 1709)" it does not work. After decompressing files - SetupME.exe in "SWSetup\SP110984\src" gives me "repair or uninstall" option so i guess I have that already installed.
Also ME chipset installer from Asus webpage gives me "You have newer version installed" information.

EDIT2: I downloaded newest ME Tools instead of 11. My bad. Rechecking atm.

EDIT3: It worked just fine with proper version. I attach link to bios file (too big to upload here): https://files.fm/u/dvv3uxenr

#146 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 01.12.2020 14:02

avatar

@pies666 - You are using wrong FPT. You need to use V11 package for this system. And no, DOS Folder would say DOS
Ahh, you figured it out, nice Please put file in a max compressed zip, and upload to some other free file host, that one is blocked on my end by malwarebytes

#147 RE: ASUS Z170-A HPET Toggle Option by pies666 01.12.2020 14:16

@Lost_N_BIOS

Let me know if this one works :-)

https://gofile.io/d/mIiywN

#148 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 01.12.2020 14:28

avatar

Yes, that worked, and the microcodes are flashed in. So they either removed ES compatibility with 3xxx BIOS, or ME FW needs to be downgraded to 11.0 (this version is in all old up to 3016, then they all start w/ 11.6 or above)
Please now dump FD via this command and send to me >> FPTw.exe -desc -d fd.bin << Never mind, sorry, please hold off on this and do >> flash this BIOS below same was you did last one
This is same BIOS as before, but with unlocked FD, we'll see if that method flashes the FD in or not. Sorry, I meant to do that before and must have forgot!
http://s000.tinyupload.com/index.php?fil...111874557767033

After flashing again, load optimized etc, then boot to windows and run command above, send me fd.bin

#149 RE: ASUS Z170-A HPET Toggle Option by pies666 01.12.2020 14:40

@Lost_N_BIOS

No problem, I flashed right now with bios You uploaded.

I attach fd.bin below.

#150 RE: ASUS Z170-A HPET Toggle Option by Lost_N_BIOS 01.12.2020 14:43

avatar

@pies666 - No dice, stock FD remains
Test once more, with only original /GAN command in autoexec (no /P /B etc) ie >> afudos.exe bios.rom /GAN
Then dump FD again with new name, such as fdnew.bin

If still same, you can compare via hex if you want, then flash programmer or pinmod is required here to test anything further.

Xobor Forum Software von Xobor
Datenschutz