Page 16 of 30
#226 RE: Updated Asus P9X79 Pro with 130125_00_02_00 by kevindd992002 03.07.2016 04:12

Again, I'm not complaining. I was just merely putting a reminder on this thread. It was already answered in the past but with a hint of "possible" newer "modified" version which made me ask again? I'm not sure what's my fault here in asking again. I know I've been very persistent in my questions in the past but this is different.

#227 ASMedia ASM-114x Series USB 3.1 firmware by Korabeu 04.07.2016 20:26

Greetings everyone,

first of all I would like to say I made this account a few days ago specifically to offer my thanks and gratitude for the enormous, educational and EXCEPTIONAL effort
of the people here who have finally answered a lot of my questions regarding various drivers.
I wish I had discovered this community a few years back but better later than never.

Before anything, I would like to warn all readers that this will be a pretty long post and I apologize in advance as such.
My intention is not to bore or put people to sleep.
Quite the contrary, I would like to offer all the details & events in the exact order that they happened, in hope of aiding the far more capable people than myself in this forum to help me with what I've ashamedly done.
Thank you for your patience and understanding.
---

That being said, allow me to introduce my situation.
I own a ASUS X99 Sabertooth mainboard that comes with an already integrated ASMedia ASM-1142 PCIE 2.0 x2 USB 3.1 Controller that gives 2 USB 3.1 ports in the back panel.

After a long & educational period spent on this forum that finally saw me correctly understanding the meaning, importance & various other aspects behind drivers installation and also their location(!)
I finally managed to get my system up-to-date, with all drivers installed and a computer running as never before (including the drivers for the ASM-1142, namely drivers v1.16.35.1).

With everything running smoothly and having absolutely nothing to complain about, I said to myself:
"- Now that ALL IS ORDER, why not treat yourself with a firmware update?"

I think I should also add that the mainboard came with BIOS 1801, I upgraded to BIOS 2101 in December 2015 and upgraded again to BIOS 3101, 2 weeks ago, in June 2016.
Somewhere in January or February 2016, running on BIOS 2101 I decided to upgrade ASM-1142 USB 3.1's firmware from what it was back then to version 141.231.300.20D.

The update was done from Windows 7 x64 Ultimate running the application found on the official ASUS X99 Sabertooth website or here.
(I have checked, the files are identical).

Despite running from the Windows environment, the update ran remarkably well & with success.
I'm not sure I followed ASUS's advice of plugging off the power cord after the update but knowing myself, I believe I did.

Encouraged by this particular event & its success, that happened months ago, I unusually decided to pursue a similar step a week ago, without doing proper research first.
It is needless to say I hadn't discovered this particular area of the forum before.

Therefore, I downloaded the latest firmware version that didn't have "unofficial" or "modded" in its description, namely v150.604.300.202.
The updater is Windows based and it can be found here.

The updater ran fine and reported that it had success, also asked for a reboot, which I immediately did.
I did have the feeling that it went a bit faster than last time and maybe had the feeling that something fishy just happened, but this could also be a placebo effect relative to what I was to discover after the reboot.
Also, I didn't - as I did before in January of February with the past update - unplug the power cord from the computer after the update.

Logging back into Windows, I went into the Device Manager to check if everything was ok and to my utter disappointment, the ASMedia USB 3.1 Controller was gone.

As I didn't have the inspiration of taking a screenshot of the device before, I will post an image of what I'm 95% inclined to believe it is/used to be(?).
(thanks bert from 104x USB3.0 thread for incidentally helping me with this).

---

Here it is for the sake of having a complete post:



Here's what I did next, in this particular order:


Step 1: Discovered that another device may have appeared in its place (not 100% sure but I certainly don't recognize it, nor could find many info about it), namely:



... and information about it:



+




Step 2: Trying to deceive my self that maybe it was only a temporary situation that required drivers installation for the device to display correctly, I went to install the drivers, and the results are:




Step 3: Discovered this area of the forum, had a slight heartache and started reading.


Step 4: Downloaded the DOS version of the firmware application found here.
This is supposed to be a later firmware version than what I had installed, namely v150.707.300.200 and its description mentions only MSI MS7966, MS7971, MS7976, MS7977, MS7978, MS7984 (which I suppose are MSI's integration of the same chip?).
Anyways, I couldn't find anything else that could access the chip from DOS mode so I gave it a try.
Here are the results of almost all arguments (the executable file 114xfwdl.exe was not in root but placed in a folder, but I don't think it matters, or does it?):

However, the .bin file used for the update is firmware v150.604.300.202 which specifies no mainboard manufacturer (that also excludes ASUS).



...and



Could it also mean that "entity not found -4" is strictly related to the fact that I'm running an ASUS board and the application states MSI's versions of integrating that chip?
Step 9 kind of points me into believing this.



Step 5: Tried running the Windows firmware update v150.604.300.202 again.
Here are the results:



...and



The same result is given for other firmware versions, e.g v150.707.300.200.


Step 6: Reinstalled Windows.


Step 7: Downgraded mainboard BIOS version from 3101 to 2101. (I did this because I know 3101 changes IME version and I hoped it would also flash the ASM-114x's controller firmware version back).

Enabled & Disabled the USB 3.1 Controller via BIOS and redid steps 1,4 & 5.
Basically nothing changed.


Step 8: Given that, I re-updated the mainboard BIOS version from 2101 to 3101.
Same thing with Enabing / Disabling the controller from the BIOS.
Went again through steps 1, 4 & 5 with no change.


Step 9: Tried reverting back to the old firmware version (v141.231.300.20D) using the same file that successfully worked in January or February, found here & on ASUS's X99 Sabertooth's official webpage.
The results are:



...the green bar goes 100%, becomes red, repeats the cycle 4 times...



...and finally reports this:



In my naive way of seeing things, does this last image show signs of hope or am I just wishful thinking that I did not brick the controller?


Step 10: Wrote a letter to Santa. (a much shorter one than this very post, wouldn't want him to know I haven't been good )

---

I made a new thread because I felt it was addressing a different controller than the ones already discussed.
If this is not the case, I kindly ask the moderators to move it where they find suitable.

These being said & written, I would like to apologize once again for the infinite post and show my appreciation
for those who will go through the trouble of reading it and hopefully post a reply.

Thank you!

#228 RE: ASMedia ASM-114x Series USB 3.1 firmware by Fernando 04.07.2016 23:32

avatar

@Korabeu:
Welcome at Win-RAID Forum and thanks for your detailed report.
Unfortunately I cannot give you any advice, because I am not an expert regarding your problem.
Nevertheless I hope, that anyone among our Gurus will help you.
Good luck!
Dieter (alias Fernando)

#229 RE: ASMedia ASM-114x Series USB 3.1 firmware by Korabeu 05.07.2016 00:23

Thank you for your warm welcome Dieter.

Truly looking forward for their replies.

#230 RE: ASMedia ASM-114x Series USB 3.1 firmware by Kbird 05.07.2016 05:49

Not sure I am much help , but it looks like the official firmware updater is doing nothing as it thinks you already have a newer version , I see all zeros next to update...

Someone who knows firmwares maybe able to fool the updater by changing numbers for you...sorry that isn't me....

Asetek make Fan and Water Pump controllers are you using a watercooler with a USB Connector to control it....similar to my Corsair AIO H80iGT , did you install it's drivers ?

The MSXXXX numbers you are seeing on Station Drivers is how MSI identifies their Motherboards , every MSI MB has MS plus a 4 digit number from my experience

#231 RE: ASMedia ASM-114x Series USB 3.1 firmware by Korabeu 05.07.2016 06:10

Hi and thank you for your reply,

I am indeed using a NZXT Kraken X61 AIO CPU watercooler.
It could indeed mean that Asetek USB Device entry in Device Manager is related to the Kraken, I might have just missed it before.

You are right about that, the updater is doing nothing but what I find to be somehow reassuring is that it SEES that the device exists.
Does that automatically mean it's not bricked?

Why doesn't the DOS utility detect the device, could it be that MSI has a different version of the controller installed?
I was under the impression there was only 1 version of this particular controller, adopted by all manufacturers.

#232 RE: ASMedia ASM-114x Series USB 3.1 firmware by Kbird 05.07.2016 21:46

the Kraken x61 is made by Asetek see here

http://www.asetek.com/customers/do-it-yo...zxt-kraken-x61/
or here for setup
http://www.hardwarecanucks.com/forum/har...s-review-4.html
http://www.hardwarecanucks.com/forum/har...s-review-5.html

As to the ASM problem I will have to let Lordkag or some other expert help with that, sorry

#233 RE: ASMedia ASM-114x Series USB 3.1 firmware by Korabeu 13.07.2016 18:24

Not a very popular thread this one...or is everyone on holiday already?

#234 RE: Updated Asus P9X79 Pro with 130125_00_02_00 by ZyMe 21.07.2016 15:30

Hi, I updated my Asus p8p67 LE asm1042 on last firmware. And i have question - how to get working USB 3.0 Boost(UAS)? its real?
sorr for bad eng.
PS Win10

#235 RE: Asmedia 104x USB 3.0 firmware by zazzn 02.08.2016 05:13

@lordkag

Hello, I just got the big middle finger from ASUS regarding upgrading my BIOS to support a bug that is causing my PCI-E NVME drive to conflict with the 4th Dimm slot of my P8p67 board. I suspect the newer bios from the LE board which is exactly the same aside from an ASmdeia SATA controller instead of the marvel is the only major difference.

Would you be able to help me understand how you where able to read the HEX to differentiate what the differences are? Is there anyway to rip out the core bios changes to flash my board so I can try to make my board work with the PCI-E card.

the 3801 is the newer bios the 3602 is the current version i'm running on right now.

#236 RE: Asmedia 104x USB 3.0 firmware by x7007 11.08.2016 17:23

If I have Asus P8Z77-V and Asmedia 104 Usb, how do I check which firmware do I have now and what chip ? and which version is the newest or which version should I update too ? using windows to flash or Ms-Dos ?

Where can I find the chip on the mobo ? I don't know if my 1080 GTX is hidden it beneath it or the CPU Cooling.

My Backup file : http://www77.zippyshare.com/v/dJqOXmLm/file.html

Is this the most updated ? asmedia_asm1042_131025_10_11_23(www.station-drivers.com)

I checked the Bin file using Hex and I have 1402 U2104_RCFG

Can someone please help ?






EDIT : So I've updated the firmware from post #36 f13t375p12753n3_HjyoFWxd it passed Successfully and then I installed the newest Asmedia asmedia_usb3_1.16.36.1(www.station-drivers.com)

Working fine, I don't see any much of a different.

#237 RE: ASMedia ASM-114x Series USB 3.1 firmware by Korabeu 18.08.2016 09:29

Up?

#238 RE: ASMedia ASM-114x Series USB 3.1 firmware by gpvecchi 18.08.2016 20:23

avatar

Well, I don't think is a hardware problem, but more software.
I'd flash latest Asus bios, the latest firmware from stationdriver http://www.station-drivers.com/index.php...id=2351&lang=en
Then check what happens; ASmedia drivers should install fine, if you still have the wrong driver, I suggest to remove all of them (from control panel and from device manager, thicking the option). Then you can use Rapr, a freeware to remove the OEM files from Win drivers folder and try a new install. If it doesn't work, I'd go for clean install...
EDIT: to update the firmware you don't have to execute the bat file, but the exe.

#239 RE: Asmedia 104x USB 3.0 firmware by tv84 06.09.2016 00:23

Hi,

Registered just to thank all the gurus here!

I've reflashed my Highpoint RocketU 1142A USB 3.0 Card (PCI-E card with 4 ASM 1042 controllers) to version 130125_00_02_00 from the 111222_0E_02_5E version.

1 > Bus:0x08 Device:0x00 Function:0x00
FW Version : 130125_00_02_00
(SVID:SSID = 0x174c:0x2104)

2 > Bus:0x09 Device:0x00 Function:0x00
FW Version : 130125_00_02_00
(SVID:SSID = 0x174c:0x2104)

3 > Bus:0x0A Device:0x00 Function:0x00
FW Version : 130125_00_02_00
(SVID:SSID = 0x174c:0x2104)

4 > Bus:0x0B Device:0x00 Function:0x00
FW Version : 130125_00_02_00
(SVID:SSID = 0x174c:0x2104)

All works well. I had no complaints. I also upgraded the drivers to asmedia_usb3_1.16.36.1(www.station-drivers.com).

Overall, I see a 5% transfer speeds increase.

Thank you very much for all the info provided in this thread.

tv84

#240 RE: Asmedia 104x USB 3.0 firmware by jimkrav 15.09.2016 10:05

Hello, I have a P8Z68 V / gen3, and I also have the same problems with the USB3 ports.
Where is the latest firmware for my ASM1042? thank you

Xobor Forum Software von Xobor
Datenschutz