Page 14 of 30
#196 RE: Asmedia 104x USB 3.0 firmware by pfinchen 05.02.2016 12:12

Hey guys,

I really need your help to understand the update procedure. (Firmware/Update tool). Maybe it works via ASUS Tool Winflash?

I got a ASUS Sabertooth Z77 Mainboard with the USB3.0 Controller 1042 (I think non 'A' on all Z77 models)

best regards

#197 RE: Asmedia 104x USB 3.0 firmware by gpvecchi 05.02.2016 22:03

avatar

Zitat von Mazzocato im Beitrag #195
@gpvecchi:
Using the /A string on the flash program (104XFWLD.exe /A) I think.

Tomorrow I'll test with a DOS bootable pendrive, thanks!

#198 RE: Asmedia 104x USB 3.0 firmware by Mazzocato 06.02.2016 00:05

@pfinchen

What I did to update my ASMedia 104x firmware:

1. Look into the physical board for the ASMedia chip to confirm if it is the 1042, 1042A or 1042AE.
2. Get the apropriate version for your chip from the topic (13xx for 1042 and 14xx for 1042A / 1042AE)
3. Create with RUFUS a DOS USB Boot device (MBR for BIOS/UEFI).
4. Copy the files you got from this topic to the USB stick with DOS you've just made.
5. Go in the bios and:
5.1. Enable CSM (if disabled), otherwise it won't boot the DOS USB drive.
5.2. Disable SecureBoot (if enabled) for the same reason as above.
5.3. Set your USB as the boot device. (e.g. USB: CruzeBlade 4Gb).
5.3.1. Note: You can't boot a USB DOS stick in UEFI mode. Only MBR/USB mode.

6. Run the flasher to backup your current firmware:
6.1. "104XFWDL /A" (without quotes)

7. Run the flasher to check if you have the right version of the firmware:
7.1. "104XFWDL /D" (without quotes)
7.2. Take note of the info and come back to the topic if in doubt. Don't upgrade if you are NOT SURE if it is the right one.

8. Run the flasher to update the firmware:
8.1 "104XFWDL /U NAME-OF-THE-FILE.bin" (without quotes).
8.2 If succeded, go to 9. Otherwise take note of the error and come back for help.

9. Run the flasher to confirm the new firmware:
9.1 "104XFWDL /D" (without quotes)

That's how I can help ya. And you must use the flasher provided here, since it is not an OROM or UEFI module (As I recall).

And do as I did. Read the WHOLE topic to confirm and acquire the knowledge. This is just a "sketch" of what I did after reading the whole topic.
Don't rush it. My 50 cents.

#199 RE: Asmedia 104x USB 3.0 firmware by pfinchen 06.02.2016 10:40

@Mazzocato
Thank you so much!

The Sabertooth Z77 Board got the 1042 controller!
The latest FW on station-driver is '130201'.

Is that correct? You asked for a newer one in the past

#200 RE: Asmedia 104x USB 3.0 firmware by thecrowler 06.02.2016 13:59

avatar

@lordkag @Fernando @RoughBoy
First of all, I would like to thank you for all the valuable infos that you provide for free.
I'm experiencing a very strange problem, which derives from the ASMedia USB 3.0 controller (DEV_1042) on my motherboard: it's an ASUS P8P67 PRO Rev. 3.1, BIOS 3602.
OS is Windows 7 Ultimate SP1 x64.
I've successfully updated the ASMedia controller firmware to version 130125_00_02_00, but the problem I'm describing already existed before (firmware was "120816_02_02_6D"): the update was intended, precisely, to find a solution.
Any 1.16.xx.x driver (I tried different flavours...) always cause the same exact problem in data transfer.
For example, when creating a very big .rar archive (39 GB), directly on the external USB 3.0 hard drive (source file is on the internal SATA drive), that archive will ALWAYS be corrupted (integrity check failed).
It seems not to happen' with smaller archives (successfully done with a 5.06 GB ISO image archive).
A simple copy/past causes no errors, but I'm quite sure that the resulting files are garbage...
WinRAR is v5.31 x64, BLAKE2 is used to calculate the hash.
Problem doesn't occur when: 1) using older drivers (v1.2.9.0/v1.14.3.0) - OR - 2) using a Fresco Logic xHCI (USB3) Controller FL1100: so that, I can obviously exclude that it's a matter of RAM memories, software, disks, the controller itself and so on.
It seems to be a matter of controller firmware plus specific, newer drivers (v1.16.xx.x).
Any help will be very, very appreciated, 'cause I've tried everithing before posting here, without any success.
Thanks for your precious time, kind regards.

EDIT: SOLVED!

I think it could be usefull to know that it was an OS related problem, and could involve many others.
1) Using 1.16.xx.x drivers from Fernando's "USB 3.0/3.1 Drivers (original and modded)" page caused the problem, as well as from station-drivers.com page: it's in my opinion that those drivers aren't compatible with Win7, although no errors seems to occur when installing/updating.
2) Using 1.16.2.0 drivers from ASUS download page (drivers are made for Windows 7 x64) solved the problem.
HERE you can find the Win7 x64 certified drivers:
http://dlcdnet.asus.com/pub/ASUS/misc/us...n7_VER11620.zip

@RoughBoy : u should consider to reproduce my steps, 'cause u're probably involved too, as many others.

#201 RE: Asmedia 104x USB 3.0 firmware by Fernando 06.02.2016 20:25

avatar

@thecrowler:
Thanks for your interesting report.
It is fine, that you found finally the initiator of all your issues.
Due to your report I have added >here< a recommendation for Win7 users not to install the latest ASMedia USB 3.0 drivers, which I am offering there. Furthermore I added a link to your report.

Zitat von thecrowler im Beitrag #200
Using 1.16.xx.x drivers from Fernando's "USB 3.0/3.1 Drivers (original and modded)" page caused the problem, as well as from station-drivers.com page: it's in my opinion that those drivers aren't compatible with Win7, although no errors seems to occur when installing/updating.
If you would have read the start post of >this< thread carefully, you should have known, that the latest ASMedia USB 3.0/3.1 drivers v1.16.32.1 WHQL are designed for being used with Win8-10 and not with Win7.
This was and is still the related part of my text:

Zitat von Fernando
These 32/64bit ASMedia USB 3.0/3.1 drivers are dated 01/21/2016, WHQL certified and suitable with Win8-10 x86/x64.

#202 RE: Asmedia 104x USB 3.0 firmware by thecrowler 06.02.2016 20:34

avatar

@Fernando
Thanks, Fernando.
The problem was not caused by the latest ASMedia USB 3.0/3.1 drivers v1.16.32.1 WHQL.
The first time I realize that something was wrong, I was using v1.16.4.0 WHQL.
The second time, v1.16.28.0 WHQL.
As I wrote, I've tried different flavours, before posting here.
It's in my opinion that quite all v1.16.xx.x drivers are not suitable for Windows 7.
The only one working is v1.16.2.0, from ASUS website.
Also, I'm not completly sure that it is a driver problem, or only a driver problem..
The matter has three variables:
1) the specific ASMedia controller;
2) the specific firmware version;
3) the OS.
I've tried v1.16.24.0 from ASUS website, certified for Windows 7, with no luck (exact same problem): but the driver is made for Windows 7, so...
Here's the download link:
http://dlcdnet.asus.com/pub/ASUS/misc/us...8-1_V116240.zip
This is why I wrote here and not in the USB 3.0 drivers page.
It could be a problem involving firmware version AND drivers v1.16.xx.x under Windows 7: or just firmware version AND drivers v1.16.xx.x (non-OS specific).
It would be nice to try all my steps on different OSes, different drivers, same controller, same firmware.

#203 RE: Asmedia 104x USB 3.0 firmware by N6O7 10.02.2016 19:46

avatar

The strange thing is that Asus provide in their AI Suite II USB 3.0 Boost software (AI_Suite_II_USB3_Boost_10518), the ASMedia driver version 1.16.13.0 for Windows 7, which is dated from Dec 16, 2013.

I have the ASMedia_ASM1042_130125_00_02_00 firmware onto my controller...

Latest ASMedia USB 3.0/3.1 drivers v1.16.32.1 WHQL installed fine but in not using it with hard drives plugged-in and data transfers, just peripherals.
Might downgrade just in case to v1.16.13.0, since they seems not compatible with the Windows 7 OS.

Thanks!

#204 RE: Asmedia 104x USB 3.0 firmware by thecrowler 12.02.2016 15:50

avatar

Zitat von N6O7 im Beitrag #203
The strange thing is that Asus provide in their AI Suite II USB 3.0 Boost software (AI_Suite_II_USB3_Boost_10518), the ASMedia driver version 1.16.13.0 for Windows 7, which is dated from Dec 16, 2013.

I have the ASMedia_ASM1042_130125_00_02_00 firmware onto my controller...

Latest ASMedia USB 3.0/3.1 drivers v1.16.32.1 WHQL installed fine but in not using it with hard drives plugged-in and data transfers, just peripherals.
Might downgrade just in case to v1.16.13.0, since they seems not compatible with the Windows 7 OS.

Thanks!


@N6O7
U're very welcome.
If u take a look at the official "P8Z77-V LE PLUS" drivers page on ASUS website, under Windows 7 x64, USB 3.0 driver version is 1.16.2.0 (exactly the one that is working for me).
Under Windows 8.1 x64, driver version is 1.16.12.0.
I really don't know why the AI Suite II is bundled with such a driver version, considering that it should be also Windows 7 compatible... I believe that it's a mistake.
If u wish to downgrade for security reasons, consider using driver v1.16.2.0 from ASUS website, instead, because I've already tried v1.16.13.0 with no luck: so, it won't be usefull.
Here's the direct link to download driver version 1.16.2.0 (taken from "P8Z77-V LE PLUS" drivers page on ASUS website):
http://dlcdnet.asus.com/pub/ASUS/misc/us...20_XPWin7_8.zip

#205 RE: Asmedia 104x USB 3.0 firmware by RoughBoy 26.02.2016 17:38

avatar

Zitat von thecrowler im Beitrag #200

@RoughBoy : u should consider to reproduce my steps, 'cause u're probably involved too, as many others.


@thecrowler
I did it.
For me all is fine when creating a very big .rar archive (26 GB) directly on an external USB 3.0 SSD from source files from an internal SSD.
The archive is not corrupted. The integrity check was passed.

ASMedia USB 3.0 controller is a DEV_1042 with firmware 130125_00_02_00 on my motherboard ASUS P8P67 Rev. 3.1 with BIOS 3602
OS is Windows 7 Ultimate SP1 x64 with latest ASMedia driver 1.16.32.1 from station-drivers.com
WinRAR is v5.31 x64

#206 RE: Asmedia 104x USB 3.0 firmware by bradm65 02.03.2016 10:04

I have just updated my Asus p8Z68-v to the latest Asmedia firmware (130125_00_02_00) and made an interesting discovery running the machine with Windows 10.

File transfer speed to an external jmicron raid 5 usb 3.0 box used to give me transfer speeds with Asmedia 1.16.31.1 drivers installed of about 250 MB/s and about 210 Mb/s with the default Microsoft Drivers. With the new Firmware, the ASmedia drivers are slower (180MB/s compared to about 200MB/s with the MS drivers.

The ASmedia drivers also behave very poorly with an USB-AC56 network when it connects to an AC router with high speed fiber internet connection. I will be reverting to the original firmware I think.

Your milage may vary but, all in all, I cannot say that I would recommend updating ASUS Z68 boards with the new ASmedia firmware revision

#207 RE: Asmedia 104x USB 3.0 firmware by bradm65 02.03.2016 12:04

Something that you may find useful.

The attached zip file is the Windows ASmedia FW update utility and a copy of xHCI_v120816_02_02_6D.bin. This version of the firmware works fine on Asus P8z68-V

#208 RE: Asmedia 104x USB 3.0 firmware by RoughBoy 03.03.2016 06:55

avatar

Zitat von bradm65 im Beitrag #206
I have just updated my Asus p8Z68-v to the latest Asmedia firmware (130125_00_02_00) and made an interesting discovery running the machine with Windows 10.

File transfer speed to an external jmicron raid 5 usb 3.0 box used to give me transfer speeds with Asmedia 1.16.31.1 drivers installed of about 250 MB/s and about 210 Mb/s with the default Microsoft Drivers. With the new Firmware, the ASmedia drivers are slower (180MB/s compared to about 200MB/s with the MS drivers.

The ASmedia drivers also behave very poorly with an USB-AC56 network when it connects to an AC router with high speed fiber internet connection. I will be reverting to the original firmware I think.

Your milage may vary but, all in all, I cannot say that I would recommend updating ASUS Z68 boards with the new ASmedia firmware revision

@bradm65
Interesting results.
Can you check your speed date of your external jmicron raid 5 usb 3.0 box with AS SSD Benchmark please?
You can download it here: AS SSD Benchmark
So we had an exact basis for comparison.
Many thanks in advance.

#209 RE: Asmedia 104x USB 3.0 firmware by bradm65 04.03.2016 09:46

Zitat von RoughBoy im Beitrag #208
Zitat von bradm65 im Beitrag #206
I have just updated my Asus p8Z68-v to the latest Asmedia firmware (130125_00_02_00) and made an interesting discovery running the machine with Windows 10.

File transfer speed to an external jmicron raid 5 usb 3.0 box used to give me transfer speeds with Asmedia 1.16.31.1 drivers installed of about 250 MB/s and about 210 Mb/s with the default Microsoft Drivers. With the new Firmware, the ASmedia drivers are slower (180MB/s compared to about 200MB/s with the MS drivers.

The ASmedia drivers also behave very poorly with an USB-AC56 network when it connects to an AC router with high speed fiber internet connection. I will be reverting to the original firmware I think.

Your milage may vary but, all in all, I cannot say that I would recommend updating ASUS Z68 boards with the new ASmedia firmware revision

@bradm65
Interesting results.
Can you check your speed date of your external jmicron raid 5 usb 3.0 box with AS SSD Benchmark please?
You can download it here: AS SSD Benchmark
So we had an exact basis for comparison.
Many thanks in advance.


The figures I go were from using Crystaldiskmark.

I use the computer for work and have already reverted to the V12 FW so I cant just rip it to bits at the drop of the hat. I will revisit it when I get a chance but I am not sure that It will be this weekend

#210 RE: Asmedia 104x USB 3.0 firmware by RoughBoy 28.03.2016 13:49

avatar

There is a "new" firmware at Station-Drivers:
Asmedia ASM-104x USB 3.0 Firmware Version 110315010230
But it seems this is an older one from 2011.
What's the opinion of the experts? Recommendable?

Xobor Forum Software von Xobor
Datenschutz