Page 24 of 25
#346 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Jerzy 20.04.2021 08:24

Zitat von kenji187 im Beitrag #345
So far so good but with issues.
Quick questions:
[...]
2. How to RAID 0 these 2 before Windows installation? On board SATA RAID (Intel/Marvel) can't see them. Running soft RAID on Windows 10 Disk Manager now.
[...]
4. Is there a fix to allow 4* NVMe drives so far? Or even 3 is better than 2. Asking cuz I just bought 4* 500 Gbs.


Ad2. You can't unless you don't have an NVMe RAID controller. The mentioned ASUS Hyper is not the one.
Ad4. A fix? Nope in this mobo you can only have 2 NVMe on the Hyper card unless... you use an NVMe RAID controller. BUT if you have 2 free pcie slots you can buy a 2 cheap NVMe x4 cards and put the 2 drives on them. This way you can have software RAID of 4 NVMe's.

#347 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Saint666 21.04.2021 06:00

update. was the Darn Display-port to dvi cable causing system crash of all things... Sooo annoying lol

flashed back to 4801 bifurcation and running good/

-------------------




update Crashes. , swapped back to my i7-3930K and runs fine..

sent back the Xeon 1680v2 and got a different one, still having same problems, soo idk.. my MB hates it i guess. sigh.

#348 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by slap_mon 23.04.2021 22:04

Hi guys,

I am trying to get a NVMe drive working on my trusty old Sabertooth X79 for quite some time now.
And by working I mean getting Windows 10 installed on it.

To my knowledge I did everything according to @Lost_N_BIOS and @agentx007 recommendations/guidelines.

I used an old 4GB USB2.0 Stick, formatted it to FAT32 and flashed a new BIOS (actually tried some of the different versions) from the first post.
So far no problems, flashing went well, and the new BIOS seems to have installed correctly.

According to the stuff written in this forum I switched "SecureBoot" to OtherOS, turned Fast Boot Off, and disabled CMS to get to this point. I also unplugged all other drives.

After some problems getting the Installation Media ( a USB Drive flashed with Rufus and the recommended settings (GPT, UEFI etc.)) working (probably wrong format/and settings in the BIOS) I finally got it to the point where I could boot the Installation Media and got to the Screen where you put in your license etc... ( all without any drives installed).


Now my problem:

When I then try to put in my NVMe drive ( a Crucial P5 on a ASUS Hyper M.2 v2) and boot the Win10 installer it freezes on the Screen with the WindowsLogo and those dots spinning.
Once it´s there, there isn´t anything I can do except turn off the power.

What I tried:

Changing out the USB Stick that I use for the Installation didn´t work out. Trying to install Windows 8.1 from a different stick results in exactly the same problem.

But:
Booting into a Live Ubuntu did work fine, and the NVMe Drive shows up correctly in GParted, so I suppose the mistake isn´t caused by the flashed BIOS itself.

Also to let you know, the first thing I tried was copying my complete installation from my old SSD to the new NVMe, but since then I read here that cloning will cause problems, so I deleted the partitions on the NVMe in GParted.

I hope someone here might be able to help me with my problem, even though it seems that the problem might not have something to do with the flashed BIOS itself.
Could there be some settings in the BIOS etc. that I forgot to change ?

And also thanks for the work you are doing here!!


EDIT:

The problem wasn't caused by either BIOS or the installer. It seems to be a compatability issue. Swapping out the Crucial P5 for a Samsung 970 Evo did the trick and fixed the problem.

#349 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by slap_mon 24.04.2021 14:55

Since my post yesterday I could find out some more "weird" (?) behaviour with the NVMe drive installed.

Booting up my standard SSD (MBR) with my current Win10 install works aswell. Even with the NVMe drive installed.

Because the standard SSD was in MBR I used mbr2gpt within Windows to convert the SSD to GPT in order to give cloning another shot.

When I then change my settings within the BIOS to Boot in UEFI Mode (CMS off, SecureBoot & FastBoot off) and try to get into Windows I get exactly the same freeze when booting up the, now to GPT converted, SSD.
Once I unplug the NVMe drive I can boot into Windows as usual without any problems.

#350 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by MeatWar 24.04.2021 15:07

avatar

If the NVMe drive is showed a standard storage disk in old Windows, then u can assume that is working properly. But if possible change to another PCIe slot just to troubleshooting.

Disconnect all system drives, only NVMe and USB Windows install GPT UEFI.

Load bios defaults, save and reboot, go to bios again and select UEFI boot (CSM off) and secure boot off.

Do a clean installation again and lets see where it freezes now.

EDIT: All ur USB Windows OS (8, 8.1, 10) installers freezes...delete all partitions of the NVMe in the old OS system, disconnect old OS system drive and try again.
Did u tried other PCIe slots or not?
Witch mod was flashed, the one with NVMe mod, uCodes and BF or just NVMe mod?

#351 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by slap_mon 25.04.2021 23:20

Thanks for the advice.

My problem is, I can't do a clean install from a USB because even when booting from the stick it freezes before I can get anywhere, when the NVMe drive is installed.

#352 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by slap_mon 28.04.2021 15:20

Okay, just as a quick update:
After all of that not working I found my self randomly searching for keywords that match my problem and found some posts by @Lost_N_BIOS stating that the Crucial P5 has shown some compatability issues, so I went ahead and swapped it out for a Samsung 970 Evo and everything worked perfectly fine!!

Even cloning my old installation worked out.
Although it took me 3 days to finally get it to work I am very happy now to have a bootable system.

Thanks so much, to everyone here :D

#353 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by MeatWar 28.04.2021 16:05

avatar

@slap_mon
Common issue on some hw vendors/models, that most users tend to ignore...and still forget that this is mods, for old systems and using current hw gen devices.
No one want s to ear that they bought a cheap adapter, or a cheap disk or that can simple exist a hw compat. problem...
When ut old us that uve tried other OS installers my suspicious was pointing to hw issue... after all it was.
Glad u achieve success on ur system and that this will be a situation for future users as reminder.

#354 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Shyam2566 23.06.2021 01:45

Hi All, need some urgent help..

My build:
MB - Sabertooth X79
CPU - 4930k
RAM - 64Gb
GPU - GTX 770
PCIe-Nvme -Asus Hyper m.2 x16 card v2 -(Samsung 980 1tb + Corsair Mp510 500gb)


I had downloaded "SABERX79 (4801 bifurcation)" from page #1 and successfully updated the bios. I am running ESXI lab on this machine and all I want is NVME storage (no need of boot capability). No matter how many combinations I tried, unable to see both NVME disks together in esxi storage. Tried with all 3 PCIE slots, at one point both NVME disks showed up when using PCIE slot one (x16), but my foolishness didn't noted the combination and tried to put the Hyper card on middle PCIE slot (x16) and unable to the get the correct combination to get both of them work together. Can someone please let me the steps about in which slot should I put the Asus Hyper m.2 card and which slots should I populate with the two nvme disks and which bifurcation settings should I use.

I am stuck with this since a day and unable to resolve it myself. Any help is much appreciated. Thanks in advance.

#355 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Jerzy 23.06.2021 09:01

Put the drives in slot 1 and 3 of the card. The 1 is the most external slot. And you have to set up the bifurcation within the mobo's UEFI.

#356 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Shyam2566 23.06.2021 19:12

Thanks @Jerzy , but no luck with x16 PCIe slots yet, got it working with drives in slots 1 and 2 of the Hyper card and used x8 PCIe slot (Last slot on Sabertooth X79) with IOU1 - PCIe Port set as x4x4. Can adjust with this for now as we cannot make it work with 4 disks on Hyper card anyway.

#357 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Jerzy 24.06.2021 13:31

Only the most upper slot will work if set x8x4x4 or x4x4x8 and maybe the middle one. The most bottom slot won't work even set 4xx4

#358 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by Overkill 27.08.2021 23:55

First of all, thank you @agentx007 and @Lost_N_BIOS for all your efforts. I have an Asus Sabertooth X79 that was running on a 120GB SATA SSD boot drive for most of its life -- since 2012. The SSD recently failed and I wanted to replace it with an m.2 NVMe drive, only to discover that the board doesn't support it out of the box. However, I quickly found this thread that taught me to enable it through the modded BIOS. I am now proudly running a Western Digital SN750 Black 1TB as my boot drive.

Just to share my small experience setting it up: after flashing my BIOS with the modded 4701 NVMe-only support, I pre-formatted the m.2 drive in GPT and connected it to my Sabertooth X79 using a fairly generic m.2-to-PCIe adapter in the second X16 slot (first slot already hosts my GPU, as expected). BIOS recognized the drive immediately; I didn't have to change any settings. A small hitch though was that when I started the Windows 10 installation, the installer first refused, saying the drive format was not supported. Without rebooting, I simply prompted the Windows 10 installer to reformat the drive from the installer interface. It did so and proceeded to install Windows 10 on it. Fastest Windows 10 install I've ever gone through.

My PC is running better than ever now, thanks to this thread. Which is why I decided to register on this site not only to thank the OPs and to share my experience, but also to seek advice on making things even better.

I am contemplating using an Asus Hyper M.2 X16 card or similar device to add even more m.2 NVMe goodness to my system. I figure that making full use of a PCIe x16 slot for a drive (and using all 8 DIMM slots) is going to make my PC better than most current-gen PCs running today.

Which leads me to this question that I hope someone could provide a definite answer: Using the modded BIOS, can a Sabertooth X79 fully utilize an Asus Hyper M.2 X16 or other similar quad-m.2 PCIe adapters?

Does anyone have any experience successfully making such devices work? And if so, does the system recognize/allow the adapter to use the drives in Raid 0? If I so choose, can I also make the system recognize the four m.2s as separate drives? I know I'll have to switch to one of the bifurcated BIOS mods, but has anyone actually gotten this kind of setup to work with any of the modded BIOS? I've gone through most of the pages on this thread and have seen many attempts to make it work, I just don't see anything definitive/conclusive.

I await the wisdom of anyone who can shed light on these plans.

Thank you!

#359 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by MeatWar 28.08.2021 00:07

avatar

I believe it can use a PCIe Multiple M.2 card but only 2 drives and it requires PCIe Bifurcation or u can spend a bit more and get a card already with its own controller doing the bifurcation instead of the motherboard (Mod).

More info on Bifurcation mod for X79 here:
[GUIDE] Adding Bifurcation Support to ASUS X79 UEFI BIOS
[Guide] - How to Bifurcate a PCI-E slot

Good luck

#360 RE: [OFFER] ASUS Sabertooth X79 UEFI (NVMe support w/optional Bifurcation + uCode + OpROM) by CatalyticCoder 30.09.2021 21:48

Hi guys,

I am trying to install Windows 10 on a Samsung 970 Evo Plus NVMe drive, which is already functioning on my Sabertooth X79, thanks to all of you.
I have been testing the drive as storage for a while now, and I am still using Windows 7 at the moment (running on a separate SATA SSD).

As regards to the modded BIOS, I believe I did everything right, since the drive shows up as PATA SS in my BIOS (when I have CSM enabled - if CSM is disabled, the drive is not recognized by BIOS, even though it is configured as GPT and formatted as NTFS, as it doesn't have an EFI partition yet, so that should be normal)

As per the instructions in the forum, I cleared the SecureBoot keys, switched "SecureBoot" to OtherOS, turned Fast Boot Off, and disabled CSM. I also unplugged all other drives.

The Installation Media (first a USB Drive flashed with Rufus, now flashed with Microsoft's Media Creator tool because I thought that would solve my issue) boots normally, gets me through to the licence activation, I put in my key, select that I want a fresh (clean) install and get to the point where I should select the disk to which Windows would install.


The problem?

When I get to the disk selection window, the disk shows as literally empty (see picture - sorry for low quality but at least it's easy on server storage :D).


The troubleshooting I have done so far

1. Tried creating a new bootable USB (as mentioned above) with Microsoft's Tool

2. Tried various different settings in BIOS, ie:
- Secure Boot to "OtherOS" and "WindowsUEFI"
- Keys cleared or installed (default)
- FastBoot on or off

3. Tried the "Repair my PC" option, tu run CMD -> diskpart
- when running list disk command, the disk shows up with size 0 and there is NO ASTERISK in gpt column (<-- this is what I find extremely odd)
- when running same commands on my windows 7 installation, there is an asterisk in gpt column


Clearly this isn't a BIOS issue, but I hope someone might be able to help me.
Am I missing something? Is this a driver problem? If so, is it possible to load additional drivers onto the bootable USB?


Thanks everyone!


Edit:
The disk is definitely there, I converted it back to MBR (just try to convert it back to GPT with diskpart during win10 installation) but to no avail.
Here is some more information:

Xobor Forum Software von Xobor
Datenschutz