#1 Recover P8Z77V-Pro BIOS need help. by stardreamer77 22.02.2017 13:57

hi,
I use P8z77V-PRO (bios 2104) with i7-3770k (OC to 4.3Ghz 1.28v) for 4 years , few week ago, when I cool boot the PC, the VGA_LED light up and can’t boot [no post screen], but if I press “reset” then it will be FINE and go in to windows . I try run prime64 and furmark for hours without any problem [MAX temp CPU: 89C , GPU:65C ]. System is stable without any BSOD or hang. So I try Clear the CMOS by short the CLRTC jumper. After I go in to BIOS, I found the “ Intel ME ver : N/A” I no sure what cause it because I didn’t check it before I short the CLRTC jumper.
Then I format a 4GB usb drive to FAT32, rename the 2104 bios file to Z77VP.CAP and use Flashback function. It success the first time, then I go in bios to check the Intel ME ver still N/A . the cool boot VGA_LED problem still there. So I try a older version BIOS 2003 with Flashback, this time the FLBK_LED keep blinking after 20 minute waiting , so I power off the main power switch. Now the board can’t boot up. When I power up, CPU_LED light up 1 sec , CPU fan spin up 1 sec then Power off, and repeat. I try the Flashback again, and still the flash process keep running forever can’t completed, the FLBK_LED keep blinking.
I have check CPU pin, no any bend pin. Try Flashback without CPU and RAM still can’t completed flashing.

I order a CH341A , first i read the W25Q64BVA16 bios chip, then save it to oldbios.bin, when i open oldbios.bin with FD44Editor try to get the UUID and serial number from it, i get " Fatal error : Error parsing BIOS data. $BOOTEFI$ signature not found. Please open correct ASUS BIOS file."
this is the picture when i open it with UEFITool:


then i download the latest bios from asus website, using UEFITool to Extract Body and save it to Z77VP.Bin file, then use FD44Editor to input the MAC ,UUID[use ramdom number] and serial number[get it from the box] and save it.
i first Erase the chip using CH341A, then open the Z77VP.Bin then Write to the chip without any problem, but when i try to Verify, i get the error : "Chip with the contents are in disagreement" . i try 1.18, 1.29, 1.30 version of the programmer all same error.
when i put the bios chip back to the motherboard, i get a 4 short beep follow with one short beep but higher tone. the system still no post.
now i no know what to do. is the Bios Chip damage? or the motherboard problem?

thanks.

my system is :
P8Z77V-PRO
I7-3770k
Cooler Master Nepton 240M
Kingston 8GB DDR3 X 4
AMD Fury X
Samsung 840 EVO 250GB
WD Black 1TB
ASUS Xonar D2X PCI-E
Seasonic X 750w
Windows 10 64bit pro


Update: the original bios chip is bad. after replace the chip and flash it with CH341A, all good now. Thanks.

#2 RE: Recover P8Z77V-Pro BIOS need help. by plutomaniac 22.02.2017 19:39

avatar

Download the latest BIOS/SPI image from ASUS. Open the .CAP file with UEFITool and remove the AMI Capsule Header by extracting the Intel Image "as is". You should end up with an 8MB (0x800000) SPI image which can now be used with CH341A. Use FD44Editor on that image first and then flash it with CH341A. I don't now how FD44Editor works exactly, meaning what it expects as an input (full SPI or BIOS-only image) but if it works with a full SPI then use the previously mentioned 8MB one, otherwise extract the BIOS section of the 8MB image via UEFIStrip, add the info to it via FD44Editor and reinsert it at the 8MB image which should then be fed to CH341A.

Xobor Forum Software von Xobor
Datenschutz