Page 4 of 15
#46 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by Phil_Smith 22.04.2014 12:16

Ok, seems like I can just format the stick with the hp tool and add the .bin-file to it.
booting from my stick and typing 'dir' i can now see the file, but still i have no clue how to run or execute it...

#47 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by Fernando 22.04.2014 13:10

avatar

@ Phil_Smith:
Hello Philip,
welcome at Win-RAID Forum!

The Dell mainboard BIOS has nothing to do with the additionally inserted PCI cards of your computer.
So if you want to update the Firmware of your ASMedia 106x SATA 6G Controller PCI card, you have to update it another way.
Since I don't have any own experience with the update of the ASM106x PCI Card Firmware, I cannot give you any assistence.
What you probably need is a bootable USB with DOS, the tool spi106.exe and a file named ahci0954.rom, but I couldn't find the latter one by doing a Google search. You may try to rename the file 1b21-0612_v0954.bin I am offering >here< to ahci0954.rom, but I doubt, that this will work, because the related .bin and .rom files, which are within the v0.951 Firmware set, have a totally different hex code.
Maybe someone else can help you.

Regards
Fernando

#48 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by Phil_Smith 22.04.2014 14:50

Hey Fernando,

thanks so much for your reply!
I'll try out what you described, although I'll keep in mind that the chances of succeeding aren't fantastic.

To do so I got everything except the spi106.exe tool. I can't seem to find anything called like that.
Is there a way you could send me that file or a link to a download location?

Thanks and regards
Philip

#49 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by saglamtimur 22.04.2014 16:58

I think just renaming 1b21-0612_v0954.bin to xxx.rom will not be the solution. If you look version .951 from below link it contains both rom and bin file (And by the way, you can find spi106.exe also), and their sizes are different. Also, there is a .rom for ahci and another one for ide. So just renaming will not help you. Safest path is flashing it with using below mentioned tool to 951.

http://www.station-drivers.com/index.php/downloads/Drivers/Asmedia/Chipsets/ASM-106x-Sata-6G-Controller/Firmwares/Version-0951/

#50 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by Phil_Smith 22.04.2014 18:00

Zitat von saglamtimur im Beitrag #49
I do not think just renaming 1b21-0612_v0954.bin to xxx.rom will not be the solution. If you look version .951 from below link it contains both rom and bin file (And by the way, you can find spi106.exe also), and their sizes are different. Also, there is a .rom for ahci and another one for ide. So just renaming will not help you. Safest path is flashing it with using below mentioned tool to 951.

http://www.station-drivers.com/index.php/downloads/Drivers/Asmedia/Chipsets/ASM-106x-Sata-6G-Controller/Firmwares/Version-0951/


worked excellently! thanks a lot!

#51 RE: Asmedia ASM-106x Sata 6G controller firmware 3.02 by Fernando 22.04.2014 18:26

avatar

Zitat von Phil_Smith im Beitrag #50
worked excellently! thanks a lot!
It is fine, that you succeeded.
What exactly have you done?

#52 Qestion to x106 performance by vander 11.05.2014 10:57

Hi, I own the 760GAP43_FX with the onboard ASM1061 and SB710. I bought the board with this SATA III controller because the chipset controller support only SATA II and will slow down any ssd.
My experience so far is disappointing. With the msahci driver (win7 x64) is the performance lower than the SB710 and with the asmedia driver it gets even worse. The asmedia also has the problem to 'loose' the harddisk after standby, thats an total nogo, so I just disdabled till now.

Is there any chance to get a decent performance and standby working by updating the firmware (its 0.95 now) or should I just burry this crap and use the SB710 instead?
The SB710 also dont work perfect, thanks to the weird old firmware version, but thats offtopic here.

P.S. I tried to replace the orom already but it gave me some trouble, thought I need to replace module with dev_id 0612? Because in device manager I see 0612.
The bios contains 0611 0612 and 0613. Extracting only work on 0611, result is identical to the 0.95 I downloaded. The next two give a file filled with 0xff and extracting with mmtool crashes. Does this mean I have to replace 0611 instead of 0612?

#53 RE: Qestion to x106 performance by Fernando 11.05.2014 11:47

avatar

@ vander:
Welcome at Win-RAID Forum!

Zitat von vander im Beitrag #52
Is there any chance to get a decent performance and standby working by updating the firmware (its 0.95 now) or should I just burry this crap and use the SB710 instead?
I recommend to update the ASMedia AHCI ROM to v0.951, which seems to work fine for other users, or v0.954, which is even newer.

Zitat
I tried to replace the orom already but it gave me some trouble, thought I need to replace module with dev_id 0612? Because in device manager I see 0612.
The bios contains 0611 0612 and 0613. Extracting only work on 0611, result is identical to the 0.95 I downloaded. The next two give a file filled with 0xff and extracting with mmtool crashes. Does this mean I have to replace 0611 instead of 0612?

Yes, your mainboard BIOS just contains the ASMedia AHCI ROM v0.95 for the ASMedia AHCI Controller DEV_0612, but the MSI staff has entered "1B21:0611" by mistake, when they inserted it.
By the way: The other 2 ASMedia PCI OROM modules (for DEV_0612 and DEV_0613), which are listed by the MMTool, are just links and not really present. You can see it within the MMTool column named "Source size".

Regards
Fernando

#54 RE: Qestion to x106 performance by vander 11.05.2014 11:52

Just to make sure I got your explanation right.
I have to replace on the 0611 location in mmtool with the 0612 module I downloaded, no other change to correct the wrong numbers??

#55 RE: Qestion to x106 performance by Fernando 11.05.2014 11:57

avatar

Zitat von vander im Beitrag #54
I have to replace on the 0611 location in mmtool with the 0612 module I downloaded, no other change to correct the wrong numbers??
Yes, that is absolutely correct.
The entries within the MMTool "RunLoc" column is irrelevant for the function of the related module.

#56 RE: Qestion to x106 performance by 100PIER 11.05.2014 15:57

@Fernando:

You said:
"I recommend to update the ASMedia AHCI ROM to v0.951, which seems to work fine for other users, or v0.954, which is even newer."

I have tried to update the ASMedia AHCI ROM to v0.951 on my ASUS P8Z77-V Deluxe.
But, I get this error:

Do you know:
1) how to get the current ASMedia AHCI ROM on the mother board ?
2) why this error ?

Regards

#57 RE: Qestion to x106 performance by Fernando 11.05.2014 16:48

avatar

Zitat von 100PIER im Beitrag #56
Do you know:
1) how to get the current ASMedia AHCI ROM on the mother board ?
2) why this error ?
1) I managed it to get the ASMedia AHCI ROM v0.954 into the BIOS of my ASUS P8Z77-V by using the Aptio UEFI MMTool.
2) You should ask someone else, why you got this error, because I have never tried to flash the ASMedia AHCI ROM by using the 106SP1.EXE. AFAIK this tool is mainly designed for ASMedia AHCI Controllers, which are on a discrete PCI card.

#58 RE: Asmedia ASM-106x Sata 6G controller firmware 3.70 by pedilover 23.06.2014 13:47

on the side of station-drivers.com there is a new version of this firmware update : Asmedia ASM-106x Sata 6G Controller Firmware Version 3.70 .
If it could solve our problems when starting the os (win7 x64) ?

#59 RE: Asmedia ASM-106x Sata 6G controller firmware 3.70 by Fernando 23.06.2014 14:22

avatar

@ pedilover:
Welcome at Win-RAID Forum!
It is fine to see you here again (we know each other since several years).

Zitat von pedilover im Beitrag #58
on the side of station-drivers.com there is a new version of this firmware update : Asmedia ASM-106x Sata 6G Controller Firmware Version 3.70 .
If it could solve our problems when starting the os (win7 x64) ?
Please read >here<, what I have written yesterday about this ASMedia 106x SATA 6G Firmware/OROM.
I don't know, if it may solve your boot problem.

Greetings from the North Sea
Fernando

#60 RE: Asmedia ASM-106x Sata 6G controller firmware 3.70 by pedilover 23.06.2014 21:28

Hi Dieter,
thanks for the quick answer. May it depend of the used chipset ? Is the new oROM from Asmedia v.3.70 only designed for the newer ones ? You have Z77, I have Z87 and there is since a few weeks Z97.
I can not understand why Asmedia is not able to create a simple running firmware for this controller ?!
Regards
P.S.
See you in the new (and old) german winlite forum !
(http://www.win-lite.de/forum/?page=Portal)

Xobor Forum Software von Xobor
Datenschutz