#1 ami aptio 4 - no recovery mode by MaCXyLo 24.08.2016 01:42

Hey,
i tried to recover my Dell Vostro 3350 after the UEFI was bricked.
however, i tried a trick found on the dell board:

Zitat
Solution fo recovery bios Dell N5110

1. Download the latest firmware from the Dell support
2. Save the exe and create a shortcut with the following parameter: " /writehdrfile"
3. Start the created shortcut and it will create a n5110a11.hdr file rename the file to N5110.hdr
4. Create a shortcut exe file with the following parameter: " /writeromfile"
5. Start the created shortcut and it will create a n5110a11.rom file rename the file to DQ15A11.rom
6. Copy both file "N5110.hdr" and "DQ15A11.rom" to a FAT formatted pendrive's root folder
7. Remove the charger and Battery from the laptop
8. Plug In the pendrive
9. Press & hold END
10. Connect the charger (still hold END)
11. The notebook starts automatically and shows the recovery screen
12. Press enter and wait until finish the flashing
13. Press esc to restart
14. Hopefully problem solved


http://en.community.dell.com/support-for...3518/t/19534608

Hold end and connect the charger will start my notebook.
but the bios wouldn't be read from my usb device.
i formatted it with the tool rufus. fat32, mbr, active partition.
i tried also different names e.g. dn13a10.rom (suggested by Andy P's SLIC tool) or dn13a10.hdr, 3350.hdr, 3350.rom, whatever.
didn't work.
Which module is responsible for this sort of recovery?
Any idea why it doesn't work on this device?
My UEFI: http://www.dell.com/support/home/gh/en/g...?driverId=99FC7

i flashed the sop8 chip manually with my spi flash device.
it's working again.
but i want to prevent future errors - so i hope some someone can give me a hint.
have no desire to unscrew the hole device till the last screw again.

Kind Regards,
MaCXyLo

#2 RE: ami aptio 4 - no recovery mode by MaCXyLo 27.08.2016 11:21

ah i see, it's the recovery module in Volume 02.
i opened it in the hex editor:
the name of the recovery rom seems to be 3350.hdr or DN13A10.rom.
however, there is nothing shown on the screen if i follow the recovery procedure.
In the same file the El Torito specification is mentioned...
maybe that's the right way.

#3 RE: ami aptio 4 - no recovery mode by MaCXyLo 04.09.2016 23:08

you can extract the recovery module in the boot block partition (02) of the UEFI module.
open it up with your hex editor, you will find the names for the rom or hdr file there.

first of all, disconnect the cd-rom and harddrive phsyically from your notebook.
warning: the connector for the harddrive is a little bit fragile ->
pull on the right and left foots to open it up.
now pull the ribbon cable out.
if you are unsure, you can use this owner guide from the dell website.

format a usb stick with RUFUS.

Select first the USB stick you want to format.
Warning: All data on this USB stick will be lost.
Use MBR partition scheme for BIOS or UEFI, FAT32 (Default), Cluster Size 8192 bytes (Default).
The volume label doesn't matter.
Set a tick at quick format.
Untick "Create a bootable disk using..."
Untick "Create a extended label and icon files"

Download the UEFI version that was at last on your notebook.
if it was version A07, then download A07.
if it was version A10, then download A10.

Extract from 3350A10.exe / 3350A07.exe the UEFI file.
Open up a cmd and enter the following command: 3350A10.exe /writehdrfile
Rename the rom file to 3350.hdr and move it on the usb stick.

Disconnect the battery from your notebook.
Plug In the pendrive.
Press the end key and hold it down.
Connect the charger (still hold END).
The notebook starts automatically and shows the recovery screen.
Press enter and wait until finish the flashing.
Press any key to restart.
The first restart attempt wouldn't be successful.
The second one would work.
Give it a little bit time between the start attempts.

Xobor Forum Software von Xobor
Datenschutz