Page 6 of 16
#76 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by xkronusx 09.03.2018 02:38

CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.2 mod v6.1a (2018-03-04)

This version causes issues with the way AMD is reporting in Radeon settings.

https://snag.gy/MuoNVA.jpg

This bug shows with the AGESA updated versions. Also causes issues with loading some games, Fortnite hangs system on loads. Some system stability odds and ends as well, not sure if it's to do with USB, SATA or Audio latency causing the issue.

I've got everything updated as far as it goes, USB firmware from your first post, AMD sata controller to 1.3.1.277 from this forum signed.

Tried looking into it with latencymon, looks like the network adapter on the board causes the highest execution, but the ISR count is the highest with HDAudBus and storport. So I'm leaning towards an issue with either the sata controller or Realtek causing issues with performance.

Windows 10 build 16299

Cheers

#77 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 09.03.2018 04:15

avatar

Thanks for the report.

I will look into that this week-end to see if i can observe the same memory glitch in my AMD video card.

As far as latency goes, you may try to switch to the 1.3.1.276 driver to see if it help. I was the one who provided the v1.3.1.277 driver for testing in this forum (extracted from an HP driver pack) and, even if i use it myself without problem, there was one report from someone saying that he was getting a lot of latency in latencymon with this driver. This seems to have stopped as soon as he put back the Micosoft version. I tried to test it myself with Latencymon but i had no problem with the v277 driver so i kept it running on my system ever since. I admit i was using the Bios with agesa v1.5.0.0 at that time and i didn't test that again since but i doubt that problem had any relation to the bios because chances are this guy had a completely different motherboard and bios. You can read his report here.

The v1.3.1.277 is a driver made for HP for their servers so, in theory, it is optimised for that. And this also means, again in theory, that it may sometimes not be as much compatible and get along well with as many other devices in a system as the v1.3.1.276. So you may want to try that one to see if at least your latency problem go away.

As for the network adapter, it is normal because it is almost always the device with the most latency on any PC. This is the same results on all the PC i own. Of course, i am only talking about enough latency to get listed first in a PC. But if it is in first position by a crazy amount compared to the other devices, then there is a problem.

#78 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by FuMingZhou 09.03.2018 06:14

hey thank you so much for your V10 version i had received my samsung evo 960 and windows couldt install on it, i looked up to redownload the V9 version to reflash the bios to see if it works, and i saw that you update it to V10 with newer nvme support that is fantastic cause i have succed on installing windows on m.2, the only down side is the crosshair only has PCIE 2.0 and even on AHCI my speed is cut to half the predicted m.2 speed. but it still 3 times faster than a ssd so thank you very much that makes me very much happy thanks alot

#79 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by xkronusx 09.03.2018 23:55

CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.2 mod v6.1a (2018-03-04)

Was giving me crashes playing Overwatch for about 10 minutes consistently, could not get through more than one match without a complete system freeze. I want to say it's because of a memory leak because the system locks up without a blue screen and must be hard reset.


Switched to

CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.0 mod v10 (2018-03-04)

Played 3 hours of Overwatch with zero crashes, also streamed so it looks like it's super stable. I've had 24 hour up time as well without any issues so it looks like there's something in the AGESA V1.5.0.2 mod that is causing issues.

LatencyMon is looking cleaner as well, more consistent execution time.

AMD sata controller 1.3.1.277 has been the most stable for me , 1.3.1.276 works well but doesn't seem to have the same performance benefits. I'll have to do some testing later to be certain but I've had better luck with 1.3.1.277.

Thanks again, I won't be upgrading my system till probably late this year so all these bios improvements and drivers go a long way. Glad to do any testing you need me to just let me know.

#80 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 11.03.2018 04:44

avatar

After many tests with AGESA 1.5.0.2 v6.1a and v6.1b, and also AGESA 1.5.0.7 v6 Hybrid, here are my results:

- All modified versions of the AGESA have these 2 bugs (AGESA 1.5.0.0 v10 is the only one working correctly):
1- Cool & Quiet not working.
2- System memory amount is wrongly reported in AMD Radeon settings.

I was expecting this problem to NOT be present in the v6.1b bios because it is the only one that had its AmiAgesaDxe module changed to match the AGESA v1.5.0.2. But it makes no difference.

I think that something is not compatible in the bios between either:

1- Any new AmdAgesaDxeDriver AGESA version with another unkown (yet) module that need to be updated to match the new version.
or...
2- Any new AmdProcessorInitPeim AGESA version with another unkown (yet) module that need to be updated to match the new version.

For now, i don't know which module is responsible for the Cool'n'Quiet management. If i can somehow find which one is, then i may try to update that module to match the new AGESA.

Those are all only theories for now...

I will have to do some deep thinking and probably do many tests to try to pinpoint the problem.

#81 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Net7 11.03.2018 05:35

avatar

I keep seeing the post where The Stilt mentioned AGESA v1.5.0.8, sadly, cannot find that anywhere else, maybe he miss-typed (and he doesnt respond to PM's on either site he mentioned it), otherwise its such a shame that its so difficult to update the AMD "microcode", sadly my 8350 system I used to play with bricky type things has a few issues supposedly fixed by a newer AGESA but of course, ASRock has no plans to update any of those BIOS's :D

Thanks for all the testing Phoenix48, this may be for an ASUS board, but it pretty much applies to all that I have seen

#82 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by 108 11.03.2018 17:40

I am sorry to be a bother, but I've looked through this whole thread and can't seem to figure out where to go to download these BIOS mod(s). So dumb question: Where do you go to download them?

Also, can you please direct me the the latest stable release (that doesn't have any more problems than the final official ASUS release from 2012 had)? Thanks a TON! I'm trying to get my system up aon running on one of these newfangled 960 EVOs. :-)

And a HUGE 'THANK YOU' to the maker of this mod, Phoenix 48. You absolutely RULE!!! You're the only person - in this world of 73 BILLION people - who's done it. That's awesome!


** UPDATE **

DOH! I found them. :-) Somehow, I didn't find the links at first. So Version 10 it will be! Wish me luck!!!

#83 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 02.04.2018 21:54

avatar

BIOS with AGESA v1.5.0.0 updated to v11

Changelog:

[Changed] - NvmExpressDxE_3 -----> NvmExpressDxe_Small


Changes in NvmExpressDxe_Small (see this thread for more details):

- Based on UDK2017 NvmExpressDxe
- Includes bug fixes from UDK2018
- Removed functionality not present in UDK2014 (not supported by AMI Aptio 4 either)
- Removed component name protocol support (useful for debugging only)
- Removed driver unload support (not used outside of the EFI Shell)
- Bug fixes and improvements preserved
- Refactored for smaller code

#84 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by xkronusx 05.04.2018 05:40

Had some issues with >CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.0 mod v11 any overclock would cause a crash in the latest windows 10, fresh install. Seems to be linked to memory timings, still crashes under any heavy loads. Multiple programs running / moving a lot of files all at once.

There's a weird stability issue with Amd Sata controller v1.3.1.276 and v1.3.1.277 will freeze the system under any crystaldisk random load.

Moved back to >CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.0 mod v10 as it seems to be the most stable, not a single DPC Watchdog Violation blue screen since moving back to this version. The sata controller is still giving issues. Currently working around this by using the Asmedia port for the boot drive and putting the AMD ports in RAID mode forcing the RAID driver to be used. This makes it the most stable for the time being, run 24 hours with no serious issues.

Thanks for the hard work, your bios mods have kept my machine and my friends machines running stable. :)

*edit not using NVME, test system is an 860 evo sata, two plextor sata drives and a western digital sata drive*

#85 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 05.04.2018 07:12

avatar

@xkronusx

Thanks for the feedback.

Unfortunately, i don't know what to say about an overclock crash with the v11 because, as written in the changelog in post #83, only the nvme module was changed since v10 and nothing else, and this has no reasons that i can see to affect the overclock. Is your system using nvme? I will try to make some test with the overclock in the week end on my system to see if i can reproduce this and find anything.

@everyone else
Please report if you have the same problem or not with v11.

Also, to those who use their system with nvme, please report if you see an increase in boot speed/performance with the new nvme module or not.

#86 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 07.04.2018 22:51

avatar

I tried to reproduce the overclock crash but, up to date, i was not able. My system is stable with v11. Unfortunately, i don't have a nvme disk so i can't test that part to see if it would make a difference.

#87 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by xkronusx 15.04.2018 17:33

Sorry took a while to figure out what the issue was, wanted to make sure I figured it out for sure before posting again.

It's my buddies machine and it looks like it was a bad SSD causing the crashes, we were running a more complex setup with a raid 0 of two plextor 256GB drives that had been working properly since they were installed
but it looks like one of the drives is failing, pulling it out of the raid and setting them single we found the one drive was having writing errors with anything to do in small randoms and reads, not great but it happens to
a drive that's 5 plus years at this point.

Sorry for the confusion, I haven't done much more testing in v11 but at the very least we figured out it was a bad drive.

Cheers.

#88 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 06.05.2018 00:04

avatar

BIOS with AGESA v1.5.0.0 updated to v12

Changelog:

[Changed] - CPU microcode cpu00600F12_ver0600063D_2013-03-06_0E64F5CB -----> cpu00600F12_ver0600063E_2018-02-07_8187EA3E

[Changed] - CPU microcode cpu00600F20_ver0600084F_2016-01-25_C8460314 -----> cpu00600F20_ver06000852_2018-02-06_893C1544

#89 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by 108 13.05.2018 11:32

The MD5 (16) and the SHA256 (64) hashes match, but the WHIRLPOOL (64) does not. Have tried downloading multiple times with the same result: WHIRLPOOL (64) is mismatched. (This is using both the SecurityXploded tool you used and other online tools for hashing the file.)

Could you please be so kind as to re-hash the file using WHIRLPOOL and update your results, notifying if there is any change to your result or not?


Thank you!

p.s. The WHIRLPOOL hash I am getting every time is:

aa10d214fb066a0d713941b30a34c9064c248ef95ded6080d83c6044a23f12f2351356274effe0f81a45bf2302a08b4b8b0117d7d07831be167dbf788e7f535e

#90 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 14.05.2018 12:17

avatar

Here are my results:

WHIRLPOOL (64) -
aa2614a941290664ac2b08791c79ebf5d6f04bcd2e36e2d60675d795296757ad15831b5260f7e1368c0db4ddfdb9a89e793532afb662436bcea27cac51988c59 (From my original file on my PC and listed in HashList.txt)
aa2614a941290664ac2b08791c79ebf5d6f04bcd2e36e2d60675d795296757ad15831b5260f7e1368c0db4ddfdb9a89e793532afb662436bcea27cac51988c59 (Recheck of the original file on my PC with HashGenerator)
aa2614a941290664ac2b08791c79ebf5d6f04bcd2e36e2d60675d795296757ad15831b5260f7e1368c0db4ddfdb9a89e793532afb662436bcea27cac51988c59 (Check from a download of the file from the server)
aa10d214fb066a0d713941b30a34c9064c248ef95ded6080d83c6044a23f12f2351356274effe0f81a45bf2302a08b4b8b0117d7d07831be167dbf788e7f535e (Your reported result in the last post for easy comparison)

Usually i would say there was a problem in your download but you already said you downloaded it multiple times with the same results. So the way i see it, only one thing remains as a possibility: The program you use to unzip it is maybe doing something wrong and changing something in the file while unziping it. Try with 7-Zip from 7-zip.org, this is what i use and my hash results are OK.

Xobor Forum Software von Xobor
Datenschutz