Page 4 of 16
#46 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by pershoot 05.02.2018 18:56

hi.

are the new bios files flash-tested just to ensure it posts? what is the difference between 6a and 6b? thank you.

#47 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 05.02.2018 21:50

avatar

@pershoot

Very good question...

No they are not tested yet. Here is the long and detailed answer:

The goal is to make a true integration of the AGESA v1.5.0.2. Almost always, people don't make a true integration because they change only the module AmdAgesaDxeDriver. It is what i had done in the previous versions up to v5 included. I changed the AmiAgesaDxe too sometimes but never had any confirmation if that was a good thing or not even if both seemed to work but further test is needed on that point to know if it is the cause to the oveclock not working or not. Back with that last part later...

Now back with the integration story, it was not a true one up to v5. Proof of that is the agesa version is reporting differently if you use the old versions of UBU 1.69.10 and 1.69.10.2. (newer versions don't report Agesa version at all) The version 1.69.10 gets his version report by looking in the module AmdAgesaDxeDriver and will report 1.5.0.2 for the v5 bios. But UBU v1.69.10.2 will still report agesa as v1.5.0.0. Why? Because the agesa is almost always integrated in more than one module in a Bios. In the case of the Formula Bios, it still report v1.5.0.0 because UBU changed his way of finding the version number and is looking instead in the AmdProcessorInitPeim module (where all the AMD microcodes are) to get the agesa version number. The fact that there is a version number for the agesa in this module is proof that it is also a main part of an agesa version as a whole. Different version number in the 2 modules is the proof that the integration was not truly and completely achieved.

In BOTH v6a AND v6b, i try to make a true integration by doing this:

1- AmdAgesaDxeDriver is changed to v1.5.0.2 (the main AGESA driver itself)
2- AmdProcessorInitPeim is changed to v1.5.0.2 (The inititialisation of the processor with the microcodes inside it)

The difference between v6a and v6b is this:

Bios v6a: AmiAgesaDxe not changed
Bios v6b: AmiAgesaDxe changed

Why do this? Because of the old overclock problem i mentioned earlier. It is still not clear up to date if it was caused by the fact that the integration was not complete (in that case, the AmiAgesaDxe probably don't matter) OR by the AmiAgesaDxe that was changed or not changed (Not clear yet which match is better if it is the problem). The AmiAgesaDxe doesn't include a version number in it but both version are made differently. I suspect that one version will still have the overclock problem and the other will not. In the event that both are working perfectly without any bug, then i will change it to match the version 1.5.0.2. One thing to look closely with the v6b is if the amount of memory is still reported correctly because this module is supposed to be the one reporting it or at least it is related to this. I know that, on other motherboard, some people have changed it without any problem and for some other motherboard, the amount of memory was not reported correctly (in rare case, not at all) after the change (bug). But maybe it was because their integration was not a true one, hard to tell... But again, i suspect that it will report the memory correctly because it is not the first time i make that change in the bios. But i guess it is not completely impossible that the true integration make the memory bug appears for the first time with v6b but i doubt it.

Here are the results i expect:

Scenario 1: v6a is perfect but v6b has overclock bug. That should mean that the main interaction of AmiAgesaDxe within the bios is with the rest of the bios but is still related to the agesa and should not be changed. It must match the bios.

Scenario 2: v6a has overclock bug but v6b is perfect. That should mean that the main interaction of AmiAgesaDxe within the bios is with the agesa but is still related to the rest of the bios and should be changed. It must match the agesa version.

Scenario 3: Both v6a and v6b are working perfectly. That should mean that the main interaction of AmiAgesaDxe within the bios is with the rest of the bios but is still related to the agesa but this module is working rather independently and could be changed if possible (if no new bugs are created). It is probably better to match the agesa version if possible but not absolutely required. It also mean that the incomplete integration was alone responsible for the overclock problem.

Hope this make things more clear about what i have done and why.

#48 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Ozi 08.02.2018 15:17

Phoenix48 -Thank you for the work!We will wait for new updates ... ..

#49 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by qpens8 21.02.2018 21:53

Hi,

Just checked my frimware version and I don't know what i have :D

#50 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by qpens8 21.02.2018 23:13

SOLVED

#51 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 25.02.2018 20:32

avatar

Status update:

Bios with true integration of AGESA v1.5.0.2 (v6a) is now tested for post. I am beta testing it and it seems to be working perfectly. No problem detected up to date. Please provide feedback if everything is working properly or not. See posts 1 and 47 for more details.

#52 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by FuMingZhou 26.02.2018 03:00

Hi there i have a small issue here. I read a lot of reply on this tread because i realy want to install a m.2 with adapter on my formlua, so i decided to give it a try since there is lot of positive feedback, i flashed to V9 but din't want to hassle with U2104_RCFG = ASM-1042 i noticed on the chip for me its the right one.
all tho after flashing i shut down the computer and wait 30 second after the boot my bios loaded in 5second right after pressing the power, then i realized my razer synapse (mouse app) loaded in 1sec (usualy it was taking about 20-30sec to load) and i noticed less input lag and the scroll wheel was not scrolling up and down (glitched scroll wheel) it was just right, so here is the issue i restarted the computer for a second time and now everything become like before flashing to V9 : input lag, scroll wheel glitch and bios load less fast. I realy dont know if some one out there knows why i have this issue, i supose that phoenix is good at modding a bios but im not sure if some one can help me with my issue or if its normal. My system is FX8350 with crosshair V formula(no Z spec), i have flashed my bios to last good bios before trying V9, i have 16gb ram, i also reset the bios before and after flashing, anyways those are my personal feedback if its possible to have some help it will be appreciated, i realy like the modded bios by the way great work. oh and i dint try putting a m.2 yet, but i will.

#53 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 26.02.2018 08:57

avatar

@FuMingZhou

First, thanks for your feedback.

There may be many different things that could affect all the things you are describing, some directly and others indirectly. Here is the list of all the possible problems and comments i can think of:

- Be sure the bios v9 you got didn't get corrupted during the download process or by the writing process on your disk. It is very rare but it still can happen. You can use a program to verify the reported hash of the bios to be sure it was not corrupted. The v9 bios itself must have a MD5 hash of 5efe6bd10a1a46410d67801f62fc822b.

- If your USB mouse if plugged in a USB 3.0 port (blue), it is controlled by the ASMedia chipset and not the BIOS directly so the problem is probably because your ASM-1042 is not updated yet. There was a lot of glitches with the original one with ASM-1042. The new firmware in the first post fix all that.

- If your USB mouse is in a USB 2.0 port (black), i didn't made any modification in the bios that is influencing the mouse or any USB ports. USB 2.0 ports are managed by the AMD SB950 controller.

- It is obvious but i must say it: Be sure your mouse driver is the right one and the latest. Some mouse also have their own chip and need a firmware update for the chip that is in the mouse to correct some bugs. I suggest you verify that on the Razer website.

- If your USB mouse is plugged in a USB 3.0 port (blue), its behavior is also influenced by the ASMedia USB 3.0 driver and the ASMedia USB root hub driver. The latest version you should have for both of those driver is v1.16.50.1 that you can find in the driver section of this forum.

- This last one is very rare but it can still happen: With some bad luck, a flash may just be incomplete and still be reported as done right by the flash updater. You usually realise that by noticing some old references (like old versions that should not exist anymore) in the bios or simply some old behaviors that you didn't expect to still have after the flash. It usually mean that the flashing process left some old files behind and didn't update them. The solution is simply to reflash the new program on top of it again. That usually fix it if that was the problem. If your mouse is plugged in a USB 3.0 port and you already flashed the new ASM-1042 firmware, it may be a good idea to reflash it again on top of it to be sure it is not the problem.

#54 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by FuMingZhou 01.03.2018 16:39

hi so im not using software to mod bios or what not but i would like to know wich software i can use to see the hash on the bios file.
Also i tried to verify ASM 1042 USB3.0 using HxD Editor and found that i have downloaded the right one ASM-1042, but din't know how to look up if the installed one is right,
anyways i looked it up on the chip its self located near the IO and the cpu so im thinking of giving it a try flashing it.
I had the mouse on usb 3.0 and put it to usb 2.0, now the scoll wheel dosent go funny when i scroll and if it was doing that on usb3.0 its not because of the mod, since it was doing it before.
I am realy noob at electronics and micro circuit even after making a am/fm radio curcuit board, so i can't tell if my razer naga 2014 has built in chip and firmware
all i know its that it has a software to load profiles and that app takes a while to load on windows 10 pro startup.

before flashing the mod i had a bigger bios screen with more text and now its just shows the basics, i noticed that, and for AHCI i thot the bios would load quicker but its more over the os i suppose.
By the way i just bought a Samsung 960 EVO M.2 250GB online with a NVME compatible pcie adapter, so as soon as i receive the package i'll give my feedback about loading windows 10 pro on m.2 but right now ill update my usb3.0
I realy apreciate the modders out there, i was even able to mod my vape rx300 today with a modded firmware i think its just cool.

#55 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 01.03.2018 21:27

avatar

@FuMingZhou

Thanks for the feedback.

First, you can use Hash generator to see the hash of a file.

Second, it seems obvious to me that your biggest problem right now is your USB 3.0 ports. So let's start there. Because it is still not clear for me if you already flashed your ASM-1042 or not then i will assume you haven't. Here is what you need to do step by step:

- Unplug everything that is in a USB 3.0 port (blue ports in front and back of the PC).
- Download the ASM-1042 firmware on the first post.
1- Create a DOS bootable USB. (You can use Rufus for this if you don't have one already)
2- Copy the uncompressed folder to your bootable USB. Reboot into your USB (by pressing F8 at startup) and go into your folder.
3- Type 104xfwdl.exe /C to verify that your current version is working properly. (This ensure the current firmware and chipset has no big problems to begin with)
4- Type 104xfwdl.exe /D to know what version is currently installed.
5- Type 104xfwdl.exe /A to make a backup of your current firmware in case something goes wrong.
This created a file named DE0_0232.BIN. Go back in Windows and look into it with HxD Editor to be sure it is the right model for you. It should be U2104_RCFG
If it is OK, reboot again into your USB.
6- Type 104xfwdl.exe /U to do the update with the new firmware version. (Do a last check to be sure there is no device pluged in your USB 3.0 ports before doing this)
7- Type 104xfwdl.exe /D to verify that the new version is installed.
8- Type 104xfwdl.exe /C to verify that the new version is working properly. If something go wrong with this verification then you may need to do "104xfwdl.exe /u" again.
9- Reboot and plug in your USB 3.0 devices.
- Done!

Third, as for your Razer Naga 2014, the latest Synapse software and driver is v1.18.21 and you can download it here. If there is a firmware to update too, the Synapse software will tell you.

And finally, i didn't make any change in the text, options or the way the bios is showing in the screen. If you got only the basics in your bios, it must be because, after the update, your bios reverted back to the "basic view" option instead of the "Advanced view" option. You can change this option in the bios and chose the display you wish. This option is in one of the 2 tabs to the right of the screen when you are in "advanced" mode. I don't remember where it is in the basic view but, well... Since it is "Basic" view, it shouldn't be too hard to find. :) I would look where it is exactly but i am not near that PC right now. Just look for an "Advanced view" option. Set it. Save and reboot and enter the bios again. Done.

#56 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by FuMingZhou 01.03.2018 21:31

hey i try to update my usb3.0 driver-ASM using my flash drive and i can't find something to format it in dos , i also try to boot my usb key with the folder in it and nothing happens there that little line that flash white with the rest of the screen pitch black but nothing load, i try sdelete from microsoft to format in dos but the program wont work on my computer it says vista or higher, im not sure what work around i can use to update my ASM 1042 some help would be appreciated if that is possible , thanks.

#57 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 01.03.2018 21:40

avatar

@FuMingZhou

A bootable DOS is not included with the firmware. You must use a software like Rufus to create a bootable USB key before putting the firmware on it. Once it is done, you have to press the F8 key at startup to choose your USB key to boot on it.

#58 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by k3rn31pan1c 03.03.2018 16:58

avatar

Hello, I flashed CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.0 mod v9 and I cant seem to get the bios to recognize a samsung 960 pro using a SYBA M.2 PCI-e To PCI-e 3.0 x4 Card Model SI-PEX40110. I've tested it on other motherboards and they recognize the ssd / adapter combo. I have the adapter installed in the bottom, pcie 4x slot. Im looking in boot priorities and all i can see is my sandisk usb. Any help would be greatly appreciated :)

#59 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 04.03.2018 03:01

avatar

@k3rn31pan1c

Unfortunately, i am very limited in how much i can help you on that subject because i don't have a pci-e disk myself and never tested it personally. All i know is that i was asked if i could add this fonctionnality and i did it, and it was reported to be working by some other users. But i can try to point you in the right directions:

- You can try to look into this thread in the forum about your issue and ask there if other users had any problems with your specific disk model. The NvmExpressDxE_3 module is responsible for the detection of the a pci-e disk.

- You can try to contact other members here who reported having sucessfully installed their disk and ask them how they precisely did it.

- In a last resort, you can try to replace the NvmExpressDxE_3 module in the bios by the older NvmExpressDxE_2 to see if this help to detect your disk.

- I also once read somewhere that for some motherboard (i don't know about this one), the detection of a pci-e drive only worked after the ASMedia SATA controller was turned off in the bios. Like i said, i don't know if this apply to the Crosshair V Formula or not but it may be worth a try.

- I also found this: "The UEFI does not list the SSD if it's empty. You need to install Windows in UEFI Mode, then UEFI will show you the Windows Boot Manager as boot option." So if your disk is empty, this may be your problem.

#60 RE: [OFFER] Asus Crosshair V Formula 1703 mod BIOS by Phoenix48 04.03.2018 15:20

avatar

BIOS with AGESA v1.5.0.0 updated to v10 + BIOS with AGESA v1.5.0.2 updated to v6.1a and v6.1b

Changelog:

[Fixed] - The NvmExpressDxe_3 and SAMSUNG_M2_DXE modules are now located in the DXE driver section of the bios where they belong.

Xobor Forum Software von Xobor
Datenschutz