Page 1 of 2
#1 W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 17.08.2016 22:43

avatar

Hi everyone, hi Dieter,

First of all thank you very much for your great efforts towards this “such-an-helpful” forum !! It’s been a real goldmine for me as I had no clue why one of my machines (a raided one) wouldn’t take the W10 upgrade (after 1st reboot the screen displays the blue W10 logo with the circle spinning round and round for ages with absolutely no activity into the tower // back in W7 : error 0XC190010 – 0x20017 reported by the upgrade utility launched by Microsoft’s official “MediaCreationTool.exe”). After exhausting and endless researches, I finally found some answers on your forum, managed to understand what’s happening and find out what to do next. However, it still scares me a lot and I would like your advice to make sure I’m going to do the things properly.

Here’s a full detailed overview of my configuration (I’m not a gamer, I’m a professional designer, that’s why I need such a “beast”) : http://www.driverscloud.com/fr/publish/c...0716-1-1/resume

The RAID 0 configuration is quite complex and was built by the manufacturer (as that config is working perfectly well, I kept it as is) : 2 WD Velociraptors RAIDED-0 in one volume and then partitioned in 2. C: for system and D: for Desktop. I use to store my working files directly on my windows desktop, thus I moved all the “library linked files” initially contained into my C:\Users\Joolaï (=my user account) to a directory I created : D:\User_Joolaï\. Besides, I also have a 1To E: drive for data (= creative ressources + archives) and another 1To F: drive for Windows Image Backups I manually perform once or twice a year + Windows Restoration ISO.

For information, here’s a short history of the major problems I came accross on this machine since I bought it in 2010 :
1. I had to de-activate Restauration Points in “Advanced System Protection” because when I first used the PC in 2010, some files related to some Restauration Point had corrupted some disk sectors on my C:\ partition (within 1 week of use) and I had to make a clean install of W7 in order to fix that. I never could find the reason of this incident, Microsoft never answered the questions I addressed them so just to make sure this never happens again, I always deactivate the protection on all disks on all my machines and I make do without any restauration point. I manually perform the Windows Image Backup utilitary instead, but not that often.
2. The only other issue I experienced with that PC was the mobo battery which was empty. Finding out the reasons of the bsods that this problem was causing was a real pain in the neck and it took me 1 year to fix it (I first accused the cpu, the ram, the mobo, the drivers, the boot sequence where I might have done some bad trying to repair something which was in fact fine…) but I ended up resolving the problem (probably with some dirty left-behinds…).
3. And now my current difficulty of upgrading from W7 home premium to w10 pro (I have purchased an activation number).
4. Very last little thing : I have an unsolvable problem with one of my dlls reported as “cannot repair” in the CBS.log file generated when I run SFC (Microsoft.PowerShell.GPowerShell.dll). I managed to take it from another computer running the same W7 version and where the dll was “clean” and to replace it in the machine I’m talking about (let’s call it G7). But it didn’t change anything.

Back to my W10 issue, I upgraded all the drivers I could prior to my upgrading attempts, except “Microsoft Intel(R) ICH10 Family USB Universal Host Controller - 3A35” which wouldn’t install by itself and which messes up everything when forcing install. I just leave it as is, it keeps working no matter how old the installed driver is (2006) !

Now, here’s what I came to understand, step by step :
- When trying to upgrade from W7, W10 setup ruins my RAID controller driver & configuration and is unable to find the volume C:\ to boot on after 1st reboot.
- The latest Intel RST driver is not optimized at all for my configuration (Intel X58 ICH10R).
- I may encounter severe problems trying to revert back to the right driver (Intel RST v11.2.0.1006 WHQL).
- Nevertheless, there’s still a way I could upgrade to W10 :
o Booting on a USB where W10pro setup has been deployed and try to do a fresh install
o There, I should have the ability to load Intel RST v11.2.0.1006 driver (saved on another USB) when the setup askes where to install, and W10 will retrieve the volumes (which I find cool).
o Yet, I read tons of horrors, things not going well concerning Intel X58 / RAID 0 / W10. I also read your piece of advice (Fernando) : “The safest way to get the Intel RST driver v11.2.0.1006 properly running with Win10 from scratch is to remove the Win10 in-box RAID driver v13.2.0.1022 from the Win10 image and to insert the desired Intel RST driver into the Win10 image” which doesn’t really please me because it sounds just like the hacks and custom roms jailbreakers apply to their iPhones. But I see your point and I really trust you. So I’m currently preparing myself to do that and follow your "Integration of Drivers (incl. AHCI/RAID) by using NTLite" tutorial. I must confess I would rather just do it the conventional way with “load driver” but as I want to secure the process as much as I can, I feel like I have no choice.

I still have fears and questions. To sum up :
- From what I've read, I didn’t see anything firmly asserting that it's strictly impossible to install W10 on an Intel X58/ICH10R system with a “raided-0” C:\ partition. But on the other hand, I didn’t read anything explicitly confirming I safely could. And My PC is not listed by Acer as a Win10 eligible model (http://www.acer.com/ac/fr/FR/content/win...eligible-models). So should I try anyway ? Is there any chance that the process I’m planning to implement fails ? What are the risks I run in case of failure ?
- In case the W10 manages to install, do you think this process will result in something as stable as my current W7 config or am I stupidly putting myself at risk with an odd system ?
- Do you have any additional piece of advice, warning or words of encouragement to give me before I jump ahead ?
- In this useful article : http://www.tenforums.com/tutorials/1950-...an-install.html, the following is stated : "If you want to have (recommended) the 450 MB (UEFI-GPT) or 500 MB (Legacy BIOS-MBR) System Reserved partition in addition to the Windows C: partition on a HDD or SSD after installation, then you would need to make sure that all partitions on the drive have been deleted until it is only unallocated space. Next, select the unallocated drive to install Windows on. If there are no partitions on the disk, you will get the System Reserved partition". Which means additionnal difficulties for me... But I got it. Now having regard of my RAIDED volume, which process am I supposed to follow in order to recreate a D: partition (next to C:\) once SetUp is over ? Would Windows integrated disk management utility do the job or do I have to do it with RST or Diskpart cmd or any other more suitable solution ?

Many many thanks for your help. Let me also address you hundreds of thanks for your great job and for your concern towards all the problems you helped to solve.

Regards
Julie

#2 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Fernando 18.08.2016 02:05

avatar

@Joolaï:
Hello Julie,
welcome at Win-RAID Forum!

According to what you have written you obviously want to do a fresh install of Win10 v1607 ("Anniversary Update") onto your already existing RAID0 array by using the Intel RST driver v11.2.0.1006.
Exactly this is what I recommend to do and I am pretty sure, that you will succeed and be satisfied by the performance of your RAID0 system. As you already know, the safest way is to remove the Win10 in-box Intel RAID driver v13.2.0.1022 from the Win10 v1607 image and to insert the Intel RST RAID driver v11.2.0.1006 instead. Nevertheless you can try to boot off the original Win10 image and simply load the Intel RST driver v11.2.0.1006 after you have deleted all currently existing partitions of your RAID0 array.

Zitat von Joolaï im Beitrag #1
In case the W10 manages to install, do you think this process will result in something as stable as my current W7 config?
Yes, I am very optimistic regarding this point.

Zitat
Do you have any additional piece of advice, warning or words of encouragement to give me before I jump ahead ?

As long as you are using your current system, you should never replace the Intel RAID driver v11.2.0.1006 by a newer one (neither yourself nor done by Windows Update).

Zitat
"If you want to have (recommended) the 450 MB (UEFI-GPT) or 500 MB (Legacy BIOS-MBR) System Reserved partition in addition to the Windows C: partition on a HDD or SSD after installation, then you would need to make sure that all partitions on the drive have been deleted until it is only unallocated space. Next, select the unallocated drive to install Windows on. If there are no partitions on the disk, you will get the System Reserved partition". Which means additionnal difficulties for me... But I got it. Now having regard of my RAIDED volume, which process am I supposed to follow in order to recreate a D: partition (next to C:\) once SetUp is over ? Would Windows integrated disk management utility do the job or do I have to do it with RST or Diskpart cmd or any other more suitable solution ?

The solution is very easy:
1. Do a backup of your important personal data, which are currently on your Drive C and D, and store it somewhere outside the RAID array.
2. Boot off the Windows 10 v1607 image.
3. When you come to the point, where the Setup has detected your current RAID0 partitions, delete them all (inclusive the small ones, which are listed with the same disk number).
4. If you don't have integrated the Intel RST driver v11.2.0.1006 into the Win10 image, you should hit the "Load driver" button, navigate to the stored driver and hit "OK".
5. Let Win10 Setup create the partition for your system drive (Drive C:). You can choose the size yourself.
6. Once the OS is up and running, you can create your Drive D: from within the Win10 Disk Management. It is very easy.

Good luck!
Dieter (alias Fernando)

#3 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 18.08.2016 14:11

avatar

Hello guys !

@Fernando
Hallo Dieter :)

Thank you so much for your care & answers. I'm feeling ready now ;) and I'll try it the safe way : replacing RST driver directly in W10 image. I'll let you know how it goes.

I just have one more question. When you say :

Zitat
As long as you are using your current system, you should never replace the Intel RAID driver v11.2.0.1006 by a newer one (neither yourself nor done by Windows Update).


Does that mean that Windows Update is going to try and update my RST driver without my knowledge or consent ? How could I make sure this never happens ? W10 Updates seems all locked on the configuration side and not as easily tweakable as in previous releases of Windows OS :(

Thx :)

#4 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Fernando 18.08.2016 15:27

avatar

Zitat von Joolaï im Beitrag #3
How could I make sure this never happens ? W10 Updates seems all locked on the configuration side and not as easily tweakable as in previous releases of Windows OS :(
There are several ways to prevent the automatic update of drivers done by Windows Update while running Win10 "Anniversary Update".
This is probably the easiest:
1. Right-click onto window on the most left side of the taskbar and choose "System".
2. Hit onto "Advanced System Settings".
3. Choose the tab "Hardware" and hit onto the button "Device Installation Settings".
4. Choose the option "No (your device may not work as expected)" and then "Save Changes"

That's all!

#5 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 18.08.2016 19:09

avatar

Hi again Fernando !

I have downloaded both Intel RST v11.2.0.1006 drivers and drivers + software whql packages from the links you provide on your tutorial. I've understood I only need the drivers package to do my new W10 image, but once installed, shall I use the full installer in order to get Intel RST application back again ?

Thx :)

#6 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Fernando 18.08.2016 21:04

avatar

Zitat von Joolaï im Beitrag #5
once installed, shall I use the full installer in order to get Intel RST application back again ?:)
Yes, you will need the RST Software to enable the write-back caching feature. This will boost your WRITE performance.

#7 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 19.08.2016 00:50

avatar

@Fernando : Ok thanks a lot for that piece of info :

Zitat
Yes, you will need the RST Software to enable the write-back caching feature. This will boost your WRITE performance.



I'm currently working on the NTLite img. It told me it was missing JMB36X driver (among others, but that one sounds important). I downloaded the latest version I found and added it to the image (just like for intel rst).

Is it all right or have I done bad ?

#8 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Kbird 19.08.2016 03:49

Nope Julie , that is correct I did exactly what you are doing ......following Fernando's Tutorial to intergrate the Drivers for my X58 Gigabyte Board too .

Nlite , looks at the Drivers for the Board currently running in Windows and then askes you to intergrate them as well as the Intel 11.2 Driver , eg the Jmicron Driver JMB36X and the NEC/Renesas USB3 etc ( i used the drivers found for Win 7x64 from the MB Manufacturer's Site ) and thankfully all has been well since.

Don't forget to remove the 13.xx.xx driver from the Nlite ISO too.

#9 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 19.08.2016 04:06

avatar

Cool :) thx @Kbird !

Intel RST 13.xx removed from install & from boot and replaced with the v11.2.0.1006 + JMB36x added the same way !

I just hope I haven't forgotten to add other critical drivers...

#10 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Kbird 19.08.2016 04:14

Most of the others like USB3 can be done later , the critical ones are the Drivers controlling HDD/SSD/DVD etc during the Win10 install.

So intel ICH10R and maybe the JMicron Driver if you have something attached/ its in use , my GB MB also has a GB Sata Driver too

#11 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 20.08.2016 00:06

avatar

Awesome :D
It just worked perfectly. Brand new W10x64 Pro running like a charm on a clean drive !
Anniversary Update came with the setup as my version was 1607 when I first rebooted, no need to do a post-install upgrade.

I'd be pleased to add some contribution based on my personal experience, here are few additional useful tricks :

- In NTLite, if "Intel Corporation | iastorav.inf" componants checkbox is grayed-out and uncheckable, because it is something like "locked by compatibility / Host machine", then you will have to click on the "Compatibility" Button in NTLite toolbar and then Uncheck "Host Machine" in "Machine Support" section. Click OK and back in the "Removing Componants" interface, you'll be able to uncheck whatever was locked by Host Machine Compatibility.



- Even if you have a Legacy BIOS (not UEFI), you'll need to disable "QuickBoot" in your Advanced BIOS Features in order to be able to boot on your W10 setup USB key. Otherwise, you may only be able to "restore W7" or whatever your current system is.

I would just have a last question : As you suggested @Fernando , I managed to disable "Advanced System Settings > Hardware > Device Installation Settings" ; but after installing Intel RST Software v11.2.0.1006 ;) I expected to find something in the settings of the application which would let met prevent it from updating itself as well as the drivers, but nope ! Have I missed something ? Is there something to do to secure this part too ?

Thank you very much @Fernando : I followed your tutorials and pieces of advice, and the result is a total success :) This forum is a goldmine ! |addpics|a2t-2-c3c1.png-invaddpicsinvv,a2t-3-deb4.png-invaddpicsinvv,a2t-4-64b6.png-invaddpicsinvv|/addpics|

#12 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Fernando 20.08.2016 01:05

avatar

Zitat von Joolaï im Beitrag #11
As you suggested @Fernando , I managed to disable "Advanced System Settings > Hardware > Device Installation Settings" ; but after installing Intel RST Software v11.2.0.1006 ;) I expected to find something in the settings of the application which would let met prevent it from updating itself as well as the drivers, but nope ! Have I missed something ? Is there something to do to secure this part too ?
The Intel RST Software will never update itself and you shouldn't do it as well.

#13 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 20.08.2016 14:51

avatar

Hi guys, Hi @Fernando :)

This morning I've been manually updating my drivers. Something puzzles me. Despite the fact that I deactivated auto download and install for drivers in Advanced Settings like you told me, I have a notification from Windows "Security & Maintenance Center" telling that one or more device need some additional softwares to run properly".



Do you think it refers to Intel RST driver or to another driver I didn't install correctly ? I don't dare to click on the "install" button... And the Device Manager is fine, it only reported a problem with my LCD-Screen driver which I could solve quickly, but that didn't have any effect on the message reported in the "Security & Maintenance Center", even after having rebooted. How can I find out which device is causing that issue ? Do you have any idea of what to do into that case ?

Thanks a lot in adv :)|addpics|a2t-1-8450.png-invaddpicsinvv|/addpics|

#14 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Fernando 20.08.2016 15:16

avatar

Zitat von Joolaï im Beitrag #13
I have a notification from Windows "Security & Maintenance Center" telling that one or more device need some additional softwares to run properly".
Did you already install the Intel RST Drivers & Software Set v11.2.0.1006? I yes, did you install .NET Framework 3.5 from within the Control Panel before?
Note: The Microsoft .NET Framework 3.5 is absolutely required for a proper function of the Intel RST Console and the RST Service.

#15 RE: W10 setup with IntelX58/ICH10R chipset & RAIDED-0 volume partitionned for C:\ (system) + D:\ by Joolaï 20.08.2016 15:44

avatar

Zitat von Fernando im Beitrag #14
Did you already install the Intel RST Drivers & Software Set v11.2.0.1006?

Yes, I did. This is one of the first things I did after W10 setup. And the version is still the good one (11.2.0.1006) - just checked 1mn ago ;)


Zitat von Fernando im Beitrag #14
I yes, did you install .NET Framework 3.5 from within the Control Panel before?

Well nope :s But Intel RST setup told me it was required and asked if I wanted to add it to the setup. There I answered YES !
Here what it looks in my "Turn Windows features on/off" settings... Existing but kind of unchecked. What do you suggest I should do ?


Cheers :)
|addpics|a2t-5-517a.png-invaddpicsinvv,a2t-6-b6f6.png-invaddpicsinvv|/addpics|

Xobor Forum Software von Xobor
Datenschutz